Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Complete mess with Microsoft Mouse/XP sp3


  • Please log in to reply
2 replies to this topic

#1 cvcooper

cvcooper

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:01:22 PM

Posted 28 February 2011 - 03:06 PM

Ok so start off on this computer I am running a P4 2.4ghz XP SP3. I recently did a lot of the funkyworms rec's and scaled down services etc to 24 processes. Everything was fine and I doubt that is part of the problem but thought I'd mention it because maybe I changed something I was not supposed to.

I am using a MS Wireless Laser Mouse 5000. It was working just fine but I noticed the scrolling was slow and the side magnifier wasn't working, no big but I use those a lot so I checked out msconfig, ipoint was enable. I also re-enabled defender to see if I had somehow disable it, nothing there. I also scrolled through services.msc to see if anything in their about plug-n-play was disable or anything relating to the mouse/microsoft intellipoint was disable but didn't find anything.

So this is where it begins. I decided to go to the MS site and install Intellipoint 8.1 and correctly selected my mouse/OS/etc. Near the end of the install something came up saying I don't have a certain system file "mouhid.sys" I noticed in my Windows\driverscache\i386 I didn't have the drivers.cab file but sp3.cab. Well I copied the drivers.cab file into it from my original XP sp1 disc. Still didn't change anything

To keep this post from going on forever I have erased and reinstalled my original 5.5 intellipoint disc, searched for drivers automatically and manually in device manager, tried different usb ports, removed the mouse and plugged back into various usb ports always getting the "there was a problem with your hardware install etc" message. What's strange is I can't re-create the missing system file message when installing 8.1 for whatever reason.

Anyway I spent about 5 hours on it (I'm stubborn I know) and all I know is that my laser mouse worked like a charm, then I tried installing Intellipoint 8.1 and it completely tanked the mouse. I have also tried (from hours of google search) disabling services/boot.ini etc in msconfig and restarting to no avail. I have done all the obvious things like new batteries etc. I have a light on the usb transmitter and it lights up but rarely connects with the mouse but sometimes it does, either way the pointer just sits in the middle of the screen

One more thing. It no longer list my mouse correctly in device manager under the Mouse section. The crappy ps/2 shows but it keeps saying MS optical mouse 1.0 under human interface devices. I disable/remove/update driver/remove driver and every possibly thing and restart to no avail. I have also always erased the previous intellipoint install before installing a new one, and also tried just removing all together and seeing if some default drivers on xp could run the mouse. I also tried to get the wireless mouse to work with the plugin mouse and without it as well to see if I couldn't run both at the same time.

I also did a sfc scan with my older disc but was told that wouldn't work with my sp1 disc b/c I am running sp3 so I'm currently downloading a sp3 recovery disc. Unfortunately I disable system restore, not sure if that would of done anything anyway.


Any ideas or suggestions would be much appreciated.

EDIT: FWIW I just unplugged my optical mouse from my vista laptop and plugged in my laser mouse and it worked right away. I noticed the drivers for the optical were in Windows/system32/drivers/ and point32k.sys, mouhid.sys and mouclass.sys

When I plugged in my laser mouse it just showed mouhid.sys and mouclass.sys.

Edited by cvcooper, 28 February 2011 - 03:41 PM.


BC AdBot (Login to Remove)

 


#2 MrBruce1959

MrBruce1959

    My cat Oreo


  • BC Advisor
  • 6,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:01:22 PM

Posted 28 February 2011 - 11:46 PM

I also did a sfc scan with my older disc but was told that wouldn't work with my sp1 disc b/c I am running sp3 so I'm currently downloading a sp3 recovery disc.


If you use the ISO image of Windows XP SP3 from the Microsoft download site, you should be able to extract the files and get everything working right again.

This is the link to download the .ISO image for Windows XP SP3

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2fcde6ce-b5fb-4488-8c50-fe22559d164e

Please read the information from this web site.

I need a mouhid.sys file/driver, my mouse support is not working

http://answers.microsoft.com/en-us/windows/forum/windows_xp-hardware/i-need-a-mouhidsys-filedriver-my-mouse-support-is/76931cef-51cb-48c1-96e2-c7f9ea5a7c76

Good luck and keep us informed.

Bruce.

Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
 
My Career Involves 45 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:


#3 cvcooper

cvcooper
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:01:22 PM

Posted 01 March 2011 - 01:07 PM

Tried this last night to no avail. I downloaded the iso but there was no option for recovery for I downloaded just a recovery .iso which did not work either. I recently followed some instructions and reduced services from services.msc to slim down the computer. I can't see anything on that screen that would indicate I messed something up.

What is strange is I have 8 usb ports on my dell 8250. Some I plug into work, and some don't (as in the light coming on on the usb mouse receiver). I tried using windows install clean up as well. Now when I try to install intellipoint is either says an unexpected error has occurred or that it can't install because a newer version exist. I have erased from add/remove and the actual file itself so I don't know.

Like I said in the OP, mouse has worked fine for years. Now that I decided to attempt to install 8.1 intellipoint, get the message about mouhid.sys (which I have), and my mouse has yet to ever work again. I will say I took it to my vista laptop, plugged it right in and it worked instantly so no problems there. I followed your instructions on getting mouhid back but to no avail. Thanks for any additional input.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users