Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

F8 key not working to boot to Safe Mode!


  • Please log in to reply
2 replies to this topic

#1 busarider29

busarider29

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:11:48 AM

Posted 19 February 2011 - 01:38 AM

Okay, from the beginning: found out tonight that I've got some malware on my machine. When in Windows, I get all sorts of little pop-up messages and such. I can't access anything as far as running programs. I can access Administrative Tools but can't open anything in there - tried to open something such as "Services" and nothing happens. So, I figure I'll boot into safe mode and run a couple scanners and clean things up. The machine does its initial thing and I got the black screen with channel info and such and the prompts at the bottom : Press F8 to Enable System Configuration, Press F9 to Select Booting Device after POST, press F1 to continue, DEL to enter SETUP. Okay, F8 and F9 don't do anything. Obviously I need F8 to get into safe mode. F1 works and continues to boot up Windows. DEL works and takes me to SETUP. So, problems with F8 and F9.

The keyboard is a USB keyboard. I've plugged it into all of the USB ports directly on the motherboard (no hubs). I've tried changing the keyboard. I don't have access to a PS2 keyboard or I would try that. Here is also something strange is that while in SETUP, the F9 key works. I don't think there are any menus or options in SETUP to allow me to use the F8 key to see if it too works in SETUP.

Is there some sort of setting or something that I can access from here to allow me to get into safe mode another way or a setting that may be preventing my F8 key from working?? Maybe something in SETUP that I can change to get the F8 key to work??

Any help much appreciated.

Windows XP Pro

BC AdBot (Login to Remove)

 


#2 busarider29

busarider29
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:11:48 AM

Posted 19 February 2011 - 02:24 AM

Issue resolved!

I noticed, well I've noticed for a while that it shows an error for the floppy drive during the boot sequence. Something to the extent that it couldn't read the floppy (floppy is broke) and then it stops its boot sequence there with the F8, F9, F1, and DEL prompts at the bottom of the screen like normal. Well, I've never thought anything of it in the past and just hit the F1 key to "continue" and allow Windows to boot.

Well, something was telling me that maybe when it was checking the floppy disk and erroring, that maybe that was causing a hiccup in allowing the machine to allow F8 selection. Went into SETUP (DEL key) and disabled the check of the floppy drive and removed the floppy from the boot sequence. This allowed the machine to continue its initial sequence of booting up with no stopping because of errors and allowed the selection of F8, hence getting to Safe Mode. Wierd, because even though it was always stopping its boot sequence because of the faulty floppy drive, the F1 key worked as well as the DEL key, just not F9 or F8.

Edited by busarider29, 19 February 2011 - 02:27 AM.


#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,107 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:11:48 AM

Posted 19 February 2011 - 11:42 AM

Thanks for posting your self-resolution, happy computing :).

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users