Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Combofix and Autoplay


  • Please log in to reply
3 replies to this topic

#1 billgateslovesapple

billgateslovesapple

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:52 AM

Posted 15 February 2011 - 09:29 AM

Hi there,

This is my first post on this forum, so hello to all.

Last week, as part of a virus removal, I was advised by Webroot support to run Combofix on my system.

Thankfully it removed the problem, but since running Combofix, autoplay has been disabled on all of my USB drives, audio CDs do not play automatically, and the scanner and camera wizard no longer runs when I plug in my USB digital camera.

I must add, that everything was running fine before Combofix did its stuff.

Before posting this, I did a lot of research, and it seems I am not alone with this problem.

I am now fully aware that Combofix disables these functions by design, and I also fully understand the reasons why it does so.

I also fully understand that there are alternative methods of accessing data on all of the above mentioned devices, and have done so successfully.

However, the reason for my post is to ask whether or not it is possible to have the CHOICE as to whether or not autoplay runs on my computer, and if so, how?

As I said, I am fully aware of the fact that online threats are getting totally out of control, especially when you consider that the virus we caught last week was the result of my wife trying to found out how to make a TEAPOT!!!

But I would still like the choice of whether autoplay runs or not on my system.

Thank you in advance for any help or advice you could give me.

I am running Windows XP SP3 Home Edition

Edited by billgateslovesapple, 15 February 2011 - 09:37 AM.


BC AdBot (Login to Remove)

 


#2 Blade

Blade

    Strong in the Bleepforce


  • Site Admin
  • 12,702 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US
  • Local time:12:52 PM

Posted 15 February 2011 - 01:00 PM

Hello.

We can re-enable Autoplay if that is what you wish.

Please note that the following information is specific to your Operating System.

A suggestion has been made that involves modifying the registry. Modifying the registry can be dangerous (and can render your system unbootable) so it's advisable that you make a backup of the registry before proceeding.
Modification of the registry can be EXTREMELY dangerous if you do not know exactly what you are doing so follow the steps that are listed below EXACTLY. if you cannot perform some of these steps or if you have ANY questions please ask BEFORE proceeding.

Download ERUNT from Derfisch or MVPS and save it to your desktop.

Please follow Step 4 onwards of the Installing & Using ERUNT guide to back up your registry. Skip Step 19 for now.

***************************************************

Please open a Notepad file: (From the Start Menu, click Run and type notepad in the window that appears.)
  • Copy the contents of the below code box into the notepad window.
  • Save the file as fixit.reg on your desktop: (Important! make sure you change the "Save As Type" to "All Files")
    REGEDIT4
    
    [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDriveAutoRun"=dword:00000149
    "NoDriveTypeAutoRun"=dword:00000000
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    "NoDriveAutoRun"=dword:00000149
    "NoDriveTypeAutoRun"=dword:00000000
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]
    "AutoRun"=dword:00000001
    
  • Close the notepad window and click on the fixit.reg file on your Desktop.

That should restore your Autoplay to it's working state.

~Blade

Posted Image

If I am helping you, it has been 48 hours since your last post, and I have yet to reply to your topic, please send me a PM
Become a BleepingComputer fan: Facebook
Follow us on Twitter!
Circle us on Google+


#3 billgateslovesapple

billgateslovesapple
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:52 AM

Posted 15 February 2011 - 05:19 PM

Hi Blade,

Thank you very much for your prompt reply.

I have followed your advice and autoplay is now working perfectly on all of my devices.

Now all I have to do is sneakily disable internet browsing whenever my wife uses the computer, and I will have no more problems..... :whistle:

Thank you for all of your help.

#4 Blade

Blade

    Strong in the Bleepforce


  • Site Admin
  • 12,702 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US
  • Local time:12:52 PM

Posted 15 February 2011 - 09:36 PM

Glad I could help!

Posted Image

If I am helping you, it has been 48 hours since your last post, and I have yet to reply to your topic, please send me a PM
Become a BleepingComputer fan: Facebook
Follow us on Twitter!
Circle us on Google+





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users