Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WIN7 keep shutting down my wireless adapter?


  • Please log in to reply
15 replies to this topic

#1 acoustic5679

acoustic5679

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:05:21 AM

Posted 13 February 2011 - 12:31 PM

Hi Guys,

I have been having this problem with windows 7. A lot of the time windows 7 shuts off my wireless belkin adapter for my wifi. I check in power settings and under the wireless adapter settings I have choose a setting of maximum performance. But if I leave the computer for a while it seems to shut it off which is really anoying when I want to leave stuff downloading overnight. Any Ideas?

BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,614 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:21 AM

Posted 13 February 2011 - 12:43 PM

I know you said you checked the Power Options settings, but please confirm you've also done this:

Go to: Network & Sharing Center
Click on: Change Adapter Settings
Right-Click on Wireless Adapter & choose Properties
Click on the Configure button
Click on the Power Management Tab
Uncheck "Allow the computer to turn off this device to save power"

"Okay" your way out.

Edited by Allan, 13 February 2011 - 12:44 PM.


#3 acoustic5679

acoustic5679
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:05:21 AM

Posted 13 February 2011 - 12:55 PM

I have tried that and there is no tab for power management under my belkin wireless adpter. IT has general, advanced, details, and driver. Under advanced though it has an option under advanced called power saving options where you can choose CAM (constantlyy awake mode) I have this set to ON and I still see this problem.

#4 Allan

Allan

  • BC Advisor
  • 8,614 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:21 AM

Posted 13 February 2011 - 12:59 PM

Okay. It was worth a shot. I've got to believe the issue lies somewhere in power options though.

#5 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:21 AM

Posted 13 February 2011 - 01:36 PM

Alan was on to something.

Is this by chance a USB connected adapter? Am unfamiliar with most Belkin products. Without out a specific model number to look at I can only guess.

#6 acoustic5679

acoustic5679
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:05:21 AM

Posted 13 February 2011 - 01:41 PM

I found a setting for the USB to be shut off. I think that was my problem considering this wireless adpapter is plugged into USB

#7 acoustic5679

acoustic5679
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:05:21 AM

Posted 13 February 2011 - 01:42 PM

We must have posted that at the same time =)

#8 Allan

Allan

  • BC Advisor
  • 8,614 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:06:21 AM

Posted 13 February 2011 - 01:49 PM

Alan was on to something.

Is this by chance a USB connected adapter? Am unfamiliar with most Belkin products. Without out a specific model number to look at I can only guess.


Good catch. I made the mistake of assuming it was an internal adapter.

#9 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:21 AM

Posted 13 February 2011 - 02:16 PM

Once in a while a even a blind squirrel finds a nut.

@ acoustic5679. Hope we got your problem solved.

It is`t an uncommon one and go`s back to XP. For what ever reason MS just does not now how to tell when a device is in use and needs to be kept on.

#10 caperjac

caperjac

  • Members
  • 1,649 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NS. CAN
  • Local time:07:21 AM

Posted 13 February 2011 - 04:48 PM

I found a setting for the USB to be shut off. I think that was my problem considering this wireless adpapter is plugged into USB

interesting ,can i ask where you found that setting ,thanks

My answers are my opinion only,usually


#11 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:21 AM

Posted 13 February 2011 - 04:55 PM

interesting ,can i ask where you found that setting ,thanks


Device Manager > expand the + next to Universal Serial Bus comtrollers > right click on each USB Root Hub > Properties > Power Management tab.

There are other devices that have this feature as well. Most integrated Network adapters both wired and wireless have it.

I believe there are a few others but they slip my mind at the moment.

#12 caperjac

caperjac

  • Members
  • 1,649 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NS. CAN
  • Local time:07:21 AM

Posted 13 February 2011 - 05:04 PM

thanks

My answers are my opinion only,usually


#13 acoustic5679

acoustic5679
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:05:21 AM

Posted 13 February 2011 - 05:04 PM

So I am still having the problem. All power managment options under every USB root hub has the allow windows to turn off box unchecked. I am clueless as to know what else it could be. I have the power managment settings set never turn off for just about everything. This is also happening when I am working in windows too so its not happening when I leave the PC alone for a while.

#14 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:21 AM

Posted 13 February 2011 - 05:10 PM

What program are you using to manage the wireless connection?

Windows or the one possibly included with the device?

Have you checked the Belkin site for an updated driver?

#15 acoustic5679

acoustic5679
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:05:21 AM

Posted 13 February 2011 - 05:39 PM

OK, so hopefully I figured it out. I installed a different driver and now I have the power options tab under device manager/properties. Windows 7 was installing the correct driver for the device I have, but the version of the model I have doesn't support Windows 7 for the driver. I installed a driver that did have win7 support, but had a different version number then my adapter and now it seems to be staying on. Maybe because the the power options were not included in the old driver software, win7 was defaulting to putting it to sleep with no way of turning it off. I will hope so. Thanks everyone!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users