Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BEX error on iexplore.exe


  • Please log in to reply
2 replies to this topic

#1 F.L.Y.

F.L.Y.

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:48 PM

Posted 13 February 2011 - 12:32 AM

My OS is win7 64-bit, I can't open IE(32-bit)but can open the 64-bit edition .The following is the problem signature(It always shows up when I open IE(32-bit))
Problem signature:
Problem Event Name: BEX
Application Name: iexplore.exe
Application Version: 9.0.7930.16406
Application Timestamp: 4c7e0414
Fault Module Name: 0201160103.dat_unloaded
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 4d218242
Exception Offset: 030da034
Exception Code: c0000005
Exception Data: 00000008
OS Version: 6.1.7600.2.0.0.256.1
Locale ID: 20527
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Can anyone help with a reason & possible solution?

Edited by F.L.Y., 13 February 2011 - 12:38 AM.


BC AdBot (Login to Remove)

 


#2 Zuhl3156

Zuhl3156

  • Members
  • 309 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bensalem, Pa.
  • Local time:11:48 AM

Posted 13 February 2011 - 06:20 AM

This should help resolve the BEX error:
http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/f0361624-5348-4d5e-b704-a22c62500d06
The DEP problem is related to 'Data Execution Prevention' and should be set to 'Turn on for Windows only'. I remember where someone had it set to 'All Programs' and that setting caused his problems.
http://windows.microsoft.com/en-US/windows-vista/Data-Execution-Prevention-frequently-asked-questions
I received the email alert before you deleted the DEP part from your post. You should edit the 'DEP' part back in, it might be related and help with diagnosis if these links don't fix IE8 for you.

Edited by Zuhl3156, 13 February 2011 - 06:23 AM.


#3 ender2003

ender2003

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:48 AM

Posted 21 July 2011 - 06:56 PM

Today my manager and I were on-site in the bustling town of Stamford, TX (go ahead, find it on a map, I dare you) and ran into a very irritating computer issue. We were trying to get a base image ready so we could burn it to 6 other PCs to speed up the install process because the bank's internet connection is so slow for downloading updates. We had gotten all the updates installed and tested a couple of applications to find that Internet Explorer 8 did not work. Even stranger, it was only the 32-bit version of IE that did not work, 64-bit worked just fine. When we opened 32-bit IE, it would try to pull up the page (google, microsoft, msn, anything) and might show part of it, then would freeze and go to a "page not available" error that would state DEP had closed the program. There would also be an error pop-up about a BEX error with a faulting module of StackHash.

Before anyone asks, our applications are not compatible with IE9 yet, so we could not upgrade to that. We ran through the normal troubleshooting of checking firewalls, IP addresses, connection to the network, etc. Everything came back normal but 32-bit IE8 was still broken. Googling the error message had us disable DEP, reset IE to default settings, open with no add-ons, registering DLL files, and a hundred other things. Basically, every site we found with that error had a different fix and none of them worked.

We finally decided it was an update that screwed us, so we restored back to yesterday afternoon before the updates and everything worked fine. Playing russian roulette with the updates, we installed groups of them (we had almost 30 total) until we broke the system, then backed it out and cut that group in half. We finally determined that the update that caused so much trouble was a Windows Update driver for an ATI Firepro v3800 video card.

Why in the blue blazes would a video driver break 32-bit Internet Explorer but leave the 64-bit version operational?

Just wanted to throw this out there in case anyone runs into a similar issue and to remind people of the importance of thorough troubleshooting. All told, it took us the better part of 4 hours to troubleshoot this (each recovery took about 45 minutes).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users