Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Norton setting for WS_FTP usage


  • Please log in to reply
3 replies to this topic

#1 bytes

bytes

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:01:46 PM

Posted 09 February 2011 - 09:42 AM

System info:

Windows XP Professional
Norton Internet security (ie. including firewall)
WS-FRP LE (1999-2000) - file transfer program

Years ago I was able to use WS-FTP to upload pages & images onto the WWW with no problem.

I haven't had to use it for a while though, and I went in the other day to log in to upload an image and I couldn't log into the WS_FTP pgm. It just stayed motionless, trying to connect for minutes and minutes until I just cancelled and tried again etc.

I'm thinking that it can't get through the firewall because I've probably got a new Norton product or at least some upgrades that have changed any system setup that was letting it work previously.

I've tried looking through the Norton help files but can't see anything.
I've tried calling their help line, but the only time I can call is in the evenings when they have all their help-line calls diverted to countries like India where the techo's can't speak good english and can't understand what I'm saying.

So .... does anybody know how I can change the firewall settings in Norton to let me be able to send files out-of-my-computer to get them online?

ANY help would be really appreciated .....

Thanks

BC AdBot (Login to Remove)

 


#2 Blathnat

Blathnat

  • Members
  • 224 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Canada
  • Local time:02:46 PM

Posted 09 February 2011 - 10:30 AM

Have you tried disabling the firewall to see if that is what is blocking your connection? Are there any advisories in History>firewall activities or intrusion prevention that show as blocked?

#3 Didier Stevens

Didier Stevens

  • BC Advisor
  • 2,706 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:46 PM

Posted 09 February 2011 - 02:29 PM

It sounds like you have an issue with active mode FTP.

FTP works with 2 ports: 20 and 21.
Port 21 is used to establish the control channel: the client (WS_FTP) connects to the FTP server on port 21.
Port 20 is used to establish the data channel. In active mode, the FTP server connects back to the client (you). This connection is probably blocked by your firewall.
In passive mode, it's the client that connects to the server to establish the data channel.

In stead of opening port 20 on your firewall to allow active mode FTP, I suggest you try to instruct WS_FTP to use passive mode FTP. I don't know how you configure WS_FTP to use passive mode, that is something you need to figure out.

Didier Stevens
http://blog.DidierStevens.com
http://DidierStevensLabs.com

SANS ISC Senior Handler
Microsoft MVP 2011-2016 Consumer Security, Windows Insider MVP 2016-2019
MVP_Horizontal_BlueOnly.png

 

If you send me messages, per Bleeping Computer's Forum policy, I will not engage in a conversation, but try to answer your question in the relevant forum post. If you don't want this, don't send me messages.

 

Stevens' law: "As an online security discussion grows longer, the probability of a reference to BadUSB approaches 1.0"


#4 bytes

bytes
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:01:46 PM

Posted 10 February 2011 - 05:19 AM

Thanks for both the replies - I had the setting on Port 20 already so that's not the problem ..... and I totally disabled everything on Norton and it didn't work either .....

...... so obviously a problem with WS_FTP ..... the problem is that it used to work and now it doesn't. I'll have to do some more hunting around.

thanks again




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users