Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Something silently opening iexplore.exe and streaming audio (along with redirects)


  • This topic is locked This topic is locked
3 replies to this topic

#1 aa381

aa381

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:52 AM

Posted 30 January 2011 - 03:53 AM

I'm running Windows XP Service Pack 3. My computer has picked up something that opens Internet Explorer as one or more instances of iexplore.exe (I can see it in the Processes tab of Task Manager) and, if I leave the processes alone long enough, play audio in the background of my computer (without using Windows Media Player or other visible methods, including opening new Internet Explorer windows). The pages that the malware is using show up in Internet Explorer's history; I haven't opened up any of the entries myeself to verify that they're actually the source of the audio.

It also seems that the malware will try to redirect me if I go to sites such as this one. The redirect seems to work in most cases, but if I first go to Google's cache of the page and then click on links from there it seems to get past the malware. In the few days before this started happening I had noticed that occasionally if I opened up Google cached pages I got a white page talking about being redirected to the cached page. It also seems that using Google links directly to threads works.

Finally, there's also some computer slowdown (which I've noticed when using Internet Explorer and Malwarebytes, but maybe that's just a side effect of the above instead of actual direct action by the malware.

I have tried Malwarebytes and Clamwin (in my computer's normal and Safe Mode); they removed some other minor malware, but they can't seem to detect what's causing this. After spending time on Google looking for help I have also tried Sophos Anti-Rootkit (normal and Safe mode), ATF Cleaner (Safe mode only) and Bootkit Remover (normal mode only unless my memory is failing me). In normal mode, Sophos returned what looks like miscellenous cookies; in Safe mode, it said something about a function called memsweeper or similar not being available and then tried to continue its scan anyay. Bootkit Remover said something about a certain path not being available, and then said that my system looked normal. ATF Cleaner seemed to have removed the files it was supposed to remove, but that didn't stop the problem.

I have also (stupidly and arrogantly) tried to run ComboFix by myself. Here is what happened:

(1.) I downloaded ComboFix from this website without changing the application's name.
(2.) I tried to run ComboFix in normal mode. ComboFix loaded (it took a few minutes), and I got the Disclaimer of Warranty. (The message I got was somewhat different than the picture on your instructions; my message also had a short list of websites that I should not have downloaded ComboFix from.) I clicked yes to proceed.
(3.) After a short period, there was a message that said that a rootkit had been found in VolSnap.sys and that ComboFix would be taking action on it. I clicked yes.
(3.) ComboFix then proceeded to just sit there. There was that blue screen that was the size and shape of the command line window, but nothing happened. I didn't even get the "ComboFix is preparing to run" option. It was just blank.
(4.) At this point, I panicked and hit the manual reset.
(5.) The computer restarted, and I attempted to run ComboFix again in normal mode. Unfortunately, this now resulted in one of two things. Either the computer would restart right as the initial loading bar filled up, or the computer would just freeze (it wouldn't even respond to mouse input).
(6.) Sometime during event 5, I discovered a .txt file on my desktop labeled catchme (no uppercase). It said that Volsnap.sys had been replaced and then said something like "File list cleared."
(7.) I did manage to get ComboFix running in Safe Mode. It asked to install the Windows Recovery Console, and said that it needed an Internet connection. Unfortunately, Safe Mode did not have an Internet connection. I pressed no in the hopes that it would abort, but instead it kept going.
(8.) Eventually, ComboFix finished scanning and produced a log. Among the things it quarantined was something with "chrome" in its name. (I do not have Google Chrome or similarly named applications.)
(9.) I think at this point I began looking around Google more for more information ComboFix. Sometime during that I found something that said that leaving Combofix on your computer might result in unexpected changes, so I panicked more and tried to remove it. I eventually used OTC.exe. That removed ComboFix, the log it created, catchme.txt, and the folder with the quarantined files. If I'd been smarter I would have tried to save them so that you could take a look at them and tried to salvage something from that particular misstep.


The symptoms did not stop during all of this. Even in Safe mode, iexplore.exe would start up by itself.


As instructed in your preparation guide, I will copy and paste the contents of DDS.txt into the body of this post. I will also attach Attach.txt and ark.txt.

(I took a moment to look at DDS's list of running processes. I think that TblMouse.exe is my tablet driver, which I installed last Sunday. Unless I'm remembering incorrectly Edimax RaUI is part of my network connection. I had Notepad open because I was trying to copy links to threads around the Internet that might be useful.


DDS (Ver_10-12-12.02) - NTFSx86
Run by Kendrick at 22:41:53.43 on Sat 01/29/2011
Internet Explorer: 8.0.6001.18702
Microsoft Windows XP Professional 5.1.2600.3.1252.1.1033.18.446.124 [GMT -8:00]


============== Running Processes ===============

C:\WINDOWS\system32\svchost -k DcomLaunch
svchost.exe
C:\WINDOWS\System32\svchost.exe -k netsvcs
svchost.exe
svchost.exe
C:\WINDOWS\system32\spoolsv.exe
svchost.exe
C:\Program Files\Java\jre6\bin\jqs.exe
C:\WINDOWS\System32\nvsvc32.exe
C:\WINDOWS\system32\atwtusb.exe
C:\WINDOWS\Explorer.EXE
C:\WINDOWS\system32\wscntfy.exe
C:\WINDOWS\system32\atwtusb.exe
C:\WINDOWS\system32\RUNDLL32.EXE
C:\WINDOWS\RTHDCPL.EXE
C:\Program Files\Common Files\Java\Java Update\jusched.exe
C:\Program Files\ClamWin\bin\ClamTray.exe
C:\WINDOWS\system32\TblMouse.exe
C:\Program Files\Skype\Phone\Skype.exe
C:\WINDOWS\system32\ctfmon.exe
C:\WINDOWS\system32\ctfmon.exe
C:\Program Files\EDIMAX\Common\RaUI.exe
C:\Program Files\Microsoft Office\Office\FINDFAST.EXE
C:\WINDOWS\system32\NOTEPAD.EXE
C:\WINDOWS\system32\taskmgr.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Documents and Settings\Kendrick\Desktop\dds.scr

============== Pseudo HJT Report ===============

uStart Page = hxxp://www.google.com/
uInternet Settings,ProxyOverride = <local>
BHO: Adobe PDF Link Helper: {18df081c-e8ad-4283-a596-fa578c2ebdc3} - c:\program files\common files\adobe\acrobat\activex\AcroIEHelperShim.dll
BHO: Skype add-on (mastermind): {22bf413b-c6d2-4d91-82a9-a0f997ba588c} - c:\program files\skype\toolbars\internet explorer\SkypeIEPlugin.dll
BHO: {5C255C8A-E604-49b4-9D64-90988571CECB} - No File
BHO: Windows Live Sign-in Helper: {9030d464-4c02-4abf-8ecc-5164760863c6} - c:\program files\common files\microsoft shared\windows live\WindowsLiveLogin.dll
BHO: Java™ Plug-In 2 SSV Helper: {dbc80044-a445-435b-bc74-9c25c1c588a9} - c:\program files\java\jre6\bin\jp2ssv.dll
BHO: JQSIEStartDetectorImpl Class: {e7e6f031-17ce-4c07-bc86-eabfe594f69c} - c:\program files\java\jre6\lib\deploy\jqs\ie\jqs_plugin.dll
EB: {32683183-48a0-441b-a342-7c2a440a9478} - No File
uRun: [Skype] "c:\program files\skype\phone\Skype.exe" /nosplash /minimized
uRun: [ctfmon.exe] c:\windows\system32\ctfmon.exe
mRun: [NvCplDaemon] RUNDLL32.EXE c:\windows\system32\NvCpl.dll,NvStartup
mRun: [nwiz] nwiz.exe /install
mRun: [NvMediaCenter] RUNDLL32.EXE c:\windows\system32\NvMcTray.dll,NvTaskbarInit
mRun: [SkyTel] SkyTel.EXE
mRun: [RTHDCPL] RTHDCPL.EXE
mRun: [Adobe Reader Speed Launcher] "c:\program files\adobe\reader 9.0\reader\Reader_sl.exe"
mRun: [SunJavaUpdateSched] "c:\program files\common files\java\java update\jusched.exe"
mRun: [ClamWin] "c:\program files\clamwin\bin\ClamTray.exe" --logon
mRun: [TblMouse] TblMouse.exe
StartupFolder: c:\docume~1\kendrick\startm~1\programs\startup\micros~1.lnk - c:\program files\microsoft office\office\FINDFAST.EXE
StartupFolder: c:\docume~1\kendrick\startm~1\programs\startup\office~1.lnk - c:\program files\microsoft office\office\OSA.EXE
StartupFolder: c:\documents and settings\kendrick\start menu\programs\startup\PowerReg Scheduler.exe
StartupFolder: c:\docume~1\alluse~1\startm~1\programs\startup\wirele~1.lnk - c:\program files\edimax\common\RaUI.exe
IE: {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe
IE: {FB5F1910-F110-11d2-BB9E-00C04F795683} - c:\program files\messenger\msmsgs.exe
IE: {5067A26B-1337-4436-8AFE-EE169C2DA79F} - {77BF5300-1474-4EC7-9980-D32B190E9B07} - c:\program files\skype\toolbars\internet explorer\SkypeIEPlugin.dll
IE: {77BF5300-1474-4EC7-9980-D32B190E9B07} - {77BF5300-1474-4EC7-9980-D32B190E9B07} - c:\program files\skype\toolbars\internet explorer\SkypeIEPlugin.dll
DPF: DirectAnimation Java Classes - file://c:\windows\java\classes\dajava.cab
DPF: Microsoft XML Parser for Java - file://c:\windows\java\classes\xmldso.cab
DPF: {6414512B-B978-451D-A0D8-FCFDF33E833C} - hxxp://update.microsoft.com/windowsupdate/v6/V5Controls/en/x86/client/wuweb_site.cab?1261511786793
DPF: {8AD9C840-044E-11D1-B3E9-00805F499D93} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_21-windows-i586.cab
DPF: {CAFEEFAC-0016-0000-0021-ABCDEFFEDCBA} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_21-windows-i586.cab
DPF: {CAFEEFAC-FFFF-FFFF-FFFF-ABCDEFFEDCBA} - hxxp://java.sun.com/update/1.6.0/jinstall-1_6_0_21-windows-i586.cab
DPF: {E2883E8F-472F-4FB0-9522-AC9BF37916A7} - hxxp://platformdl.adobe.com/NOS/getPlusPlus/1.6/gp.cab
Handler: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - c:\progra~1\common~1\skype\SKYPE4~1.DLL

============= SERVICES / DRIVERS ===============

R1 SAVRKBootTasks;Boot Tasks Driver;c:\windows\system32\SAVRKBootTasks.sys [2011-1-29 18816]
R2 MLPTDR_Q;MLPTDR_Q;c:\windows\system32\MLPTDR_Q.SYS [2004-11-18 18848]
R2 WTService;WTService;c:\windows\system32\atwtusb.exe -s --> c:\windows\system32\atwtusb.exe -s [?]
S1 aiptektp;Pen Pad;c:\windows\system32\drivers\aiptektp.sys [2011-1-23 23168]
S3 MEMSWEEP2;MEMSWEEP2;\??\c:\windows\system32\10.tmp --> c:\windows\system32\10.tmp [?]

=============== Created Last 30 ================

2011-01-30 04:36:26 18816 ------w- c:\windows\system32\SAVRKBootTasks.sys
2011-01-29 22:11:22 6144 ------w- c:\windows\system32\3.tmp
2011-01-29 22:11:07 6144 ------w- c:\windows\system32\2.tmp
2011-01-29 20:54:03 -------- d-----w- c:\program files\Sophos
2011-01-28 08:19:56 0 ----a-w- c:\windows\Ehovikuwafo.bin
2011-01-24 06:09:47 -------- d-----w- c:\program files\Power Presenter RE
2011-01-24 06:07:16 348160 ----a-w- c:\windows\system32\msvcr71.dll
2011-01-24 06:07:16 1060864 ----a-w- c:\windows\system32\mfc71.dll
2011-01-24 06:07:15 -------- d-----w- c:\program files\Free Notes & Office Ink
2011-01-24 05:44:19 12160 -c--a-w- c:\windows\system32\dllcache\mouhid.sys
2011-01-24 05:44:19 12160 ----a-w- c:\windows\system32\drivers\mouhid.sys
2011-01-24 05:44:09 10368 -c--a-w- c:\windows\system32\dllcache\hidusb.sys
2011-01-24 05:44:09 10368 ----a-w- c:\windows\system32\drivers\hidusb.sys
2011-01-23 02:13:26 20992 ----a-r- c:\windows\system32\inetab32.dll
2011-01-21 06:31:11 83249512 ----a-w- c:\program files\common files\windows live\.cache\wlcF64D.tmp

==================== Find3M ====================

2010-11-18 18:12:44 81920 ----a-w- c:\windows\system32\isign32.dll
2010-11-09 14:52:35 249856 ----a-w- c:\windows\system32\odbc32.dll
2010-11-06 00:26:58 916480 ----a-w- c:\windows\system32\wininet.dll
2010-11-06 00:26:58 43520 ----a-w- c:\windows\system32\licmgr10.dll
2010-11-06 00:26:58 1469440 ------w- c:\windows\system32\inetcpl.cpl
2010-11-03 12:25:54 385024 ----a-w- c:\windows\system32\html.iec

============= FINISH: 22:48:22.31 ===============

Attached Files



BC AdBot (Login to Remove)

 


#2 gringo_pr

gringo_pr

    Bleepin Gringo


  • Malware Response Team
  • 136,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Puerto rico
  • Local time:11:52 AM

Posted 02 February 2011 - 07:22 PM

Hello and Welcome to the forums!

My name is Gringo and I'll be glad to help you with your computer problems.

Somethings to remember while we are working together.

  • Do not run any other tool untill instructed to do so!
  • Please Do not Attach logs or put in code boxes.
  • Tell me about any problems that have occurred during the fix.
  • Tell me of any other symptoms you may be having as these can help also.
  • Do not run anything while running a fix.


We apologize for the delay in responding to your request for help. Here at Bleeping Computer we get overwhelmed at times, and we are trying our best to keep up. Please note that your topic was not intentionally overlooked. Our mission is to help everyone in need, but sometimes it takes just a little longer to get to every request for help. No one is ignored here.

Click on the Watch Topic Button and select Immediate Notification and click on proceed, this will help you to get notified faster when I have replied and make the cleaning process faster.


In order for me to see the status of the infection I will need a new set of logs to start with.

Please print out or make a copy in notpad of any instructions given, as sometimes it is necessary to go offline and you will lose access to them.

DeFogger:

  • Please download DeFogger to your desktop.

    Double click DeFogger to run the tool.
  • The application window will appear
  • Click the Disable button to disable your CD Emulation drivers
  • Click Yes to continue
  • A 'Finished!' message will appear
  • Click OK
  • DeFogger may ask you to reboot the machine, if it does - click OK
Do not re-enable these drivers until otherwise instructed.

Download DDS:

  • Please download DDS by sUBs from one of the links below and save it to your desktop:

    Posted Image
    Download DDS and save it to your desktop

    Link1
    Link2
    Link3

    Please disable any anti-malware program that will block scripts from running before running DDS.

    • Double-Click on dds.scr and a command window will appear. This is normal.
    • Shortly after two logs will appear:
    • DDS.txt
    • Attach.txt
  • A window will open instructing you save & post the logs
  • Save the logs to a convenient place such as your desktop
  • Copy the contents of both logs & post in your next reply





Scan With RKUnHooker

  • Please Download Rootkit Unhooker Save it to your desktop.
  • Now double-click on RKUnhookerLE.exe to run it.
  • Click the Report tab, then click Scan.
  • Check (Tick) Drivers, Stealth,. Uncheck the rest. then Click OK.
  • Wait till the scanner has finished and then click File, Save Report.
  • Save the report somewhere where you can find it. Click Close.
Copy the entire contents of the report and paste it in a reply here.

Note** you may get this warning it is ok, just ignore

"Rootkit Unhooker has detected a parasite inside itself!
It is recommended to remove parasite, okay?"


"just click on Cancel, then Accept".


information and logs:

  • In your next post I need the following

  • .logs from DDS
  • log from RKUnHooker
  • let me know of any problems you may have had

Gringo

I Close My Topics If You Have Not Replied In 5 Days If You Will Be Longer Please Let Me Know

If I Have Not Replied To One Of My Topics In 48 Hrs Please Bump The Topic



My help is free, however, if you wish to make a small donation to show your appreciation or to help me continue the fight against Malware, then click here -->btn_donate_SM.gif<-- Don't worry every little bit helps.

Proud Graduate Of Malware Removal University

#3 gringo_pr

gringo_pr

    Bleepin Gringo


  • Malware Response Team
  • 136,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Puerto rico
  • Local time:11:52 AM

Posted 05 February 2011 - 01:50 AM

Hello

three day bump

It has been Three days since my last post.

  • do you still need help with this?
  • do you need more time?
  • are you having problems following my instructions?
  • if after 48hrs you have not replied to this thread then it will have to be closed!

Gringo
I Close My Topics If You Have Not Replied In 5 Days If You Will Be Longer Please Let Me Know

If I Have Not Replied To One Of My Topics In 48 Hrs Please Bump The Topic



My help is free, however, if you wish to make a small donation to show your appreciation or to help me continue the fight against Malware, then click here -->btn_donate_SM.gif<-- Don't worry every little bit helps.

Proud Graduate Of Malware Removal University

#4 gringo_pr

gringo_pr

    Bleepin Gringo


  • Malware Response Team
  • 136,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Puerto rico
  • Local time:11:52 AM

Posted 08 February 2011 - 02:47 AM

Due to the lack of feedback, this topic is now closed.In the event you still have problems, please send me or any Moderator a Private Message and ask them to reopen this topic within the next 5 days.
I Close My Topics If You Have Not Replied In 5 Days If You Will Be Longer Please Let Me Know

If I Have Not Replied To One Of My Topics In 48 Hrs Please Bump The Topic



My help is free, however, if you wish to make a small donation to show your appreciation or to help me continue the fight against Malware, then click here -->btn_donate_SM.gif<-- Don't worry every little bit helps.

Proud Graduate Of Malware Removal University




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users