Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Used Flash Disinfector to Protect Flashdrive, But


  • Please log in to reply
9 replies to this topic

#1 Torvald

Torvald

  • Members
  • 366 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:San Antonio, TX USA
  • Local time:04:53 PM

Posted 28 January 2011 - 10:38 PM

Hello,

I used Flash Disinfector about six months ago to help protect one of my flashdrives, but when I ran the program it also disabled the autorun process on the two DVD drives on my Windows XP Pro desktop.

Have put up with the inconvenience for long enough, and now would like to restore my computer's autorun ability, so that inserting a CD or DVD will automatically read and run the autorun files on my CDs and DVDs.

So far I've not been able to figure out how to fix this situation. Ran sfc /scannow, but that didn't work, and resetting the autoplay features didn't help either. Also ran a little batch file I found somewhere on the internet that was supposed to delete my existing autorun.inf files, but that also did not work.

Can someone please give me some advice as to what to try next?

Thanks.

Google is my friend. Make Google your friend too.


BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:02:53 PM

Posted 28 January 2011 - 11:28 PM

# Open Windows Explorer by pressing the Windows + "e" key.

# Right-click the desired CD-ROM and select Properties from the menu.

# Select the AutoPlay tab.

# Select each item from the pulldown list and for the Action to perform, pick the apporpriate action to take if enabling autorun.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:07:53 AM

Posted 29 January 2011 - 04:29 AM

@ dc3

That is not going to do what is required to enable autorun on the optical drives

@ Torvald

Have a look at the following Microsoft Support article:
How to disable the Autorun functionality in Windows

You can enable as well as disable ... using this info: "To disable or enable Autorun automatically, click the appropriate Fix this problem link."

There is a "Fix it for me" option which I suggest you use as the safest way to do the job.

Edited by AustrAlien, 29 January 2011 - 04:31 AM.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:02:53 PM

Posted 29 January 2011 - 09:29 AM

That is not going to do what is required to enable autorun on the optical drives


I found the instructions at a site where I've usually found good information. Didn't try these instructions, which I usually do, and you are correct, they won't enable or disable the optical autorun. :whistle:

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 Torvald

Torvald
  • Topic Starter

  • Members
  • 366 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:San Antonio, TX USA
  • Local time:04:53 PM

Posted 07 February 2011 - 07:38 PM

Hi guys,

Thanks for the advice on using the "Fix it for me" option, but that unfortunately did not work.

My optical drives are still unsuccessfully trying (but failing) to read the autorun.inf files on CDs and DVDs. The drives simply spin for awhile when a new disk in inserted, but then finally quit without loading or running any software.

Any more ideas on how to undo how flash disinfector is blocking the reading/running of autorun.inf files on my Windows XP Pro system?

Google is my friend. Make Google your friend too.


#6 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:07:53 AM

Posted 08 February 2011 - 03:46 AM

I would like to have a look at the relevant entries in the Windows registry.

:step1: Please export to text files, the contents of two registry keys:
  • Click Start > Run
  • Copy and paste the following line of code in the open Run box
regedit /e C:\reg1.txt "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer"
  • Now click OK
  • Click Start > Run
  • Copy and paste the following line of code in the open Run box
regedit /e C:\reg2.txt "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer"
  • Now click OK

:step2: Please post the contents of the two exported registry keys for us to look at:
  • Double-click/Open My Computer and then navigate to C:\ drive
  • In there, you should see two files called reg1.txt and reg2.txt.
  • Double-click one of the files to open it with Notepad.
    • Copy and paste the whole contents of that file in your next reply.
  • Repeat with the second text file, to include the contents of that file also in the same reply.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#7 Torvald

Torvald
  • Topic Starter

  • Members
  • 366 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:San Antonio, TX USA
  • Local time:04:53 PM

Posted 08 February 2011 - 07:52 PM

Here is the contents of reg1.txt:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"HonorAutoRunSetting"=dword:00000001
"NoRun"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\Run]



And here is the contents of reg2.txt:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000091
"NoBandCustomize"=dword:00000000
"NoMovingBands"=dword:00000000
"NoCloseDragDropBands"=dword:00000000
"NoSetTaskbar"=dword:00000000
"NoToolbarsOnTaskbar"=dword:00000000
"NoSaveSettings"=dword:00000000
"NoActiveDesktop"=dword:00000000
"ClassicShell"=dword:00000000
"NoDriveAutoRun"=hex:ff,ff,ff,ff

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer\run]

Google is my friend. Make Google your friend too.


#8 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:07:53 AM

Posted 09 February 2011 - 03:11 AM

The registry value causing your problem is the following one:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer
"NoDriveAutoRun"=hex:ff,ff,ff,ff

There are two registry values that can be used to persistently disable AutoRun: NoDriveAutoRun and NoDriveTypeAutoRun. The first value disables AutoRun for specified drive letters and the second disables AutoRun for a class of drives. If either of these values is set to disable AutoRun for a particular device, it will be disabled.

Source: Enabling and Disabling AutoRun

It is not necessary to have this entry in the above key of your registry at all, so I suggest that we delete it entirely by doing the following:

Please open Notepad and paste the contents of the code box below into the open window of a new text file.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\policies\Explorer]
"NoDriveAutoRun"=-

In the main menu of Notepad go to File > Save
  • In the "Save as type" box, choose "All files"
  • Enter the file name as delete.reg
  • Choose your desktop as the "Save in" location
  • Click on "Save".
Close the Notepad window.

On your desktop, locate the file that you just created delete.reg.
Double-click on the file.
When prompted "Are you sure ... ", click "Yes".

Restart the computer normally to ensure that the changes are made. <<< Important
When you now insert a CD or DVD with autorun capability, it should run.

*** Please be aware that having autorun enabled is now considered a security risk, and is discouraged.
If in any doubt about the disk that you are inserting, you can disable autorun by holding down the <SHIFT> key while inserting the disk, and continuing to hold it down until the optical drive has stopped attempting to read the disk.

Edited by AustrAlien, 09 February 2011 - 03:12 AM.

AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#9 Torvald

Torvald
  • Topic Starter

  • Members
  • 366 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:San Antonio, TX USA
  • Local time:04:53 PM

Posted 10 February 2011 - 09:48 PM

AustrAlien,

Thanks!!!!!!

That registry tweak has finally fixed my computer problem.

Google is my friend. Make Google your friend too.


#10 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:07:53 AM

Posted 10 February 2011 - 09:53 PM

My pleasure. Thanks for letting me know.

Take care and good luck.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users