Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Shared Printer Question


  • Please log in to reply
9 replies to this topic

#1 Delphi51

Delphi51

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:10 PM

Posted 23 January 2011 - 01:21 PM

A new HP color laserjet worked locally and on other computers in the house when first installed in November, 2010. A month later, it stopped working from other computers. The job appeared in the print queue on both the remote computer and the computer with the printer attached via USB. A few minutes later, the job disappeared as if printing was successful. The data light on the printer never blinked.

The Microsoft troubleshooter program that pops up at http://support.microsoft.com/kb/314073 (requires XP service pack 3 and dot.net) suggested setting that printer as the default printer on the remote computer. Very much to my surprise, that solved the problem! I see another person with the same experience writing at http://www.eggheadcafe.com/software/aspnet/31395309/network-printer-only-prints-if-set-as-default-printer.aspx.

I would sure like to know another solution. It is a real pain having the expensive color printer set as the default.

Edited by hamluis, 23 January 2011 - 01:58 PM.
Split from 2005 topic, PM sent new OP.


BC AdBot (Login to Remove)

 


#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:10 AM

Posted 23 January 2011 - 04:53 PM

Hi Delphi51 -
The M/soft .NET Framework 3.5 may be required on all of these units -
Please be sure you have XP SP3 on all the computers in the home network and check for all M/soft updates -
Also un/re-install the printer on all those units with problems (if you still have the printer CD) then check for Driver updates -

Thank You -
EDIT -
Sorry but I could not access the Egghead link= Blank page (even though I am a member there)

Edited by noknojon, 23 January 2011 - 04:57 PM.


#3 Delphi51

Delphi51
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:10 PM

Posted 23 January 2011 - 08:14 PM

Thanks for helping! The egghead link can be found in a Google search for "network printer only prints if set as default" and it works when clicked on there. I suppose that means the page exists only in Google's archived copy of the internet. Just another guy with the same problem. You have one in your own archives that led me here to mention the partial solution I found.

We have service pack 3 and Microsoft .NET framework 3.5 SP1 installed on all the computers.

#4 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:10 AM

Posted 23 January 2011 - 09:50 PM

Sorry, I posted this and my internet dropped - I will redo it again, hope I remember what I said :blink: -
Hi again -
You need to set the HP printer as 'default' on all of your computers - Not just the main connected one -
If you have the Install CD for it please delete the old version from Add/Remove on the remote units, then reinstall on them as Default printer -
Will any of the remote units print normally if plugged into the printer directly ? I know this is a pain but please try it -
The HP printer Must be set as default so that it can be found, otherwise the computers do not know where to look for it -

Thank You -
EDIT - << The printer is ONLY physically hooked into the router, there are no USB or Parallel connections in use. >>
Above From Egghead - I would try to hook it via a USB port on the base computer and not the router as above -
Just another idea -

Edited by noknojon, 23 January 2011 - 09:58 PM.


#5 Delphi51

Delphi51
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:10 PM

Posted 24 January 2011 - 12:50 AM

There may be some misunderstandings here, noknojon. The printer (CP1215) has no network port and is connected by USB cable to computer 1. Computers 2 and 3 are successfully printing to it over the home network - as long as the HP is set as default printer on them.

The HP printer Must be set as default so that it can be found, otherwise the computers do not know where to look for it

Well, this was not necessary for the first month! But now it is. Why?
When NOT set as default, the driver on computer 2 sends the job over to computer 1 where it appears in the print queue for the HP printer. Computer 1 takes a while to clear it out of the queue, so it must be sending it off to . . . somewhere. It doesn't make sense to me that "the computers do not know where to look for it".

Edited by Delphi51, 24 January 2011 - 12:50 AM.


#6 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:10 AM

Posted 24 January 2011 - 07:21 AM

I would sure like to know another solution. It is a real pain having the expensive color printer set as the default.

Do you also use another printer ?? You must select a default printer from the panel - Why do you not want the HP set as default ??

Un/Re install the printer from all computers, check for any driver updates, and you should be back to November 2010 -

Thank You -

#7 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:10 PM

Posted 24 January 2011 - 07:25 AM

A quick question. Has any other software been installed on computer 1? Some programs, such as PDF viewers, Office software install a virtual printer. It will set itself as the default printer if the User is not careful. Then, when ever a job is sent to the machine with the printer attached it is printed out as a file and placed into a folder by the virtual printer.

What, if anything else, is shown as a printer in the Printer\Faxes folder on the PC with the printer attached?

#8 Delphi51

Delphi51
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:10 PM

Posted 24 January 2011 - 03:37 PM

Congratulations and many thanks to Thunderz!!!

I found several "printers" listed on computer 1 that we had not installed:
- Auto Brother on computer 3
- Auto Cute PDF writer on computer 3
- Auto HP 7040 on computer 2
- Microsoft XPS Document Writer
Deleting those and another auto one on computer 3 has cleared up the problem.
The HP color laserjet was set as default on computer 1 so these others should not have had anything to do with printing over the network. Maybe just too many printers?

Each of the computers still has an installation of Cute PDF writer and computers 2 and 3 have a local laser printer attached via USB.

And thanks again to BleepingComputer and everyone who worked on this weird problem!

#9 ThunderZ

ThunderZ

  • Deactivated
  • 4,454 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:10 PM

Posted 24 January 2011 - 05:40 PM

Glad BC was able to help. :thumbsup:

#10 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:10 AM

Posted 24 January 2011 - 06:00 PM

Do you also use another printer ?? You must select a default printer from the panel=post#6

Sorry if I stated this wrongly , but I meant the same as ThunderZ reply -
<< Maybe just too many printers? >> This was the point I was trying to relay to you, but I confused us both -

Happy Computing - -




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users