Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Weird happenings in Windows 7


  • Please log in to reply
1 reply to this topic

#1 starwarsgeek

starwarsgeek

  • Members
  • 129 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:20 PM

Posted 14 January 2011 - 10:48 PM

I have some weird things going on that started today...

1) My mouse needs to be clicked 2 or 3 times before it will select the items that I am trying to select from my desktop, or to open windows, etc. Yet when I click multiple times sometimes it 'grabs' an item on my desktop and allows me to move it around, even though I'm not holding the button down? This mouse is only about a month old, and has been working perfectly thus far so I don't think the mouse is bad...

2) When I try to copy items (like mp3's) from my PC folder to an external hard drive, it copies the first few files and then just hangs and gets stuck. I can't close the "copying" window, I can't close the windows that I am copying from or to... nothing.

Any ideas what is going on with this all of a sudden? Any and all help/suggestions would be appreciated.

BC AdBot (Login to Remove)

 


#2 Allan

Allan

  • BC Advisor
  • 8,614 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:01:20 PM

Posted 15 January 2011 - 10:11 AM

1) Have you tried a different mouse just to make sure it isn't the mouse?
2) Wired or wireless?
3) Do you have the correct mouse driver installed?
4) What happens in safe mode - does the problem still occur?
5) What is new or different since the last time everything worked properly (ie, new hw, new sw, virus, error, etc)?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users