Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wireless keyboard will not work before start up.


  • Please log in to reply
9 replies to this topic

#1 wavemaker

wavemaker

  • Members
  • 283 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Maryborough Queensland Australia
  • Local time:06:09 PM

Posted 12 January 2011 - 02:41 AM

Gooday all, the title of this topic looks weird but here is what happens. I have Win7 and Ubuntu on my hard drive. Due to an error in my grub, I need to select this drive to get the machine to start windows. As yet I have not been able to get Ubuntu to start, windows does. So, to select the right drive at start up, I tap the F8 key to get the start up menu. My wireless keyboard wont do this. To get started I have to use a wired keyboard to select the drive and then once open the wireless board works seamlessly. I am using it to type this. The wireless keyboard is a Logitech MK 250. Any help in this regard would be most appreciated.
When The Going Gets Weird, The Weird Turn Pro. (H.S.T.)

BC AdBot (Login to Remove)

 


#2 MadDawg

MadDawg

  • Members
  • 453 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Houston, TX
  • Local time:03:09 AM

Posted 12 January 2011 - 03:18 AM

AFAIK, the issue is that the keyboard does not support "full" plug-and-play. Wireless keyboards usually need a driver that is only present in an OS, therefore they do not work in the BIOS or boot menus. This is just my guess.
A penguin broke my windows with a half-eaten apple!

#3 FrankOtheMountaiN

FrankOtheMountaiN

  • Members
  • 532 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NY
  • Local time:04:09 AM

Posted 13 January 2011 - 03:24 PM

Another reason why I hate wireless kybds and mouse.

Frank O' The Mountain
Doing more stupid before 5AM than most people do all day.


#4 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:09 AM

Posted 13 January 2011 - 03:28 PM

I've been using wireless keyboards forever and never had a problem. Check in bios to see if there is a setting to see USB at boot. If so, make sure it's enabled.

#5 w7pro

w7pro

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:03:09 AM

Posted 13 January 2011 - 04:06 PM

Have you checked the driver to see if it's recognized? Also, you might want to see if the battery is still working.

-- Ryan
Windows Outreach Team

#6 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:09 AM

Posted 13 January 2011 - 04:10 PM

Have you checked the driver to see if it's recognized? Also, you might want to see if the battery is still working.

-- Ryan
Windows Outreach Team

The driver would not be "recognized" at boot.

#7 FIDELIS_IT

FIDELIS_IT

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:127.0.0.1
  • Local time:03:09 AM

Posted 14 January 2011 - 06:57 AM

When you start your computer up try to get into BIOS. Check to see if your legacy usb option is enabled. If it is not, enable it. Even though it is a wireless keyboard, it still needs a usb port for the mini receiver. It is worth a shot. Hope it helps
CARPE DIEM

#8 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:09 AM

Posted 14 January 2011 - 07:57 AM

When you start your computer up try to get into BIOS. Check to see if your legacy usb option is enabled. If it is not, enable it. Even though it is a wireless keyboard, it still needs a usb port for the mini receiver. It is worth a shot. Hope it helps

Yeah. I believe I said the same thing in my first post.

#9 wavemaker

wavemaker
  • Topic Starter

  • Members
  • 283 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Maryborough Queensland Australia
  • Local time:06:09 PM

Posted 14 January 2011 - 08:51 PM

Thank you all for your responses.I went into bios and there found 3 options for usb,. All are enabled. The keyboard and mouse work fine once the operating system fires up.

Edit, problem solved. I had the usb receiver in an after market rack of usb2. Whilst reading the posts a second time I reread FIDELIS-ITs post and I had a light bulb moment and plugged the antenna in to one of the usb ports on board the mother board. Shut down and restarted and whako the diddle oh. Away she goes. Thank you very much for your help.
Would someone kindly mark as resolved.

Edited by wavemaker, 14 January 2011 - 09:04 PM.

When The Going Gets Weird, The Weird Turn Pro. (H.S.T.)

#10 Allan

Allan

  • BC Advisor
  • 8,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:04:09 AM

Posted 15 January 2011 - 09:36 AM

Thanks for posting back and glad you got it sorted out :)




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users