Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

McAfee Site Security Approval


  • Please log in to reply
8 replies to this topic

#1 brigg

brigg

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:12:59 PM

Posted 08 January 2011 - 05:49 PM

I want to get a "site approval" from McAfee for my website, www.BeFoundKC.com, but this is a problem for more than just this one site.
I always do a .htaccess 301 redirect for, for example, http://befoundkc.com to http://www.befoundkc.com, for
seo purposes....and because I never want to use the http://befoundkc.com url.

However, McAfee says - It appears that the Web site befoundkc.com (or www.befoundkc.com) is returning an HTTP 2xx or 3xx status response code in the header of 404 pages. Please configure the server to return 404 errors.

I want to keep the 301 redirect, but also want the site security seal of approval from McAfee. I did set up the custom 404 page in Go Daddy,but apparently the .thaccess file is overriding it. Is there any way around ths??

Kansas City Mo area - Central time zone 

Dell D620 Laptop    -   Operating System:  Windows XP Professional 32-bit SP3     -     CPU:  Intel Core Duo T2300E @ 1.66GHz 51 °C     -  Yonah 65nm Technology

RAM:  1.00GB Dual-Channel DDR2 @ 267MHz (4-4-4-12)    -     Motherboard:  Dell Inc. 53 °C     -     Graphics:  Plug and Play Monitor (1280x720@60Hz)
Storage:  74GB SAMSUNG HM080HI (SATA) 36 °C     -     Optical Drives:  TSSTcorp CDRW/DVD TSL462C     -     Audio:  SigmaTel High Definition Audio CODEC
PAE Enabled - Installation Date: 3/20/2009     -     Plug and Play Monitor (1280x720@60Hz)     -     Intel Mobile Intel 945GM Express Chipset Family (Dell)
 

BC AdBot (Login to Remove)

 


#2 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:12:59 PM

Posted 09 January 2011 - 03:39 PM

I do not know how GoDaddy does 404 pages. But usually you have to set custom 404 page using htaccess like this :
ErrorDocument 404 /404.html

I use BlueHost and even when I use their interactive error page tool, it only modifies the htaccess file.

I guess GoDaddy has set the 404 pages to your domain like this:
ErrorDocument 404 http://befoundkc.com/404.html

So the 404 page, redirects to www.befoundkc.com. You may have to manually edit the .htaccess file.

Edited by Romeo29, 09 January 2011 - 03:41 PM.


#3 brigg

brigg
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:12:59 PM

Posted 09 January 2011 - 10:55 PM

Thanks, I'm trying it now.
So my .htaccess looks like this now

Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^befoundkc.com [nc]
rewriterule ^(.*)$ http://www.befoundkc.com/$1 [r=301,nc]
ErrorDocument 404 /be-found-kc-websites-blogs.html

Where be-found-kc-websites-blogs.html is my 404 error page - I'm just trying to max
the SEO benefit by using Keywords in the URL.

So, does that look okay?

Edited by brigg, 09 January 2011 - 11:01 PM.

Kansas City Mo area - Central time zone 

Dell D620 Laptop    -   Operating System:  Windows XP Professional 32-bit SP3     -     CPU:  Intel Core Duo T2300E @ 1.66GHz 51 °C     -  Yonah 65nm Technology

RAM:  1.00GB Dual-Channel DDR2 @ 267MHz (4-4-4-12)    -     Motherboard:  Dell Inc. 53 °C     -     Graphics:  Plug and Play Monitor (1280x720@60Hz)
Storage:  74GB SAMSUNG HM080HI (SATA) 36 °C     -     Optical Drives:  TSSTcorp CDRW/DVD TSL462C     -     Audio:  SigmaTel High Definition Audio CODEC
PAE Enabled - Installation Date: 3/20/2009     -     Plug and Play Monitor (1280x720@60Hz)     -     Intel Mobile Intel 945GM Express Chipset Family (Dell)
 

#4 brigg

brigg
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:12:59 PM

Posted 09 January 2011 - 11:12 PM

I did the following correction, waited a minute or two, tried the site verification again, and still received: and "It appears that the Web site befoundkc.com (or www.befoundkc.com) is returning an HTTP 2xx or 3xx status response code in the header of 404 pages."
---the .htacess file looked like this:
Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^befoundkc.com [nc]
rewriterule ^(.*)$ http://www.befoundkc.com/$1 [r=301,nc]
ErrorDocument 404 /be-found-kc-websites-blogs.html

Where be-found-kc-websites-blogs.html is my 404 error page

I made the following change but received the same error message as above (again, I only waited a few minutes after uploading the file before trying the site verification:
Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^befoundkc.com [nc]
rewriterule ^(.*)$ http://www.befoundkc.com/$1 [r=301,nc]
ErrorDocument 404 /http://www.befoundkc.com/be-found-kc-websites-blogs.html

ANY IDEAS?

Kansas City Mo area - Central time zone 

Dell D620 Laptop    -   Operating System:  Windows XP Professional 32-bit SP3     -     CPU:  Intel Core Duo T2300E @ 1.66GHz 51 °C     -  Yonah 65nm Technology

RAM:  1.00GB Dual-Channel DDR2 @ 267MHz (4-4-4-12)    -     Motherboard:  Dell Inc. 53 °C     -     Graphics:  Plug and Play Monitor (1280x720@60Hz)
Storage:  74GB SAMSUNG HM080HI (SATA) 36 °C     -     Optical Drives:  TSSTcorp CDRW/DVD TSL462C     -     Audio:  SigmaTel High Definition Audio CODEC
PAE Enabled - Installation Date: 3/20/2009     -     Plug and Play Monitor (1280x720@60Hz)     -     Intel Mobile Intel 945GM Express Chipset Family (Dell)
 

#5 brigg

brigg
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:12:59 PM

Posted 09 January 2011 - 11:48 PM

Go Daddy says this today about this problem:
"It appears that the htaccess file within the account is set to redirect all requests as 301 redirects. You will need to update the htaccess file or remove it in order to change the HTTP status code that returns. The homepage at the very least should return a 200 status, but it also produces a 301."

I want to keep the 301 redirect for SEO purposes.
An ideas?

Kansas City Mo area - Central time zone 

Dell D620 Laptop    -   Operating System:  Windows XP Professional 32-bit SP3     -     CPU:  Intel Core Duo T2300E @ 1.66GHz 51 °C     -  Yonah 65nm Technology

RAM:  1.00GB Dual-Channel DDR2 @ 267MHz (4-4-4-12)    -     Motherboard:  Dell Inc. 53 °C     -     Graphics:  Plug and Play Monitor (1280x720@60Hz)
Storage:  74GB SAMSUNG HM080HI (SATA) 36 °C     -     Optical Drives:  TSSTcorp CDRW/DVD TSL462C     -     Audio:  SigmaTel High Definition Audio CODEC
PAE Enabled - Installation Date: 3/20/2009     -     Plug and Play Monitor (1280x720@60Hz)     -     Intel Mobile Intel 945GM Express Chipset Family (Dell)
 

#6 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:12:59 PM

Posted 10 January 2011 - 09:47 AM

Did you try this :

Options +FollowSymlinks
ErrorDocument 404 /be-found-kc-websites-blogs.html

RewriteEngine on
RewriteCond %{HTTP_HOST} ^befoundkc\.com$ [NC]
RewriteRule ^(.*)$ http://www.befoundkc.com/$1 [R=301,L]

Edited by Romeo29, 10 January 2011 - 09:48 AM.


#7 brigg

brigg
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:12:59 PM

Posted 10 January 2011 - 12:10 PM

Hello - thanks for the specifics on what the .htaccess needs to look like.
I changed it, waited a minute and tried again.

Still got "It appears that the Web site befoundkc.com (or www.befoundkc.com) is returning an HTTP 2xx or 3xx status response code in the header of 404 pages."

Is there anything I need to change in my 404 error page? I've done nothing special to it at all.

Kansas City Mo area - Central time zone 

Dell D620 Laptop    -   Operating System:  Windows XP Professional 32-bit SP3     -     CPU:  Intel Core Duo T2300E @ 1.66GHz 51 °C     -  Yonah 65nm Technology

RAM:  1.00GB Dual-Channel DDR2 @ 267MHz (4-4-4-12)    -     Motherboard:  Dell Inc. 53 °C     -     Graphics:  Plug and Play Monitor (1280x720@60Hz)
Storage:  74GB SAMSUNG HM080HI (SATA) 36 °C     -     Optical Drives:  TSSTcorp CDRW/DVD TSL462C     -     Audio:  SigmaTel High Definition Audio CODEC
PAE Enabled - Installation Date: 3/20/2009     -     Plug and Play Monitor (1280x720@60Hz)     -     Intel Mobile Intel 945GM Express Chipset Family (Dell)
 

#8 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:12:59 PM

Posted 10 January 2011 - 02:24 PM

I just checked your site, it is working as it should.
For www 404, it returns 404. For non-www 404, it returns 301 and then 404. Good all sites work that way.
I think you are giving befoundkc.com to McAfee. You should now use only www.befoundkc.com wherever needed.

Edited by Romeo29, 10 January 2011 - 02:28 PM.


#9 brigg

brigg
  • Topic Starter

  • Members
  • 457 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:12:59 PM

Posted 10 January 2011 - 05:08 PM

Thanks for checking it all out.
My guess is the problem with non-www 404 - it returns 301 and then 404.

The thing is, I really want to keep the 301 redirects for SEO purposes.
I never use the non www address - the URLs I give McAfee are just copied and pasted
from when I'mm in the site.
It looks like this is as good as it gets!
I think I'm over McAfee!

Kansas City Mo area - Central time zone 

Dell D620 Laptop    -   Operating System:  Windows XP Professional 32-bit SP3     -     CPU:  Intel Core Duo T2300E @ 1.66GHz 51 °C     -  Yonah 65nm Technology

RAM:  1.00GB Dual-Channel DDR2 @ 267MHz (4-4-4-12)    -     Motherboard:  Dell Inc. 53 °C     -     Graphics:  Plug and Play Monitor (1280x720@60Hz)
Storage:  74GB SAMSUNG HM080HI (SATA) 36 °C     -     Optical Drives:  TSSTcorp CDRW/DVD TSL462C     -     Audio:  SigmaTel High Definition Audio CODEC
PAE Enabled - Installation Date: 3/20/2009     -     Plug and Play Monitor (1280x720@60Hz)     -     Intel Mobile Intel 945GM Express Chipset Family (Dell)
 




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users