Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Just Installed Vista


  • Please log in to reply
5 replies to this topic

#1 terrionna

terrionna

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:25 PM

Posted 02 January 2011 - 12:56 AM

Hello. I just went from windows xp to vista. Im wondering what drivers i need because i thought i had them all but everything is so slow. Programs open slow, internet lags like crazy. I was just wondering if anyone could give me a list of drivers i need to make my os run at top speed. Please help.

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,738 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:07:25 PM

Posted 02 January 2011 - 01:14 AM

Was it clean install?
Legit Vista DVD?

Please, post some computer info:
- processor type, amount of RAM (hold Windows logo key, hit Pause/Break key)
- hard drive size/free space (open "My Computer", right click on hard drive letter, click "Properties")
- installed security programs (antivirus, firewall)

My Website

My help doesn't cost a penny, but if you'd like to consider a donation, click DONATE

 


#3 terrionna

terrionna
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:25 PM

Posted 02 January 2011 - 03:57 AM

I have a dell inspiron 1521
Yes it was a clean install i used the vista cd that came with my laptop. the drivers cd wouldnt work for me so i had to use my dad to get all the drivers i thought i needed when he wasnt working.
Processor: AMD Athlon 64x2 dual-core processor tk-55 1.80Ghz
894 MB
System type: 32 bit operating system
Its vista home basic

74.50 gb of hardrive space and 30.4 free
and i have Mbam and microsoft security essentials installed

#4 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,738 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:07:25 PM

Posted 02 January 2011 - 01:33 PM

This is your culprit:
894 MB of RAM
Vista needs at least 2GB of RAM to run smoothly.

My Website

My help doesn't cost a penny, but if you'd like to consider a donation, click DONATE

 


#5 terrionna

terrionna
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:08:25 PM

Posted 02 January 2011 - 01:49 PM

oh oh i didnt know that. i guess i will be buying those dimms after all. thanks for your help.

#6 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,738 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:07:25 PM

Posted 02 January 2011 - 02:36 PM

You're very welcome Posted Image

My Website

My help doesn't cost a penny, but if you'd like to consider a donation, click DONATE

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users