Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unable to set up UDP Port Forwarding


  • Please log in to reply
6 replies to this topic

#1 Wes T

Wes T

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:06:51 PM

Posted 27 December 2010 - 11:53 AM

Hello. First time poster. Thanks for viewing this thread.

So here's my issue. I'm trying to set up a home Ventrilo server, but for some reason I'm unable to turn on UDP port forwarding. Yesterday afternoon the Ventrilo server was working fine, but then I (stupidly) decided to delete port the forwarding rule. Later on, I decided to re-enable the port forwarding, but then the router started to give me errors. Each time I would try to set up port forwarding for any computer on my network, I received the error: "The desired port range is not allowed to be configured."

I have Verizon FiOS, so I tried calling up Verizon who gave me the run around and told me to call Actiontec, the manufacturer of the router. When I was able to get through to the Actiontec support, they weren't much more helpful. The guy I spoke to tried to fix the issue through remote administration, but in the end he kept getting the same error and wasn't able to resolve the issue. Since then, I've discovered that I can set up TCP port forwarding on my router, but trying to set up UDP port forwarding gives the above error. Unfortunately, Ventrilo requires using both TCP and UDP.

I'm lost as to what could cause this error. I've tried to Google this issue, but it seems that no one else has this particular problem. I know UDP port forwarding worked before, because I was able to use my Ventrilo server before. I have not changed anything on any of my computers such as setting up firewalls. I did, however, set up a Dynamic DNS through dyndns.org. I'm not sure if that could have caused my issues.

Any help is appreciated. Thanks!

*Edit: I should also mention that I've tried to resetting my router - through the internet browser and by physically pressing the reset button on the router - to no avail.

Edited by Wes T, 27 December 2010 - 12:01 PM.


BC AdBot (Login to Remove)

 


#2 Onetallnerd

Onetallnerd

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:51 PM

Posted 28 December 2010 - 03:03 AM

I am having this exact same problem I get this error input message.

Invalid rule: The desired port range is not allowed to be configured.

My router is an Actiontec MI-424-WR. version c.
I have no idea what the heck is wrong with it?

#3 Wes T

Wes T
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:06:51 PM

Posted 28 December 2010 - 06:26 PM

I wonder if that means it's something that Verizon has changed. Did you just recently start having this issue when you tried to set up port forwarding?

#4 Wes T

Wes T
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:06:51 PM

Posted 28 December 2010 - 08:19 PM

I was able to get this problem solved by the grace of the Actiontec tech support representative who called me back and walked me through the solution. I can't remember his name, but if you are reading this, thank you very very very much for your help. Needless to say, I was a bit surprised that I was actually contacted by them, and I take back any sore attitudes I had toward their tech support.

In case anyone else is in the same boat as I was, here's my solution. I'm not sure if it will work for everyone else, but if you have an Actiontec MI-424-WR and are using Verizon, this solution may work.

Log in to your router settings (192.168.1.1.).

Then click on Advanced > Port Forwarding Rules.

Add a rule with a name of your choosing.

Then add two Server Ports.
The Protocol for both should be TCP.
The Source Ports for both should be Any.
The Destination Ports should be set as Single, # and #+1, where # is the number of the port you're trying to forward and #+1 is the port number plus one.
(For my purposes, I only needed to open up a single TCP and a single UDP port for 3784. So if you need to have more than that then you will need add more TCP server ports and give them subsequent Destination port numbers.)

After that is done go to Firewall Settings > Port Forwarding, and set up the port forwarding rule for the computer in question. From the application list, select the port forwarding rule you just created and apply the settings. Your computer should now be added with the port forwarding rule with the TCP ports.

Now go back to Advanced > Port Forwarding Rules, and edit the rule that you made. Edit the second Server Port (the one with Destination Port #+1) so that the Protocol is UDP and the Destination Port is #.

Apply these settings. If you go back to the Firewall Settings > Port Forwarding then the ports for the computer you were adding the rule to should now have both TCP and UDP. And that's how to add UDP Port Forwarding.



If this still doesn't work you may need to set up a Port Triggering rule for ports you're trying to forward. You should add port entries to both the Outgoing and Incoming sections.

When I spoke with the tech support rep, it seemed that this issue was fairly recent. This indirect solution seems to be the only fix for now, but Actiontec is looking for a more permanent solution.

Anyway, hope this helped some other people who were having the same issue.

#5 Animal

Animal

    Bleepin' Animinion


  • Site Admin
  • 35,111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where You Least Expect Me To Be
  • Local time:04:51 PM

Posted 28 December 2010 - 08:28 PM

Thank You for sharing your fix. :thumbup2:

The Internet is so big, so powerful and pointless that for some people it is a complete substitute for life.
Andrew Brown (1938-1994)


A learning experience is one of those things that say, "You know that thing you just did? Don't do that." Douglas Adams (1952-2001)


"Imagination is more important than knowledge. Knowledge is limited. Imagination circles the world." Albert Einstein (1879-1955)


Follow BleepingComputer on: Facebook | Twitter | Google+

#6 Onetallnerd

Onetallnerd

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:51 PM

Posted 31 December 2010 - 12:19 AM

I said thanks on the email. Now I'm saying thanks again. It worked perfectly, and before I was thinking I messed up with the router myself. Good to know it was verizon's fault not mine. :P

#7 Vadim K

Vadim K

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:51 PM

Posted 17 February 2011 - 08:21 PM

If this still doesn't work you may need to set up a Port Triggering rule for ports you're trying to forward. You should add port entries to both the Outgoing and Incoming sections.


Still no luck. Now my settings is

forwarding
192.168.1.21 IPTV UDP Any -> 554-555 All Broadband Devices Active

triggering
Outgoing Trigger Ports Incoming Ports to Open
IPTV UDP 554-555 -> 554-555 UDP 554-555 -> 554-555

Any ideas? Help please!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users