Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Stuck installing drivers for my 3D 6850


  • Please log in to reply
5 replies to this topic

#1 jakeandchase

jakeandchase

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:08:25 PM

Posted 26 December 2010 - 11:24 PM

Hey, i am new to Linux. I have the latest version of Ubuntu, full updated. It is installed with Wubi through windows 7.

I want to install the drivers for my Sapphire HD 6850.

I was refereed to: Catalyst 10.1 Linux Driver
I was refereed to: http://wiki.cchtml.com/index.php/Ubuntu_Maverick_Installation_Guide to install it.

I was copying and pasting the commands down the page into terminal. It was working all fine.
Installed the .debs, but when i get up to "generic config" stage and enter "sudo aticonfig --initial -" I get the message: "aticonfig: No supported adapters detected"

Can anyone please help? Or is there another method for installing them?

BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:25 AM

Posted 28 December 2010 - 03:59 PM

Do you have the restricted repositories enabled?

You will need to enable them, then do a apt-get update && apt-get upgrade -y and install the latest drivers.

Restricted Drivers Manager

NOTE: You must have the restricted repository enabled in Applications -> Ubuntu Software Centre -> Edit -> Software Sources... for this to work. You must also have the fglrx-modaliases and jockey-gtk (or jockey-kde for Kubuntu) packages installed. You will be limited to the drivers for your version of Ubuntu that Canonical deems stable. This may not give you the latest drivers, but should be safest. On Ubuntu Maverick, this will install Catalyst 8.780, which is roughly equivalent to Catalyst 10-10. Go to the Additional Drivers Manager (System -> Administration -> Additional Drivers) and activate the "ATI/AMD proprietary FGLRX graphics driver" (or double-click the "available driver" notification icon). Ubuntu will then install and configure the driver for you.


Edited by cryptodan, 28 December 2010 - 03:59 PM.


#3 jakeandchase

jakeandchase
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:08:25 PM

Posted 28 December 2010 - 07:22 PM

How do i do this? Sorry i'm knew to linux.

#4 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:25 AM

Posted 29 December 2010 - 06:23 AM

See the quoted text in my post.

#5 jakeandchase

jakeandchase
  • Topic Starter

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Local time:08:25 PM

Posted 03 January 2011 - 03:59 AM

:S I did ALL you quoted.

I now have when i go system>admin>hardware drive i get this:
Posted Image


Then when i go to system>preferences>ati catalyst control center, i get this:
Posted Image

And i still have the original crappy res and cannot enable visual effects. :S

#6 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:25 AM

Posted 03 January 2011 - 06:14 AM

Try running aticonfig via a terminal window.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users