Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Satellite L355 Keyboard/Touchpad not working


  • Please log in to reply
No replies to this topic

#1 adventureluck

adventureluck

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:02 PM

Posted 22 December 2010 - 07:36 PM

Hello all,

Recently the keyboard and touchpad on my Satellite L355 stopped working. I am running windows vista basic. Just turned it on one day and the keyboard and touch work in the bios, and to choose if you want to run normally or in safe mode, but not once you start the operating system. I tried taking the battery out, as well as the power cord, and leaving it like that for about half an hour. I also tried holding the power down while there was no plug, or battery hooked up. Held it for 30 seconds, and that didn't work either. I searched and searched but for the life of me, I couldn't find another way to hard reset an L355. Hooked up a mouse and keyboard externally and they work fine. Scanned for viruses and just found some cookies. Tried uninstalling/reinstalling keyboard drivers in device manager and that didn't work (uninstall, then reboot). Am I doing the hard reset wrong? I mean, I guess I can just try calling toshiba tomorrow. Tech support monkeys are so bad sometimes though (is the computer on? yes..)Anyway, if you guys have any suggestions for me, I would really appreciate it.

Thanks,

Me

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users