Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 file in use error and batch save error


  • Please log in to reply
2 replies to this topic

#1 getgcs

getgcs

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:53 PM

Posted 15 December 2010 - 05:29 PM

I have a file in a folder called bla.exe

I copy a newer version to the folder

windows 7 asks me if I want to copy and replace the file

I say yes

Windows 7 says "error file is open in another program"

WHAT THE HECK IS THAT!!!
(it is in no way shape or form open in any program except for explorer!)

There is some kind of delayed file protection inside windows 7 that is not in windows XP nor vista.

in XP or vista you can copy and replace files with no problems.

I have searched and found several possible fixes that dont fix the problem:
1.) I set the advanced owner permisions to my whole C: drive to have the owner as Administrator instead of trusted installer

2.) UAC is off and I have set all basic permissions to full control on admin and on everyone
_______________________________________ ______________________

problem #2

In windows XP I edit a batch file and I click save to save its new contents.

In windows 7 I save the edited batch file and it says it is in use and I end up having to save it as a different name or different location!
_______________________________________ _____________________

- I have searched to no end on this issue since win 7 came out.
- I have this same issue after re-installing windows 7 multiple times( and with default settings)
- I have this same issue on different peoples computers that have win 7 too.

_______________________________________ ______________________

the files that have copy errors can be ANY exe and it wont let you unless you wait about 10 minutes after you clicked the original exe.

the batch save problem also exists on any windows 7

_______________________________________ _____________________-

Any possible help or solutions would be great.....someday I guess.... ???

BC AdBot (Login to Remove)

 


#2 MrBruce1959

MrBruce1959

    My cat Oreo


  • BC Advisor
  • 6,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:10:53 PM

Posted 16 December 2010 - 02:00 AM

I read your question several times to make sure I am following you correctly.

What I am perceiving from what you are describing is that you are attempting to put two files of the same name in the same folder at the same time. Is this correct?

Normally it will create or allow the file to be in the same folder but will add a 2 to the end of the file.
such as bla.exe and bla(2).exe

I use Microsofts Visual Studio 2010 a lot and have created batch files for some programs I have worked on and only use Windows 7 most of the time.

I have not experienced the issues you speak of with being warned that the batch file is in use elsewhere on my system when I am working with a batch file.

If I am way off course here, sorry about my misunderstanding your question.

Bruce.

Edited by MrBruce1959, 16 December 2010 - 02:08 AM.

Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
 
My Career Involves 37 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:

#3 getgcs

getgcs
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:53 PM

Posted 17 December 2010 - 09:14 PM

Well no I have a file called bla.exe in a folder.

I have a newer version of the file and I try to copy it to that folder with (bla.exe) and it normally would overwrite it on xp but not on windows 7...

I get error: "The operation cannot be completed, the file is in use in another program. (IT IS NOT IN USE AT ALL... IT WAS JUST HIGHLIGHTED OR LOOKED AT)

Vista and xp are fine with this I even changed the default services back to normal instead of some being disabled and still no go.

I paid for windows 7 and I wish I could figure this out...

Thanks for your response Bruce.

Edited by getgcs, 17 December 2010 - 09:16 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users