Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ubuntu 10.10 cannot open Windows shares


  • Please log in to reply
15 replies to this topic

#1 bomber1712

bomber1712

  • Members
  • 464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin, USA
  • Local time:12:17 AM

Posted 14 December 2010 - 09:15 PM

Hi all,

I have a "server" with WinXP (32 bit) with a wired connection to my WRT54G Linksys Wireless router.I have 2 printers attached to this machine, and both are shared. In addition, I have a wired Win7 Pro (64 bit) desktop, a Win7 Home Premium (32 bit) laptop that connects wireless, a WinXP (32) desktop connected wirelessly, a Ubuntu 10.10 laptop (dual boot Win XP), and a Ubuntu 10.04 laptop. I have several drives on the Windows systems that are set up as shares. I can "see" and "share" all of the drives and printers when using any of the Windows systems, but cannot see anything with the Ubuntu machines.

I have tried several things, but I cannot get a fix. Anyone interested in helping?

BC AdBot (Login to Remove)

 


#2 myrti

myrti

    Sillyberry


  • Malware Study Hall Admin
  • 33,771 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:At home
  • Local time:07:17 AM

Posted 15 December 2010 - 01:13 PM

Hi,

have you installed samba? That should make it rather simple normally. How have you tried to mount it?

regards myrti

Edited by myrti, 15 December 2010 - 01:15 PM.

is that a bird?  a plane? nooo it's the flying blueberry!

If I have been helping you and haven't replied in 2 days, feel free to shoot me a PM! Please don't send help request via PM, unless I am already helping you. Use the forums!

 

Follow BleepingComputer on: Facebook | Twitter | Google+


#3 bomber1712

bomber1712
  • Topic Starter

  • Members
  • 464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin, USA
  • Local time:12:17 AM

Posted 15 December 2010 - 02:08 PM

myrti! You do it all, huh?

I DO have samba installed and to the best of my knowledge it is configured correctly (workgroup=MSHOME). When I try to open the Network, it shows me MSHOME, but when I open it, it only shows me the computer that I am on! Should I remove Samba and then reinstall it? I also tried (from memory) SMB4k(?) to see if that did a better job, to no avail.

I even tried to wire my Ubuntu to the network. In this case, I could see all of the shares, but when I tried to mount any of them, I got an error message about "failed to retrieve list" or something like that.

The funny thing is that at one point I did have Ubuntu systems playing nice with my Windows network. I had 9.10 originally, upgraded to 10.04, and then to 10.10. On one system, I did a full reformat and clean install of 10.10 (dual boot Win XP pro). On the other one, I have dual boot 9.10 and 10.04. I tried the 9.10 boot to see if that was where I had connectivity, but was unable to see the shares, too.

I am thinking a fresh install of 10.10 on both.

#4 myrti

myrti

    Sillyberry


  • Malware Study Hall Admin
  • 33,771 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:At home
  • Local time:07:17 AM

Posted 15 December 2010 - 02:31 PM

Heya...

I am everywhere. You can not escape me! :crazy:

On a more serious note, Kubuntu is my main OS.. so I drop by this forum as well on occasions. :)

If it is only a windows share you want to be able to access from the ubuntu PC you could do this:

All commands go into the command line (terminal if you're using ubuntu, konsole if you're using kubuntu)
  • First install smbfs:

    sudo apt-get install smbfs
  • Create the directory in which you want to mount the network share:

    sudo mkdir /media/samba
  • Then mount the network share: (you need to adapt the IP and the username and the share name)

    sudo mount -t smbfs -o username=yourusername //192.168.x.x/sharename /media/samba/
  • You can now access the network share as if it was a folder on your PC.
regards myrti

is that a bird?  a plane? nooo it's the flying blueberry!

If I have been helping you and haven't replied in 2 days, feel free to shoot me a PM! Please don't send help request via PM, unless I am already helping you. Use the forums!

 

Follow BleepingComputer on: Facebook | Twitter | Google+


#5 bomber1712

bomber1712
  • Topic Starter

  • Members
  • 464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin, USA
  • Local time:12:17 AM

Posted 15 December 2010 - 07:58 PM

Thanks, myrti! That worked. I also found that if I use Places>Connect to Server, I can access all of the shares on a particular computer, which is COOL! Can I make a permanent shortcut to this or do I have to access it each time?

I have a laptop with a share, as well. Computer name is User-PC, user name is Bomber and static IP is 192.168.1.149. I can use Places>Connect to Server to get a window asking for a password, but it will not accept my password to give me access to the share. What gives there?

#6 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:05:17 AM

Posted 15 December 2010 - 08:08 PM

I have been meaning to post to this topic.

In order to mount other shares via samba you have to make sure that you are have an account setup on the machine with the shares, and that you using those credentials via Linux other wise you wont be able to access the shares.

#7 bomber1712

bomber1712
  • Topic Starter

  • Members
  • 464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin, USA
  • Local time:12:17 AM

Posted 15 December 2010 - 08:16 PM

cryptodan,

Any thoughts as to why I can connect to one, but not the other? I do have user accounts on all of my windows machines.

#8 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:05:17 AM

Posted 15 December 2010 - 08:20 PM

Permissions on the machine you having issue connecting too. But are you using those account credentials on the shared drives?

#9 bomber1712

bomber1712
  • Topic Starter

  • Members
  • 464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin, USA
  • Local time:12:17 AM

Posted 15 December 2010 - 09:22 PM

I tried to open the computer at "Places>Connect to Server...". I chose windows share, entered 192.168.1.149 and then it askes for user (bomber) and password. I enter my user name and the password that I use to log in to my windows account, and it just continues to ask for user, domain, and password.

#10 myrti

myrti

    Sillyberry


  • Malware Study Hall Admin
  • 33,771 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:At home
  • Local time:07:17 AM

Posted 15 December 2010 - 09:29 PM

It might be the firewall on the Windows PC that is blocking you out. It might be that the useraccount is case sensitive.

What message are you getting when you try to mount it in terminal? It should give you an error message.

regards myrti

is that a bird?  a plane? nooo it's the flying blueberry!

If I have been helping you and haven't replied in 2 days, feel free to shoot me a PM! Please don't send help request via PM, unless I am already helping you. Use the forums!

 

Follow BleepingComputer on: Facebook | Twitter | Google+


#11 bomber1712

bomber1712
  • Topic Starter

  • Members
  • 464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin, USA
  • Local time:12:17 AM

Posted 15 December 2010 - 11:58 PM

Then mount the network share: (you need to adapt the IP and the username and the share name)

sudo mount -t smbfs -o username=yourusername //192.168.x.x/sharename /media/samba/


Can I "browse" all shares using this command? I'm thinking:

sudo mount -t smbfs -o username=yourusername //192.168.x.x /media/samba/

#12 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:05:17 AM

Posted 16 December 2010 - 12:29 AM

Shares are mounted like this:

\\hostorcomputer\sharename

#13 bomber1712

bomber1712
  • Topic Starter

  • Members
  • 464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin, USA
  • Local time:12:17 AM

Posted 16 December 2010 - 08:32 AM

OK, big DUH! moment....I checked my 192.168.1.149 computer, and NONE of the folders are shared! So, now I set up a share and was able to access using "Places>Connect to Server..."

Thanks to all for help. I still think it should be easier! I would have gone into an issue about connecting a shared printer, but it died, so I bought a Wireless and got it hooked up!

FYI - Best Buy has a REALLY nice wireless printer (Canon Pixma MP560) for $50 (retail $150) this week! Wireless is nice. The bonus for me is that it has 2 paper trays, so I can load Letter and Photo (4x6). Thats a really nice feature! When I want to print a photo, I don't need to go to the printer to change the settings and paper. There is a nifty program that gets installed called "One Click Photo Printing". It's so easy, my non-techie wife can print photos all day!

#14 bomber1712

bomber1712
  • Topic Starter

  • Members
  • 464 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wisconsin, USA
  • Local time:12:17 AM

Posted 16 December 2010 - 01:09 PM

One last thought that was not answered:

Once I connect to the share, is there any way to make that "connection" permanent or do I have to mount it each time?

#15 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:05:17 AM

Posted 16 December 2010 - 02:29 PM

You can add it to /etc/fstab so it mounts each time on boot.

Making Samba Mounts Permanent just be aware that the machines need to have static IP's and that they are turned on the following order.

1) Machines with the Shares that need mounting.

2) Linux Machine with which samba is running on.

If the machines are turned on in reverse order, then your linux machines will take forever to boot, or they will not boot up at all.

Also keep in mind bandwidth as well.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users