Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

URGENT - disk0s2: I/O error.


  • Please log in to reply
2 replies to this topic

#1 Start

Start

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:29 AM

Posted 11 December 2010 - 08:51 AM

Hey guys:

I have a friend that has a sick Macbook. His Macbook model is: MacBook (13-inch, Early 2008). His Macbook cannot boot. When the power button was pressed, the grey apple logo and the spinning thing appears. In addition, there is a progress bar underneath. I waited till the progress bar disappears, but it automatically shuts down after that. I tried to restart normally, but the same thing happened. I tried removing the battery and holding down the power button for 20 to 30 secs, but it did not work. I tried booting into the verbose mode, and "disk0s2: I/O error." appears. Here's a section of the log:

Executing fsck_hfs (version diskdev_cmds-491.3~2)
** Checking Journaled HFS Plus volume
** Checking extents overflow file.
disk 0s2:I/O error.
disk 0s2:I/O error.
disk 0s2:I/O error.
disk 0s2:I/O error.
disk 0s2:I/O error.
disk 0s2:I/O error.
disk 0s2:I/O error.
** Checking catalog file.
** Checking multi-linked files.
** Checking catalog hierarchy.
** Checking extended attributes file.
disk 0s2:I/O error.
Invalid node structure
(8, 70)
** The volume Macintosh HD could not be verified completely.
/dev/rdisk0s2 (hfs) EXITED WITH SIGNAL 8


I also tried using "/sbin/fsck -fy", but disk 0s2: I/O error. appears again. Is there a way to retrieve the files inside? How can this be fixed?

Thanks.

BC AdBot (Login to Remove)

 


#2 MrBruce1959

MrBruce1959

    My cat Oreo


  • BC Advisor
  • 6,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:12:29 PM

Posted 11 December 2010 - 10:34 PM

Hello and welcome to Bleepingcomputer.

I am going to be serious when I say I have zero back-ground experience with Macintosh computers or their hardware.

But based on the errors I see that you posted above, it appears to me like you may have either a corroded contact on the hard drive or motherboard, that connects the drive to the motherboard.

I would try disconnecting the cable at both ends and re-connecting them, lets see if this corrects the problem, it certainly wouldn't hurt and may resolve the problem.

If this does not resolve the problem, then there stands a very good possibility that the drive is failing.

Its either time to clone the drive, or back its contents up, by using this drive as a slave drive to a good working drive with an OS in it set as the master.

As I said I do not have much experience with Macintosh computers, so if my suggestions do not seem to make sense, then that would be my knowledge of Windows OS getting in the way of my better judgment.

But if on the other hand, this does help then I taught myself something new.

Bruce.

Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
 
My Career Involves 45 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:


#3 thrillhouse

thrillhouse

  • Members
  • 1,040 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Va
  • Local time:01:29 PM

Posted 11 December 2010 - 10:44 PM

http://support.apple.com/kb/ts1417

hope this helps.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users