Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Spellcheck in OpenOffice Fails


  • Please log in to reply
8 replies to this topic

#1 RAPHelp

RAPHelp

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:10:09 PM

Posted 11 December 2010 - 02:21 AM

Just started using OpenOffice 3.2 and spellcheck doesn't seem to work. When pf7 is pressed, spellcheck runs (I guess) and asks if the rest of the document should be checked. I clicked 'yes' and it came back saying that spellcheck was complete BUT there were words misspelled and those weren't found.

What have I done wrong? ... Failed to set up properly?

English was chosen as the default language.

BC AdBot (Login to Remove)

 


#2 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:02:09 AM

Posted 11 December 2010 - 05:37 AM

What words were misspelled, and do they have any synonyms like the following:

there, their, and they're

If you type the following:

Their are people over they're eating there cookies, and their enjoying it.

Spell check wouldn't pick up any spelling errors, however, grammar check would and suggest the following:

There are people over there eating their cookies, and they're enjoying it.

Spell check on the computer comes with its lack of human input and understanding of the english language.

Did you try the same document in an Office Suite like Office 2003?

#3 RAPHelp

RAPHelp
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:10:09 PM

Posted 11 December 2010 - 01:13 PM

Three misspelled words that weren't found:
bexn ... should be - been
i9s ... should be - is
thwe ... should be - the

didn't try office 2003 .... using oo because it's free

#4 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:10:09 PM

Posted 11 December 2010 - 01:40 PM

i9s shouldn't be picked up as being misspelled because of the number in it.

No excuses on the other two, tho.

#5 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:02:09 AM

Posted 11 December 2010 - 06:08 PM

With OOo you may have to build the dictionary.

#6 RAPHelp

RAPHelp
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:10:09 PM

Posted 11 December 2010 - 07:24 PM

Is that the stuff about 'adding extensions'? Didn't seem very straight forward when I looked quick.

#7 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:02:09 AM

Posted 11 December 2010 - 08:18 PM

Here: Dictionaries for OOo

Edited by cryptodan, 11 December 2010 - 08:18 PM.


#8 RAPHelp

RAPHelp
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:10:09 PM

Posted 11 December 2010 - 11:55 PM

Tried adding en_US.ext - doesn't work (undoubtedly my error)

Reported problem in OOo (OpenOffice Writer) forum - awaiting response

Thank you for the suggestions - will update if get a solution.

#9 RAPHelp

RAPHelp
  • Topic Starter

  • Members
  • 167 posts
  • OFFLINE
  •  
  • Local time:10:09 PM

Posted 12 December 2010 - 04:16 PM

Problem was mine - surprise,surprise

Went to Format->Styles and Formatting->Default ... right-click drop-down->Modify->'Font tab
Language field was empty (had 'none') ... picked English (USA)

Spellcheck works !!

I would have expected OOo to set that field when the dictionary was added - but then I guess several dictionaries could be added (with no way for OOo to determine which to use) ... but maybe a reminder (when the dictionary was added) would be useful.

BTW: (in answer NpaMA's post in this thread) ... spellcheck DOES check for words containing numbers:
Tools->Options->(expand Language Settings)Writing Aids->Options area ... set 'Check words with numbers'.
When spellcheck, it finds things like 'i9s' as incorrect - which is good for me ... I type like I have 'fat fingers'




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users