Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

EXE files toast after malware cleanup- basic fixes didn't work


  • Please log in to reply
1 reply to this topic

#1 JennhatesPCs

JennhatesPCs

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:09:37 PM

Posted 10 December 2010 - 06:51 PM

A PC on our network recently came down with a rogue antivirus infection that I found and cleaned with Malwarebytes. (Fake.Alert, Trojan.Agent and Malware.Trace) After cleaning, the PC now won't run most .exe files either from shortcuts or from Program Files in Windows Explorer. Attempts to run apps either result in the Application Unknown error message or launching of the "Open With" dialogue.

Noted exceptions: Outlook and IE will both run from the Start Menu shortcuts but will not launch from desktop shortcuts, QuickLaunch or from Windows Explorer.

The inability to run .exe files is limited to the user profile that was involved with the original infection. Administrator does not have any problems at all with executables.

I tried a couple of things I found in on this site and on the Microsoft support site.

1. While logged in as Administrator, I went to the file types dialogue to make sure that EXE files were associated with Applications. EXE does not actually appear in the list of registered file types though when I click "New" and try to create a new association for EXE, it says it is already registered with the file type Application. I tried repeating this while logged into the buggy profile but all options in the dialogue are grayed out. Again, EXE is not in the list of registered file types.

2. Then I went to regedit and looked up the exefile/shell/open/command key. The string is "%1" %* which is what it's supposed to be I believe. This is true when I go into regedit as either Admin or as the buggy user.
--
Thinking that a lingering infection might be at work, I attempted to reboot into Safe Mode. Unfortunately, no Safe Mode options are available in the boot menu. I have posted about this issue separately.

Thank you for your help with my exe problem! The user has found some workarounds to open documents and the like but is not able to run other work apps and that is no good.

Edited by JennhatesPCs, 10 December 2010 - 06:53 PM.


BC AdBot (Login to Remove)

 


#2 Union_Thug

Union_Thug

    Bleeps with the fishes...


  • Members
  • 2,355 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:is everything
  • Local time:12:37 AM

Posted 10 December 2010 - 11:29 PM

Have you tried this fix?

EXE File Association Fix (Restore default association for EXE files): http://www.dougknox.com/xp/file_assoc.htm (zipped)
EXE (lnk and regfile) Fix for Windows XP: http://www.kellys-korner-xp.com/xp_tweaks.htm




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users