Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

No Dns On Winxp Box


  • Please log in to reply
3 replies to this topic

#1 Dotan Cohen

Dotan Cohen

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:09:49 PM

Posted 03 December 2005 - 10:19 AM

I just set up a home network consisting of a Edimax router, a Fedora Core 4 box and a Windows XP Pro box. The router configuration I did on the linux box, and it accesses the internet just fine.

The windows machine can get online with IP addresses only. I called my ISP and filled in the DNS main and secondary servers in the appropriate places in the router configuration, but the winbox still cannot use domain names, only IP addresses. DNS Client is running, and of course I have tried rebooting the machine.

What must I do to get the windows machine to properly use domain names? Thank you in advance.

Dotan Cohen
http://technology-sleuth.com/short_answer/what_is_hdtv.html

BC AdBot (Login to Remove)

 


#2 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:01:49 PM

Posted 03 December 2005 - 01:37 PM

You left out a little infomation. Are you using DHCP? I assume not since you are setting the DNS manually. Unless you are accessing a server to have internet and LAN service you cannot put anything in the "Domain" field. You should have your "Computer Name" inthe "Host" field in the "DNS" page. If you are using a router check and see if the "DNS" Ip addresses are listed there. My Linksys aquires them. Check them against the ones you ISP provided for you. If they are different you should use the ones you router obtains automaticily. I did. My ISP gave the wrong DNS when I switched over to static from DHCP.
"2007 & 2008 Windows Shell/User Award"

#3 Dotan Cohen

Dotan Cohen
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:09:49 PM

Posted 04 December 2005 - 03:12 PM

On the WAN side, I have a static IP. On the LAN side, the machines are using DHCP as assigned by the router.

The problem was that the winbox wanted to resolve the DNS entries at the router- and I had yet to enter the ISP's DNS servers in the router. I don't know how the linbox was/is resolving dns entries. I'm not abouyt to check, either, until it stops working, though...

So I entered the ISP's DNS servers in the router, and had to reboot the winbox, but now it is resolving. Thank you very much.

#4 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:01:49 PM

Posted 04 December 2005 - 03:20 PM

I'm glad you worked it out. You should only need to input fields on each computer if they are statis. If you are using DHCP the router should take care of that. Using a Statis IP on WAN the ISP should have provided you the DNS. On a Dynamic IP it is assigned automaticily.
"2007 & 2008 Windows Shell/User Award"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users