Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't access Windows 7 in any way.


  • Please log in to reply
2 replies to this topic

#1 R2d

R2d

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:38 AM

Posted 29 November 2010 - 04:38 PM

Greetings,

I turned on my pc only to find it attempting to repair itself and failing numerous times.
If I try to access Windows 7 (32bit) normally, it takes me back directly to the repair options, of which I tried system restore but nothing changed. Safe mode wouldn't boot also, it would restart at some point, even my windows xp installed on another partition would reboot upon reaching the loading screen.

I knew it was probably a virus and I downloaded the kaspersky bootdisk 10 and scanned my computer and cleared a rootkit.win32.tdss virus.

Now I don't directly get into the repair screen, instead the pc reboots when it reaches the Windows 7 loading screen. Same thing with safemode, the pc restarts while loading a CLASSPNP.SYS file.
Windows xp can atleast be started now so I can ask for help.
I already tried bootrec.exe /bootfix in command prompt but I'm still facing the same problem.

Any help is greatly appreciated.

PS: I don't know if it's because I tried system restore while windows was still infected, but it's worth mentioning. Also after clearing the virus the system restore points disappeared.

BC AdBot (Login to Remove)

 


#2 Zuhl3156

Zuhl3156

  • Members
  • 309 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Bensalem, Pa.
  • Local time:02:38 AM

Posted 29 November 2010 - 05:07 PM

Run CHKDSK from the Command Prompt and see if it finds and repairs any bad sectors on your HDD. http://technet.microsoft.com/en-us/library/bb491051.aspx
Use option two: http://www.sevenforums.com/tutorials/433-disk-check.html

Edited by Zuhl3156, 29 November 2010 - 05:10 PM.


#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,265 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:11:38 PM

Posted 01 December 2010 - 11:57 AM

Use the System File Checker tool (SFC.exe) to determine which file is causing the issue, and then replace the file. To do this, follow these steps:

1. Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.
2. Type the following command, and then press ENTER:
sfc /scannow
The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.

To determine which files could not be repaired by the System File Checker tool, follow these steps:

1. Open an elevated command prompt.
2. Type the following command, and then press ENTER:
findstr /C:"[SR] Cannot repair member file" %windir%\logs\cbs\cbs.log >sfcdetails.txt
Note The Sfcdetails.txt file contains details from every time that the System File Checker tool has been run on the computer. The file includes information about files that were not repaired by the System File Checker tool. Verify the date and time entries to determine the problem files that were found the last time that you ran the System File Checker tool.
3. Type the following command, and then press ENTER:
edit sfcdetails.txt
The Sfcdetails.txt file uses the following format:
Date/Time SFC detail

The following sample log file contains an entry for a file that could not be repaired:

2007-01-12 12:10:42, Info CSI 00000008 [SR] Cannot
repair member file [l:34{17}]"Accessibility.dll" of Accessibility, Version =
6.0.6000.16386, pA = PROCESSOR_ARCHITECTURE_MSIL (8), Culture neutral,
VersionScope neutral, PublicKeyToken = {l:8 b:b03f5f7f11d50a3a}, Type
neutral, TypeName neutral, PublicKey neutral in the store, file is missing


If the System File Checker tool cannot repair a file, follow these steps:

1. At an elevated command prompt, type the following command, and then press ENTER:
takeown /f Path_And_File_Name
For example, type takeown /f E:\windows\system32\jscript.dll.
2. Type the following command, and then press ENTER to grant administrators full access to the file:
icacls Path_And_File_Name /GRANT ADMINISTRATORS:F
For example, type icacls E:\windows\system32\jscript.dll /grant administrators:F.
3. Type the following command to replace the file with a known good copy of the file:
Copy Path_And_File_Name_Of_Source_File Path_And_File_Name_Of_Destination
For example, type copy E:\temp\jscript.dll E:\windows\system32\jscript.dll.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users