Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Repair Permissions Doesn't repair


  • Please log in to reply
4 replies to this topic

#1 MaryBet82

MaryBet82

  • Members
  • 454 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:22 AM

Posted 26 November 2010 - 03:13 PM

I ran repair permissions when I had shutdown/logoff and other problems per another post. A long list of permissions were repaired but when I ran verify permissions after the repair there were eight problems still id'ed. On rerunning Repair Permissions the problems were reported as being repaired but they were still there when I checked w/ verify permissions. I also ran repair permissions in single user mode using applejack and the same thing happened.

There are two "user differs, should be 0, user is 95"'s and 6 permissions differ. All are in System/Library/etc.[different folders] and all have Java somewhere in the path. Is there anyway I can repair these? Do I need to?
mac 10.6 on macbook pro
WinXP sp2 on Dell 380 w/ 512 MB RAM- currently dead in the water
WinXP tab ed sp 3 on Thinkpad X41 w/ 1.5 GB RAM - lemony flavored
Win2K Sp4 on Sony VAIO GXR600 w/ 512 MB RAM - currently blue screening

BC AdBot (Login to Remove)

 


#2 Buddyme2

Buddyme2

  • Members
  • 715 posts
  • OFFLINE
  •  
  • Local time:10:22 PM

Posted 26 November 2010 - 10:40 PM

Like these?

Repairing permissions for “Macintosh HD”
Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jconsole.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Classes/jconsole.jar".
User differs on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib", should be 95, user is 0.
Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/lib".
User differs on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Libraries", should be 95, user is 0.
Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Libraries".
Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/deploy.jar", should be -rw-r--r-- , they are lrwxr-xr-x .
Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/deploy.jar".
Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/libdeploy.jnilib", should be -rwxr-xr-x , they are lrwxr-xr-x .
Repaired "System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Resources/JavaPluginCocoa.bundle/Contents/Resources/Java/libdeploy.jnilib".
Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.

Permissions repair complete



Ignore them. From what I can gather online regarding the java permissions, they are pointing to symbolic links rather than to the proper files.

Some other Mac OS X: Disk Utility's Repair Disk Permissions messages that you can safely ignore.

#3 computerxpds

computerxpds

    Bleepin' Comp


  • Moderator
  • 4,514 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:02:22 AM

Posted 26 November 2010 - 10:44 PM

Same here. You are not alone I just checked and i get the same thing.
animinionsmalltext.gif
If I have replied to a topic and you reply and I haven't gotten back to you within 48 hours (2 days) then send me a P.M.
Some important links: BC Forum Rules | Misplaced Malware Logs | BC Tutorials | BC Downloads |
Follow BleepingComputer on: Facebook! | Twitter! | Google+| Come join us on the BleepingComputer Live Chat on Discord too! |

#4 MaryBet82

MaryBet82
  • Topic Starter

  • Members
  • 454 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:03:22 AM

Posted 27 November 2010 - 10:27 AM

Thanks buddyme2 and computerxpds,

Yea, that's pretty much what I have. Glad to know I don't have to do anything.
mac 10.6 on macbook pro
WinXP sp2 on Dell 380 w/ 512 MB RAM- currently dead in the water
WinXP tab ed sp 3 on Thinkpad X41 w/ 1.5 GB RAM - lemony flavored
Win2K Sp4 on Sony VAIO GXR600 w/ 512 MB RAM - currently blue screening

#5 computerxpds

computerxpds

    Bleepin' Comp


  • Moderator
  • 4,514 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:02:22 AM

Posted 27 November 2010 - 10:51 AM

Your welcome! :)
animinionsmalltext.gif
If I have replied to a topic and you reply and I haven't gotten back to you within 48 hours (2 days) then send me a P.M.
Some important links: BC Forum Rules | Misplaced Malware Logs | BC Tutorials | BC Downloads |
Follow BleepingComputer on: Facebook! | Twitter! | Google+| Come join us on the BleepingComputer Live Chat on Discord too! |




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users