Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

The media is write-protected


  • Please log in to reply
1 reply to this topic

#1 Caspersim

Caspersim

  • Members
  • 63 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Global
  • Local time:11:25 PM

Posted 21 November 2010 - 08:09 PM

External 2.5" Seagate Momentus 320Gb HDD.

Recieved from my father-in-law, he says it doesn't work. So I take it and there is no power at all. I take it apart and replace the USB connector and I receive power. However, trying to initialize the disk in computer management windows 7 says "the media is write protected". Computer management labels it as a "CD-ROM", now I don't know if this might be an issue, or it just does that until the disk is initialized. I tried diskpart and modifying 'writeprotect' in the registry but neither worked.

I also loaded up Win XP x64 to try it there, but I received pretty much the same results.

Thanks

Caspersim
"History records that the money changers have used every form of abuse,
intrigue, deceit, and violent means possible to maintain their control over
governments by controlling the money and its issuance."

~ 4th US President James Madison

BC AdBot (Login to Remove)

 


#2 Trezax

Trezax

  • Members
  • 25 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:25 PM

Posted 23 November 2010 - 12:08 PM

Under Windows 7, launch the registry editor (press Windows Logo + R, type regedit, then press Enter). Navigate then to this registry path:

HKEY_LOCAL_MACHINE > System > CurrentControlSet > Control > StorageDevicePolicies

Right click on writeprotect and select modify. Set the value data to 0, then click OK. Do the same with ControlSet001 and ControlSet002. Close the registry editor and restart your system. Try then to access your external storage device.

Edited by Trezax, 23 November 2010 - 12:09 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users