Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox 4 beta 7


  • Please log in to reply
4 replies to this topic

#1 Philip Brampton

Philip Brampton

  • Members
  • 372 posts
  • OFFLINE
  •  
  • Local time:03:43 AM

Posted 11 November 2010 - 04:39 AM

Firefox 4 beta 7 has just been released.
Beautiful interface.
Fast.
But why can't Mozilla produce software that opens smoothly as does IE and Google.This has been an annoyance with version 4 right from beta 1.
It spoils the whole program.
Fortunately beta 6 doesn't suffer the same problem so i am staying with it.
Regards

BC AdBot (Login to Remove)

 


#2 VaynardX

VaynardX

  • Members
  • 121 posts
  • OFFLINE
  •  
  • Local time:03:43 PM

Posted 14 November 2010 - 09:57 AM

^

Well, you can fix the long startup with some firefox tweaks, but yeah, if you're asking for the out-of-the-box fastness when firing it up, it does take time. Have'nt tested that version 4 beta, can you enlighten us some more? What about speed and javascript rendering?

#3 Philip Brampton

Philip Brampton
  • Topic Starter

  • Members
  • 372 posts
  • OFFLINE
  •  
  • Local time:03:43 AM

Posted 14 November 2010 - 11:08 AM

I'm not talking speed,It is great on speed.
What i am talking about is when opening the browser the UI flickers two or three times before it settles.
I trust that makes it clearer
Regards

#4 keyboardNinja

keyboardNinja

    Bleepin' Ninja


  • Members
  • 4,815 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:teh interwebz
  • Local time:01:43 AM

Posted 17 November 2010 - 11:45 AM

Yeah, I've been running the Beta for a while now, and I've noticed the same odd flickering on startup. It's a minor annoyance, but not a dealbreaker. :)
PICNIC - Problem In Chair, Not In Computer

Posted Image Posted Image

20 Things I Learned About Browsers and the Web

#5 Philip Brampton

Philip Brampton
  • Topic Starter

  • Members
  • 372 posts
  • OFFLINE
  •  
  • Local time:03:43 AM

Posted 17 November 2010 - 01:49 PM

Strangely enough it only does it on my windows 7 machine.Beta 7 on my XP computer opens very smoothly.
Roll on the final version.
Thanks for your interest




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users