Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't enter BIOS setup and (un?)related problems


  • Please log in to reply
No replies to this topic

#1 CajunBadger

CajunBadger

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:10:01 PM

Posted 31 October 2010 - 04:42 PM

Sorry for the long one, but want to get all details in!

My laptop is a Dell Inspiron 1521 running Vista Home Prem and WinXP Pro in a dual boot setup.

Seems like I have several problems but wondering if they're related. Initially noticed a problem with my keyboard - a few keys type the wrong character or ("g" types "gt", "h" types "hy", "t" types "gt" and backspace key puts in the current time and date). I've hooked up an external keyboard and it appears the laptop keyboard has a problem. Figure this is resolved since the "g" and "h" keys are typing characters right next to them...just have to replace the keyboard.

I've scanned with Avira and Malwarebyte's MBAM and no sign of infection...

Now for the tougher one - before removing the keyboard to try and clean it, I happened to reboot and noticed the Dell logo had disappeared. It also wasn't doing the preliminary "checks" so I decided to go into the BIOS setup. After hitting the F2 key, it sits for a bit longer than remember and then I get all green hearts on the screen. No BIOS options... I've gone through the steps of removing the battery, disconnecting it from a/c power, disconnecting the CMOS battery, and holding the power button for a minute. When I boot back up it tells me "RTC mode fixed - Time and date may be wrong, Invalid configuration information - please run SETUP program, Time-of-day not set - please run SETUP program, Strike the F1 key to continue, F2 to run the setup utility, Press F5 to run onboard diagnostics" But when I press the F2 key, nothing happens and F1 and F5 don't work either. I end up having to power it down and restart it. Going into Setup, I see the green hearts again.

As a side observation (not sure related or not), if I try to boot into Vista Safe Mode it goes through the motions and results in a blank screen. Trying WinXP in regular and Safe Mode does the same thing...only booting into Vista regular works. I've tried running a repair but the screen goes blank after it finishes loading the Windows files... Not sure this is related, but odd this all seems to be happening at the same time - wondering if BIOS being fubar'd is creating a display issue? Appears this is related - just tried running Acronis True Image to make an image of my install and it gave me "...unable to set video mode 640x480x4..." I'd jump to it being a video/onboard graphic chip issue but I still can boot into Vista... Also tried running Dell diagnostics at boot up and ran fine once, but now I get a 2000-0333 error: "Graphics test timed out waiting for keyboard response." though not sure what keyboard response I'm supposed to give! It flashed through colors continuously and beeps if I don't hit the keyboard on each color - but never seems to stop unless I stop hitting the keyboard (and it finally stops with this error). Grrr....

And lastly, my main battery was showing it was at the end of it's life for charging (indicator was flashing orange to show this), yet oddly enough it's all of a sudden not flashing any more - unless this is related to the BIOS problem? At the moment, knowing bad batteries can create some odd problems so I'm running it straight from a/c with the battery disconnected.

I'm wondering if the CMOS battery could be going bad (about 3 years old)? I had a thought to try flashing the BIOS although if I remember right, it was the most current version. But I'm hesitant if there's a problem and don't want to make the laptop unbootable.

I can live with Vista as is for now, but really want to correct this. Plus concerned if I do try a fresh install, whether I'll run into a blank screen during the installation process - appears so since can't get Windows to load when booting from cd. Any thoughts on what to try - I can order a new keyboard and CMOS battery, but hate to waste money if it's more serious. Help!

Edited by CajunBadger, 31 October 2010 - 04:42 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users