Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot Run... Files Using TaskMgr


  • Please log in to reply
No replies to this topic

#1 Year of Glad

Year of Glad

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:49 AM

Posted 24 October 2010 - 10:57 PM

Here's my situation:

Something happened to my computer, running Vista Home Premium with UAC turned OFF, so that when I start Task Manager (by right-clicking on the taskbar) and then go to File --> New Task (Run), I am not allowed to run any .exe files; it says it can't find the file or that it may be a permissions issue. In the Run... dialog box, there is a shield icon and it says next to that that the item will be created with administrative privileges. (My account is an administrator account in Vista, although I do understand that that is different from the "true" administrator account.)

If I open taskmgr by browsing to the file, right-clicking on it, and opening it using another account on my computer, even one that is NOT an "administrator" account, then choosing New Task (Run) from taskmgr works fine. There's something "wrong" with my particular account that is preventing it from allowing me to use the New Task (Run) option from Task Manager.

Note that I am able to open .exe files normally, whether through shortcuts or by navigating directly to the .exe file by browsing through My Computer.

I am also able to run .exe files by going to Run... from the Start Menu. When I do this, it DOES say that the item will be created with administrative privileges; however, it doesn't give an error. It just opens the appropriate executable.

This might seem a minor deal, but it does cause other error messages; for instance, if I open a PDF by double-clicking it, opening Adobe Reader, after a few moments, I get the "Windows cannot access the specified device, path, or file..." message regarding AdobeARM.exe. Presumably, this is some other .exe that Adobe Reader tries to run and fails for the same reason that tasks run from Task Manager fail. I get the same message regardless of whether I run Task Manager as myself or another user.

What's going on with my task manager? I think for some reason its defaulting to "runasadmin" or something. Can anyone help me out?

EDIT: I also noticed that I have two instances of rundll32.exe running in task manager (when I run it using my normal profile). The command line column says they are both "C:\Windows\System32\rundll32.exe" sysdm.cpl,EditUserProfiles. I'm not sure if this is relevant, although considering it seems tied to User Profiles and I've NEVER noticed it before, maybe it is.

Thanks.

Edited by Year of Glad, 25 October 2010 - 12:37 AM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users