Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

DHCP from router through switch not working


  • Please log in to reply
2 replies to this topic

#1 cbird01

cbird01

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:10:55 PM

Posted 12 October 2010 - 04:44 PM

Our network is a simple windows Workgroup network over hardwired ethernet. Everything is connected to a network switch....I believe this means it is using APIPA for assigning IP addresses to network equipment. We have not assigned static IP addresses nor do we use internet connection sharing.

An IPCONFIG confirms APIPA assignment with computer returning 169.254 IP address.

I would like to use DHCP, so I connected a router to the switch in the following way:


1) Ethernet cable from Port 1 of Router(Buffalo WHR-HP-G54) to Port 1 of switch(ASUS GX-D1081).
2) All computers and printer are plugged in ports 2-8 of switch. (there is no uplink port, just regular ports which all serve as uplinks)

I reset my network adapter on my computer to force it to get a new IP address. It is still being assigned via APIPA(169.254...). I logged into my router and checked the DHCP range and set it to 192.168.11.11 to 192.168.11.99 (I wanted to reserve 2-10 for static addresses). The address of router is 192.168.11.1

I also tried putting the ethernet cable into the WAN port of the router and the computer still got assigned via APIPA. I can not ping the router through the switch.

If I plug my computer directly into the router, then it properly assigns an IP of 192.168.11.11.

I can't seem to allow my Router to assign IP's through my switch. My switch does not have any DHCP abilities like some smart switches - it is just pass through. There is no way to change any settings, so I am sure it is not the switch. They also all have auto MDI/MDIX, so it can't be the need for a crossover cable either. The only thing I can think of is settings on the Router itself.

Any help is appreciated

PS - I want to do this since APIPA is unreliable and I am adding a new Network MFP printer which can not use APIPA - the printer is showing a third network 192.0.0 in subnet 255.255.255.0. I can't assign it an IP in the range of the APIPA addresses, so I want to go DHCP. I also have 6 laptops that attach to this network, which I do not want to manually configure for static IP's :thumbsup: I may want to assign a static IP to the MFP in the range I opened up (2-10) if that makes sense (does it?)

Edited by cbird01, 12 October 2010 - 04:49 PM.


BC AdBot (Login to Remove)

 


#2 cbird01

cbird01
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:10:55 PM

Posted 12 October 2010 - 05:46 PM

Just thought I should add this:

There is nothing else attached to the router and the wireless function is disabled. We get our internet from a wireless mobile card which handles up to 5 simultaneous connections. This takes the 192.168.1 IP range. This network is used for internet only and not for networking purposes.

#3 kennzsniper

kennzsniper

  • Members
  • 142 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:55 AM

Posted 12 October 2010 - 10:56 PM

hmm..

Points to ponder.

1. Say if you were directly connected to the router does it give you a DHCP lease?
2. If you set a static IP address on a computer that is connected to switch and the switch connected to the router. Can you ping the router via 192.168.11.1?
3. How long exactly is the cable between your router and the switch?
4. Your switch, based from my google search is a gigabit switch. I am thinking perhaps you may be experiencing autosensing issues between the router and the switch?
Is there any way to set the switch to 100 full duplex or 10 full duplex for isolation?
Hardware tech when I was in college.
1st job was a network support for SOHO
2nd job was lappy tech
3rd Job way out of my league but its nice...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users