Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Change Default In Windows Explorer


  • Please log in to reply
20 replies to this topic

#1 Troubled1

Troubled1

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Location:Way DownUnder and Outback
  • Local time:02:49 PM

Posted 16 November 2005 - 06:35 PM

Hi there,

Whenever I open Windows Explorer (XP Home Edition), it immediately opens at my hard drive: LOCAL DISK (C:) which means I always have to scroll up to MY DOCUMENTS and click on the Expand Button in order to access my most frequently used files.

How can I change the default path, so that it immediately goes to MY DOCUMENTS?

Hope this makes sense!

Troubled1

BC AdBot (Login to Remove)

 


#2 donzo44

donzo44

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Location:Carnoustie, UK
  • Local time:07:49 PM

Posted 16 November 2005 - 06:59 PM

Hi there,

Whenever I open Windows Explorer (XP Home Edition), it immediately opens at my hard drive: LOCAL DISK (C:) which means I always have to scroll up to MY DOCUMENTS and click on the Expand Button in order to access my most frequently used files.

How can I change the default path, so that it immediately goes to MY DOCUMENTS?

Hope this makes sense!

Troubled1

Hi

Worth reading the link:

http://support.microsoft.com/default.aspx?...;307856&sd=tech

Change the Windows Explorer Default Startup Folder
To change the default startup folder for Windows Explorer: 1. Click Start, point to All Programs, point to Accessories, and then right-click Windows Explorer.
2. On the menu that appears, click Properties.
3. In the Target box, append the "/root" command-line switch to the "%SystemRoot%\Explorer.exe" command, using the startup location that you want. For example, if you want Windows Explorer to start at the root of drive C, edit the command to the following:
%SystemRoot%\Explorer.exe /root, C:\
4. Click OK.

Regards
Dual Opteron 250's, 1.6TB, youngest son still at home, large electricity bill

#3 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:05:49 AM

Posted 16 November 2005 - 08:37 PM

Nice post donzo44 :thumbsup:

Troubled1 - if you want the classic two pane view of Windows Explorer you should change that entry to
%SystemRoot%\Explorer.exe /e, C:\Documents and Settings\<user>\My Documents

-where <user> is your Windows username.

Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#4 Troubled1

Troubled1
  • Topic Starter

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Location:Way DownUnder and Outback
  • Local time:02:49 PM

Posted 16 November 2005 - 09:47 PM


Hi there,

Whenever I open Windows Explorer (XP Home Edition), it immediately opens at my hard drive: LOCAL DISK (C:) which means I always have to scroll up to MY DOCUMENTS and click on the Expand Button in order to access my most frequently used files.

How can I change the default path, so that it immediately goes to MY DOCUMENTS?

Hope this makes sense!

Troubled1

Hi

Worth reading the link:

http://support.microsoft.com/default.aspx?...;307856&sd=tech

Change the Windows Explorer Default Startup Folder
To change the default startup folder for Windows Explorer: 1. Click Start, point to All Programs, point to Accessories, and then right-click Windows Explorer.
2. On the menu that appears, click Properties.
3. In the Target box, append the "/root" command-line switch to the "%SystemRoot%\Explorer.exe" command, using the startup location that you want. For example, if you want Windows Explorer to start at the root of drive C, edit the command to the following:
%SystemRoot%\Explorer.exe /root, C:\
4. Click OK.

Regards



#5 Troubled1

Troubled1
  • Topic Starter

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Location:Way DownUnder and Outback
  • Local time:02:49 PM

Posted 16 November 2005 - 10:32 PM


Hi there,

Whenever I open Windows Explorer (XP Home Edition), it immediately opens at my hard drive: LOCAL DISK (C:) which means I always have to scroll up to MY DOCUMENTS and click on the Expand Button in order to access my most frequently used files.

How can I change the default path, so that it immediately goes to MY DOCUMENTS?

Hope this makes sense!

Troubled1

Hi

Worth reading the link:

http://support.microsoft.com/default.aspx?...;307856&sd=tech

Change the Windows Explorer Default Startup Folder
To change the default startup folder for Windows Explorer: 1. Click Start, point to All Programs, point to Accessories, and then right-click Windows Explorer.
2. On the menu that appears, click Properties.
3. In the Target box, append the "/root" command-line switch to the "%SystemRoot%\Explorer.exe" command, using the startup location that you want. For example, if you want Windows Explorer to start at the root of drive C, edit the command to the following:
%SystemRoot%\Explorer.exe /root, C:\
4. Click OK.

Regards



Thanks for the reply Donzo,

Unfortunately though, it hasn't changed anything. Actually, I tried the same thing quite a while ago. Someone who was computer knowledgable gave me the instructions, but it didn't change anything back then either. So I had always assumed that the instructions were incorrect or perhaps unsuitable for my computer.

So when I went into W.E. Properties this time, the target path was the same as when I made changes way back. This is what was in the target field:


%SystemRoot%\Explorer.exe /root, %HOMEFOLDER%\My Documents

(I didn't add the %HOMEFOLDER% - it must have added that info automatically??)

When I checked out the M'soft Support artice (thanks for the link), I noticed that there was a backslash at the very end of the path. So I went back into W.E. Properties and added a backslash to my path, but it hasn't made any difference either.

Hmm, back to the drawing board??

Troubled1

ps I think I posted an incorrect reply earlier?? sorry for any confusion.

#6 Troubled1

Troubled1
  • Topic Starter

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Location:Way DownUnder and Outback
  • Local time:02:49 PM

Posted 16 November 2005 - 11:16 PM

Hey there Rimmer,

Tried your suggestion as well, but still no change?

In the Properties box, this is what it says in the "Start in:" field ...

%HOMEDRIVE%%HOMEPATH%

... Just thought I would throw that in for speculation??

Troubled1

#7 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:05:49 AM

Posted 17 November 2005 - 12:22 AM

I don't know what the 'Start in' field is for, it doesn't seem to make any difference on my PC. It's the 'Target' field you need to edit.
Have you changed that to - %SystemRoot%\Explorer.exe /e, C:\Documents and Settings\<user>\My Documents ?

Edited by Rimmer, 17 November 2005 - 12:23 AM.


Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#8 Troubled1

Troubled1
  • Topic Starter

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Location:Way DownUnder and Outback
  • Local time:02:49 PM

Posted 17 November 2005 - 12:38 AM

Yes, I have (and replaced <user name> with my Window's user name) but it's not making any difference.

Troubled1

#9 donzo44

donzo44

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Location:Carnoustie, UK
  • Local time:07:49 PM

Posted 17 November 2005 - 06:53 AM

Hi

You are correct it does not work. I never checked it until now.

http://windowsxp.mvps.org/ExplorerParams.htm

Above link suggests the same but this did not work either.

Maybe worked at one time and got 'broken' in SP2? If I come across anything I will reply. Sounds like a registry hack might be the answer.

Regards
Dual Opteron 250's, 1.6TB, youngest son still at home, large electricity bill

#10 donzo44

donzo44

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Location:Carnoustie, UK
  • Local time:07:49 PM

Posted 17 November 2005 - 07:03 AM

Hi Again

This works:

click start then run and type in the following (for example)

explorer /e, g:\mac

Explorer will start up in g:\mac directory.

I'm sure there's a way you could make this a shortcut...........

Regards
Dual Opteron 250's, 1.6TB, youngest son still at home, large electricity bill

#11 donzo44

donzo44

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Location:Carnoustie, UK
  • Local time:07:49 PM

Posted 17 November 2005 - 07:10 AM

And again

Workaround as follows:

Create a batch file with this line(for example)

cmd /c explorer /e, g:\mac


If you don't know how to create a batch file then post reply.

Regards
Dual Opteron 250's, 1.6TB, youngest son still at home, large electricity bill

#12 donzo44

donzo44

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Location:Carnoustie, UK
  • Local time:07:49 PM

Posted 17 November 2005 - 07:18 AM

Hi yet again

Previous post will work for (almost any) directory. Reread your original post so what you need is a batch file containing(for example):

cmd /c explorer /e, c:\Documents and Settings\Bryan\My Documents

Assuming your windows is on drive C:. Change Bryan to whatever your user name is. Save the batch file.

Regards
Dual Opteron 250's, 1.6TB, youngest son still at home, large electricity bill

#13 Troubled1

Troubled1
  • Topic Starter

  • Members
  • 27 posts
  • OFFLINE
  •  
  • Location:Way DownUnder and Outback
  • Local time:02:49 PM

Posted 17 November 2005 - 07:52 AM

Hi

http://windowsxp.mvps.org/ExplorerParams.htm

Above link suggests the same but this did not work either.



:thumbsup: Good stuff Donzo!!! .... above link's suggestion works THANKS to you (& Rimmer) for your efforts, you have saved me from pulling out my hair/

cheers

Troubled1

#14 BanditFlyer

BanditFlyer

  • Members
  • 283 posts
  • OFFLINE
  •  
  • Local time:11:49 AM

Posted 17 November 2005 - 11:45 AM

Hi Donzo,

Stupid question: I rarely use the shell in MS computers - at least it's rare compared to my use of the shell in *nix computers, but...

Whenever I use the command prompt in a Windows PC, I always have problems navigating to folders with names that have spaces in them. I realize that dos has a max folder length of 8 chars, and every now and then I find a tutorial on how to navigate to such files, but I have to search for it each time I need to use it.

M$ should have just stolen the complete naming system from Bell Labs. Then we wouldn't have to worry about how to handle names with spaces in them.

Do have a link to some reference material on how to do the "cd Program Files" or "cd PROGR~8" or whatever the translation is?

Edit for clarity: after reading my question, I realized it needed clarification.

Do you have any links that say how to navigate to folders with spaces in the name, such as the
"Program Files" folder via a command prompt?

Edited by BanditFlyer, 17 November 2005 - 11:57 AM.


#15 donzo44

donzo44

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Location:Carnoustie, UK
  • Local time:07:49 PM

Posted 17 November 2005 - 12:07 PM

Hi

Really desperate to find out? I could have a search as I seem to remember a good link somewhere.....

Meantime why not try Drop to DOS from http://www.hsinlin.com/software/dos.html

Regards

Bryan
Dual Opteron 250's, 1.6TB, youngest son still at home, large electricity bill




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users