Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

The Sacrifice wont download


  • Please log in to reply
2 replies to this topic

#1 HonestAbe

HonestAbe

  • Members
  • 54 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Phoenix Arizona
  • Local time:07:44 AM

Posted 05 October 2010 - 09:17 PM

My L4D2 game wont update to install the new dlc "the sacrifice". My L4D one game did it , and it runns, but my L4D2 game keeps giving me this window that reads "unable to launch game at this time. try again later" or somthing like that. Anyone else got any ideas? ive restarted steam once, my computer twice, and still nothing. Been waiting 4 and a half hours. Come on valve.
"Cogeto Ergo Sum"
I think, therfore i am.
Guns dont kill people, stupid people kill people.

BC AdBot (Login to Remove)

 


#2 nikjerry

nikjerry

  • Banned Spammer
  • 8 posts
  • OFFLINE
  •  
  • Local time:09:44 AM

Posted 07 October 2010 - 06:12 AM

I have read about your this of the problem and want to say that it seems that you have problem in your computer not in your system. I also having the same problem but I have solved that but it was my plug in problem. So I also suggest you the best to check your all of the wires as well as your all of the settings. Hopefully your problem will be solved.

#3 Vaerli

Vaerli

  • Members
  • 582 posts
  • OFFLINE
  •  
  • Local time:07:44 AM

Posted 07 October 2010 - 06:08 PM

I would imagine it might be the Steam servers. They've got to have heavy traffic on them since the L4D 2 update is about 3.5GB. While this may not be their problem, I would think it would be.

Q6600, 4GB g-skill, 8800GT, P5N-D motherboard
Posted Image
My art





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users