Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't Run Windows Update via XP or IE


  • Please log in to reply
2 replies to this topic

#1 disneeze

disneeze

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:42 PM

Posted 04 October 2010 - 10:15 PM

This is a strange one that I'm stumped on...

I can't run Windows update via Windows XP or Internet Explorer. Windows will not initiate Windows Update even though the Automatic Updates service is started. When I try to manually run Windows Update via IE it hangs on "Looking for latest updates..."

I've cleared IE files.
Tried Hotfix 927891.
Verified BITS and AU and Event Log services are running on Auto.
Registered various dlls.
Renamed and cleared SoftwareDistribution folder.

I've also reinstalled the AutoUpdate services as outlined [url="http://"%20http://forums.techarena.in/windows-update/606187.htm"[/url]" target="_blank" rel="nofollow">here.
And ran a batch file to reset the services as outlined [url="http://"%20http://forums.whirlpool.net.au/archive/1155546"[/url]" target="_blank" rel="nofollow">here.

I've found that I can't stop the BITS and WUAUSERV services either from the Services control panel or the CMD line. This is not normal...

Any help would be greatly appreciated. Thanks.

BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,280 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:42 PM

Posted 04 October 2010 - 11:12 PM

Microsoft has an article addressing this, it seems that there is virus that disables this. I would suggest reading this article and trying the repairs that are suggested in it.

http://support.microsoft.com/kb/959894

Edited by Budapest, 04 October 2010 - 11:51 PM.
Moved from XP ~BP

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 disneeze

disneeze
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:42 PM

Posted 05 October 2010 - 11:24 AM

Thanks, dc3, for the link. I have downloaded and ran the Windows Malicious Software Removal Tool, as well as Spybot and Malwarebytes.

Still no luck... Windows Update still hangs and the BITS and WUAUSERV services won't stop.

Any other advice?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users