Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Problem Browsing Secure Sites

  • Please log in to reply
2 replies to this topic

#1 coolbreeze


  • Members
  • 1 posts
  • Local time:01:21 PM

Posted 15 November 2005 - 11:49 AM


Can anyone help? I have a problem browsing secure (SSL) websites. The links don't register at all once the padlock icon is displayed . Any ideas what may be causing this? I'm on XP and my browser is IE6. Don't think I have SP2 installed. I'm on a dial-up connection (Sloooooow). Any help would be appreciated. Thanks.

BC AdBot (Login to Remove)



#2 boopme


    To Insanity and Beyond

  • Global Moderator
  • 72,470 posts
  • Gender:Male
  • Location:NJ USA
  • Local time:09:21 AM

Posted 16 November 2005 - 12:01 AM

First of all welcome to Bleepingcomputer :thumbsup:

Perhaps this will help.
Please try the following:

Click the Refresh button, or try again later.

If you typed the page address in the Address bar, make sure that it is spelled correctly.

To check your connection settings, click the Tools menu, and then click Internet Options. On the Connections tab, click Settings. The settings should match those provided by your local area network (LAN) administrator or Internet service provider (ISP).

If your Network Administrator has enabled it, Microsoft Windows can examine your network and automatically discover network connection settings.

If you would like Windows to try and discover them, click Detect Network Settings
Some sites require 128-bit connection security. Click the Help menu and then click About Internet Explorer to determine what strength security you have installed.

If you are trying to reach a secure site, make sure your Security settings can support it. Click the Tools menu, and then click Internet Options. On the Advanced tab, scroll to the Security section and check settings for SSL 2.0, SSL 3.0, TLS 1.0, PCT 1.0.

Click the Back button to try another link.

How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#3 casandraJEM


  • Members
  • 2 posts
  • Local time:07:21 AM

Posted 16 November 2005 - 05:54 PM

I had the same problems and i found a solution to mine. I had to uncheck an option that was checked in my firewall software to block secure sites in a network. You might want to check if you have any options like that, but i changed mine and it works now. Hope that helps -sandra

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users