Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Generic Host Win32 process error. Common fixes have not worked :(


  • Please log in to reply
1 reply to this topic

#1 bigd18

bigd18

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:28 PM

Posted 02 October 2010 - 09:40 PM

So as I'm working on something online I have a pop up come up and it says "Generic Host Process for Win32 Services" has encountered and error. From what I read online, this is pretty common. I've tried some of the common fixes but so far none of the work. I've tried:

-changing a Registry entry. I think it was like "WhatIsDomain" and I made it false
-I've reset my Winsock
-tried some LSP fixer or something (srry, i don't quite remember the name)
-and I've tried some patch that from Microsoft that is supposed to do it.

But nothing works sad.gif

the error reports content on the error dialog box says "that the following files will be included in the error report :
C:\DOCUME~1\IBM\LOCALS~1\Temp\WER2255.dir00\svchost.exe.mdmp
C:\DOCUME~1\IBM\LOCALS~1\Temp\WER2255.dir00\appcompat.txt

For the error signature on the message it has this (idk if this helps just trying to be through)
szAppName : svchost.exe szAppVer : 5.1.2600.5512 szModName : ntdll.dll
szModVer : 5.1.2600.5755 offset : 00023845


I've also attached a HijackThis log file.
I really hope someone can help me out cuz its a real hassle having online classes when u keep getting kicked off the web
THANKS A TON!!
=============================================
IBM Thinkpad Lenovo R52
Windows XP Pro

Attached Files


Edited by boopme, 02 October 2010 - 10:17 PM.


BC AdBot (Login to Remove)

 


#2 kahdah

kahdah

  • Security Colleague
  • 11,138 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:11:28 PM

Posted 09 October 2010 - 06:41 AM

Hello bigd18

Welcome to BleepingComputer smile.gif
==========================
  • Download OTL to your desktop.
  • Double click on OTL to run it.
  • When the window appears, underneath Output at the top change it to Minimal Output.
  • Under the Standard Registry box change it to All.
  • Under Custom scan's and fixes section paste in the below in bold

    netsvcs
    %SYSTEMDRIVE%\*.*
    %systemroot%\system32\*.dll /lockedfiles
    %systemroot%\Tasks\*.job /lockedfiles
    %systemroot%\System32\config\*.sav
    %systemroot%\system32\drivers\*.sys /90
    %systemroot%\system32\Spool\prtprocs\w32x86\*.dll

  • Check the boxes beside LOP Check and Purity Check.
  • Click the Run Scan button. Do not change any settings unless otherwise told to do so. The scan wont take long.
    • When the scan completes, it will open two notepad windows. OTL.Txt and Extras.Txt. These are saved in the same location as OTL.
    • Please copy (Edit->Select All, Edit->Copy) the contents of these files, one at a time, and post it with your next reply.
====================
Please download Rootkit Unhooker and save it to your desktop.
  • Double-click RKUnhookerLE.exe to run it.
  • Click the Report tab, then click Scan
  • Check Drivers, Stealth Code, Files, and Code Hooks
  • Uncheck the rest, then click OK
  • When prompted to Select Disks for Scan, make sure C:\ is checked and click OK
  • Wait till the scanner has finished then go File > Save Report
  • Save the report somewhere you can find it, typically your desktop. Click Close
  • Copy the entire contents of the report and paste it in your next reply.
Note - You may get this warning it is ok, just ignore it."Rootkit Unhooker has detected a parasite inside itself!
It is recommended to remove parasite, okay?"

Please do not pm for help, post it in the forums instead.

If I am helping you and have not responded for 48 hours please send me a pm as I don't always get notifications.

My help is always free, however, if you would like to make a donation to me for the help I have provided please click here Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users