Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

I have a virus and don't know how to get rid of it


  • Please log in to reply
5 replies to this topic

#1 sunshine77

sunshine77

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:41 PM

Posted 02 October 2010 - 11:57 AM

It seems I have downloaded a trojan (trojanhorse generic19.AHPV,trojanhorse generic19.AFIV and trojanhorse generic19.AGZP a few days ago, I use AVG. When I logged on the other day I had Antimalware Doctor running on my computer as well as program called Major defense System, so i found this site followed the instructions to remove it. I downloaded Malawarebytes and used rkill.com, and I thought I was rid of it but apparently not.

Now I have some other program called"Resident Shield Alert" that pops up all the time, also I have a hard time getting on the internet, someone suggested that i run AVG in safe mode but when i do that I get to safe mode and it only gives me the option to do a IBM recovery, but I assume that would wipe my computer. I decided not to that. To top all that off, when I try to go to control panel I can not get into anything, and when I try to search anything to do with the pop ups and all the stuff i am having issues with, it redirects me to random websites. I had to go to wikipedia to link through to this site for crying out loud!

I am also getting a message that says error in C:\windowssystem32\rundll32.exe missing entry:irprops.cpl,,Bluetooth Authentication Agent when ever I restart. I pretty much use FireFox but I also randomly get a message that says "IE is not your default browser, and asks me to make it my default" but its not even open on my computer. Has someone hacked my computer?

I am not sure what to do? Can someone please help me? I am scared to do anything on my computer

Thanks!

Edited by sunshine77, 02 October 2010 - 12:36 PM.


BC AdBot (Login to Remove)

 


#2 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:12:41 PM

Posted 02 October 2010 - 12:28 PM

Try safe mode again

http://www.malwareremoval.com/tutorials/safemodeboot.php

it only gives me the option to do a IBM recovery


You are pressing F8 too early

Use MBAM to do a scan in safe mode
Chewy

No. Try not. Do... or do not. There is no try.

#3 sunshine77

sunshine77
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:41 PM

Posted 02 October 2010 - 02:49 PM

OK so I did the same thing again and the only 2 options it gave me are Microsoft Windows XP Professional and IBM Recovery, through IBM Recovery was the only way I could go into safe mode, I chose safe mode an it to me to a black screen saying safe mode in the 4 corners then a grey box came up asking me to do an IBM recovery. I tried to go into safe mode both ways through f5 and f8 and i did this about 4 times and i keep getting the same options. What am i doing wrong? I have been in safe mode before, but can;t remeber what it looks like. How do i know when I am in safe mode?I know these seem like silly questions but I am not very computer literate. I ran malwarebytes again and I had this Rootkit Agent, and when I tried to remove it I got a message saying parts of it couldn't be removed. and now that i came back on my IE exporer window keeps popping up like someone else is on my computer running it.

#4 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:12:41 PM

Posted 02 October 2010 - 03:06 PM

I chose safe mode an it to me to a black screen saying safe mode in the 4 corners


That's safe mode
Chewy

No. Try not. Do... or do not. There is no try.

#5 sunshine77

sunshine77
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:41 PM

Posted 02 October 2010 - 03:27 PM

OK, but like I said the only thing that happened was it asked me to do the ibm recovery, the only option it gave me was to run it, exit out or reboot pretty much. I chose to exit and it took me to windows XP start up, I went in windows XP and ran malawarebytes and the only infection it found was a rootkit agent which could not be removed. So how should i proceed from here? Its obvious it is not gone, I keep getting redirected to other websites etc and I am still getting the windows error message. I am not sure what else i should do.

Thank you

#6 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:12:41 PM

Posted 02 October 2010 - 04:59 PM

Please follow the instructions in ==>This Guide<==.

Once the proper logs are created, then make a NEW TOPIC and post it ==>HERE<==

If you can produce at least some of the logs, then please create the new topic. If you cannot produce any of the logs, then post back here and we will provide you with further instructions.
Chewy

No. Try not. Do... or do not. There is no try.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users