Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wireless automatic connection problem.


  • Please log in to reply
35 replies to this topic

#1 bassmann710

bassmann710

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 02 October 2010 - 07:06 AM

Hi everyone. I have an old Dell laptop running XP professional SP3. My problem is that when I set the wireless G PCI card to connect to my home network automatically, it does connect, but packets don't seem able to be received (or sent, I can't remember which). I cannot connect to any website until I disconnect, and then connect manually. Could this be fixed by delaying a service during boot or something? If so, which service(s)? I have other laptops running XP and they do not have any issues connecting wirelessly to the network, so I doubt it's a network problem. Once I connect manually, there are no problems at all. Any ideas? Thanks in advance!

Steve

BC AdBot (Login to Remove)

 


#2 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:04:12 AM

Posted 02 October 2010 - 11:29 AM

Is this a WEP or WPA encrypted network?

#3 bassmann710

bassmann710
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 02 October 2010 - 02:39 PM

Is this a WEP or WPA encrypted network?


WEP.

#4 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:04:12 AM

Posted 03 October 2010 - 04:55 PM

Go to Control Panel -> Network Connections.
Right click on your adapter and click Properties.
Click the Wireless Network tab.
Scroll down the network and click Remove.
Click OK and connect to your wifi network again.

This will reset all the wifi settings for your SSID and make sure it's authenticating correctly. Under WEP if you don't have the correct authentication key it will do as you describe.

#5 bassmann710

bassmann710
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 03 October 2010 - 08:42 PM

Thank you for the fast response. I followed the steps you told me, and I still have the same problem. I did make sure that I double checked the password for the network. The password is correct, but the problem still persists. It happens whenever I try to set the connection to the network to "automatic". The connection seems "frozen" whenever I reboot, or resume from standby. Pretty much whenever the connection is terminated, when it tries to automatically connect again, it gets stuck. But with manual, it has no trouble. I try a ping through command prompt and it returns a "not found" error.

Another detail that might be useful is that when this problem happens, it always says that only 1 packet has been received in the network status window. The fact that this only happens when it is set to "automatic" leads me to believe it has to do with the order some drivers are loaded or the order that some services are started, but this I cannot be sure of.

Any ideas? Thanks.

#6 rockmilk

rockmilk

  • Banned
  • 202 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:12 AM

Posted 03 October 2010 - 10:37 PM

Have you tried THIS hope this helps you. :thumbsup:

#7 rockmilk

rockmilk

  • Banned
  • 202 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:12 AM

Posted 03 October 2010 - 10:39 PM

Have you tried THIS hope this helps you. :thumbsup:

Tutorial for winsock xp found HERE .

Edited by rockmilk, 03 October 2010 - 10:50 PM.


#8 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:04:12 AM

Posted 03 October 2010 - 11:52 PM

Lets test your theory.

Leave it set to automatic, then go into the Network Connections and right click on your wireless connection and click Disable.

Then restart your machine and let all the drivers load. The network will stay disabled, but all the drivers will load. Once you get windows up, open and close a few programs and make sure everything loads into your system tray and stuff.

Then go into Network Connections and click Enable and let it search on Automatic.

Does it connect and run?

#9 bassmann710

bassmann710
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 04 October 2010 - 06:49 AM

Yes. It works fine if I enable the wireless connection (in network connections), with the connection to my network set to automatic (in the wireless network tab), after the computer is done booting and loading all startup programs and services. Thanks for the neat suggestion to test it. I don't think I would have thought of that method. So what does this problem signify now? And should I try the other suggestion that rockmilk said now? Thanks again!

Edited by hamluis, 04 October 2010 - 08:28 AM.
Removed unnecessary quote ~ Hamluis.


#10 bassmann710

bassmann710
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 04 October 2010 - 06:54 AM

Have you tried THIS hope this helps you. :thumbsup:

Tutorial for winsock xp found HERE .


Thank you for the suggestion and link! I will test that in just a bit!

#11 rockmilk

rockmilk

  • Banned
  • 202 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:12 AM

Posted 04 October 2010 - 08:26 PM

How did things go for you?

#12 bassmann710

bassmann710
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 05 October 2010 - 10:00 AM

Well, I'm still having the same problem, even after the Winsock fix that rockmilk provided me with. This really has me stumped. I should note that it doesn't always get stuck on 1 packet received. But it never seems to get over 10, signifying that something is still wrong. Any other ideas? O_O Thanks!

#13 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:12 AM

Posted 05 October 2010 - 10:40 AM

When you are connected to the wireless network can you do the following:

Start then Run type in cmd hit enter. In the black box that appears type in "ipconfig /all >> c:\ipconfig.txt" and then open up ipconfig.txt and copy and paste the contents here.

Of course without the quotes.

Edited by cryptodan, 05 October 2010 - 10:40 AM.


#14 bassmann710

bassmann710
  • Topic Starter

  • Members
  • 35 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 07 October 2010 - 01:04 PM

Sorry for the delay. But here is the contents of ipconfig.txt:
I blocked out the MAC addresses. I hope that's not a problem.



Windows IP Configuration



Host Name . . . . . . . . . . . . : Courtney

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Hybrid

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

DNS Suffix Search List. . . . . . : home



Ethernet adapter Local Area Connection:



Media State . . . . . . . . . . . : Media disconnected

Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controller

Physical Address. . . . . . . . . : censored



Ethernet adapter Wireless Network Connection 2:



Connection-specific DNS Suffix . : home

Description . . . . . . . . . . . : Broadcom 802.11g Network Adapter

Physical Address. . . . . . . . . : censored

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

IP Address. . . . . . . . . . . . : 192.168.1.4

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.1.1

DHCP Server . . . . . . . . . . . : 192.168.1.1

DNS Servers . . . . . . . . . . . : 192.168.1.1

71.242.0.12

Lease Obtained. . . . . . . . . . : Thursday, October 07, 2010 9:17:25 AM

Lease Expires . . . . . . . . . . : Friday, October 08, 2010 9:17:25 AM

Edited by bassmann710, 07 October 2010 - 01:06 PM.


#15 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:09:12 AM

Posted 07 October 2010 - 01:37 PM

You are getting the right IP's addresses, so it is working.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users