Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Dial up and CD Rom Drive


  • Please log in to reply
15 replies to this topic

#1 csigsrfan

csigsrfan

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:41 PM

Posted 30 September 2010 - 01:51 AM

:flowers: Whenever I am online and put in a software or picture cd(ones that I have made from the computer) it will either kick me off then or what a little bit and kick me off. I am about to do a pc recovery but was wondering if there was any way to solve this without on. :thumbsup:
Window XP SP3
PCI DATA Fax SoftModem with SmartCP
Cimpaq Presario SR1603WM

BC AdBot (Login to Remove)

 


#2 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:05:41 PM

Posted 30 September 2010 - 02:22 AM

Did you read some of the guides about slow computers?

http://www.bleepingcomputer.com/forums/topic44690.html

http://www.malwareremoval.com/tutorials/runningslowly.php

Have you added ram to that computer?
Chewy

No. Try not. Do... or do not. There is no try.

#3 csigsrfan

csigsrfan
  • Topic Starter

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:41 PM

Posted 30 September 2010 - 05:15 PM

1,18 RAM
and it is not a slow computer
I have run MsMpEng(anti-virus) malwarbytes and ccleaner

#4 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:04:41 PM

Posted 30 September 2010 - 05:38 PM

How did you make these CDs? What program did you use? It could be there is an autorun.inf file on the CD that runs a task which is causing your DUN to disconnect your modem.

Does it do it with commercialy made data CDs? Like your windows XP disk or a game CD?

#5 csigsrfan

csigsrfan
  • Topic Starter

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:41 PM

Posted 01 October 2010 - 01:59 AM

I just used the computer move to cd. I have used them before without it doing this. YYes I installed a CSI game and it kicked me offline and would not go back online

#6 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:05:41 PM

Posted 01 October 2010 - 04:34 AM

PCI DATA Fax SoftModem with SmartCP


Before broadband became popular, I was a modem enthusiast, your modem uses the cpu for all it's work. They don't make them any cheaper, I admit it was a long shot but needed to be eliminated.
Chewy

No. Try not. Do... or do not. There is no try.

#7 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:04:41 PM

Posted 01 October 2010 - 10:59 AM

I suspect your CDRom is running in PIO mode. When in PIO mode it can use 100% of the CPU. If this happens it leaves no CPU cycles available for running your Softmodem codec, so it disconnects.

If your CDRom supports DMA you can make sure it's enabled. You will need to do this in two places. Compaq sometimes has an option in BIOS setup to enable DMA for ATA devices.

To enter BIOS setup, press F10 when you first see the Compaq logo when you first turn on the computer, before you see the Windows XP logo. Then use the arrow keys on your keyboard and the Enter key to navigate the BIOS setup. Looking for an options to enable DMA or UDMA for your CDRom or ATA controller. Follow the on screen instructions to save your modifications. Warning: Do not change anything else. It is possible to change settings that would make your system unstable to unbootable.

Once you have verified BIOS is set to use DMA mode, boot into your Windows XP and do the following:

1. Click "Start" -> "Control Panel".
2. Click "Classic View" if you aren't in Classic View already.
3. Double-click "System".
4. In the System Properties dialog window, click the "Hardware" tab.
5. Click "Device Manager".
6. In the Device Manager, click the '+' next to "IDE ATA/ATAPI controllers" to expand that section.
7. Double-click the "Primary IDE Channel"
8. Click the "Advanced" tab.
9. Set the Transfer Mode for all devices to "DMA if available".
10. Click "OK".
11. Repeat steps 7-10 for "Secondary IDE Channel" or any other Channels listed in this section of the device manager.
12. Close the Device Manager window and System Properties window.
13. Restart your PC.

#8 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:05:41 PM

Posted 02 October 2010 - 02:09 AM

For dma see this guide

http://forum.imgburn.com/index.php?showtop...dpost&p=967
Chewy

No. Try not. Do... or do not. There is no try.

#9 csigsrfan

csigsrfan
  • Topic Starter

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:41 PM

Posted 03 October 2010 - 02:13 PM

[quote name='Gabrial' date='Oct 1 2010, 10:59 AM' post='1955416']
I suspect your CDRom is running in PIO mode. When in PIO mode it can use 100% of the CPU. If this happens it leaves no CPU cycles available for running your Softmodem codec, so it disconnects.

If your CDRom supports DMA you can make sure it's enabled. You will need to do this in two places. Compaq sometimes has an option in BIOS setup to enable DMA for ATA devices.

To enter BIOS setup, press F10 when you first see the Compaq logo when you first turn on the computer, before you see the Windows XP logo. Then use the arrow keys on your keyboard and the Enter key to navigate the BIOS setup. Looking for an options to enable DMA or UDMA for your CDRom or ATA controller. Follow the on screen instructions to save your modifications. Warning: Do not change anything else. It is possible to change settings that would make your system unstable to unbootable.

I tried that and F10 is System Recovery

#10 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:04:41 PM

Posted 03 October 2010 - 07:52 PM

Try F2, F1, and DEL as well. Compaq has used different keys over the years to enter BIOS.

#11 csigsrfan

csigsrfan
  • Topic Starter

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:41 PM

Posted 05 October 2010 - 04:25 PM

I have tried f1(setup) f2(nothing) Esc(boot menu) I have learned that my BIOS Revision is 3.07 but have not been able to get into BIOS

#12 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:04:41 PM

Posted 05 October 2010 - 05:09 PM

F1 Setup sounds like BIOS setup to me.

#13 csigsrfan

csigsrfan
  • Topic Starter

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:41 PM

Posted 05 October 2010 - 06:45 PM

BIOS on that is grayed out

#14 csigsrfan

csigsrfan
  • Topic Starter

  • Members
  • 176 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:41 PM

Posted 15 October 2010 - 12:03 AM

I suspect your CDRom is running in PIO mode. When in PIO mode it can use 100% of the CPU. If this happens it leaves no CPU cycles available for running your Softmodem codec, so it disconnects.

If your CDRom supports DMA you can make sure it's enabled. You will need to do this in two places. Compaq sometimes has an option in BIOS setup to enable DMA for ATA devices.

To enter BIOS setup, press F10 when you first see the Compaq logo when you first turn on the computer, before you see the Windows XP logo. Then use the arrow keys on your keyboard and the Enter key to navigate the BIOS setup. Looking for an options to enable DMA or UDMA for your CDRom or ATA controller. Follow the on screen instructions to save your modifications. Warning: Do not change anything else. It is possible to change settings that would make your system unstable to unbootable.

Once you have verified BIOS is set to use DMA mode, boot into your Windows XP and do the following:

1. Click "Start" -> "Control Panel".
2. Click "Classic View" if you aren't in Classic View already.
3. Double-click "System".
4. In the System Properties dialog window, click the "Hardware" tab.
5. Click "Device Manager".
6. In the Device Manager, click the '+' next to "IDE ATA/ATAPI controllers" to expand that section.
7. Double-click the "Primary IDE Channel"
8. Click the "Advanced" tab.
9. Set the Transfer Mode for all devices to "DMA if available".
10. Click "OK".
11. Repeat steps 7-10 for "Secondary IDE Channel" or any other Channels listed in this section of the device manager.
12. Close the Device Manager window and System Properties window.
13. Restart your PC.


Thanks. I had to uninstall them to get them back into UDMA mode.
May I please have this topic closed
Again thanks for all the help

#15 DaChew

DaChew

    Visiting Alien


  • Members
  • 10,317 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:millenium falcon and rockytop
  • Local time:05:41 PM

Posted 15 October 2010 - 05:31 AM

Uninstall the IDE/ATA Controller (NOT the Channels!!!) from under the IDE ATA/ATAPI Controllers branch (again in Device Manager) and reboot your PC. Windows will 'find' it again when it boots back up. DMA will be enabled by default.


From my link I posted
Chewy

No. Try not. Do... or do not. There is no try.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users