Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Stop Autoplay from appearing but still execute autorun.inf


  • Please log in to reply
1 reply to this topic

#1 maki2012

maki2012

  • Members
  • 171 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:06:29 AM

Posted 29 September 2010 - 03:54 PM

I crammed it all into the title. Searched google and the BC forums. Most of the results are about disabling autoplay or re-enabling the window.

I want to be able to insert the flash drive and have it run through my autorun.inf file but without the autoplay prompt. My home PC is Win 7, but I'd be using it on many different computers, including those running Vista and XP.
Any ideas?

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,699 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:11:29 AM

Posted 29 September 2010 - 07:28 PM

You simply can't have it both ways.
Basically, disabling autorun is done by creating registry key, which disables autorun.inf:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\IniFileMapping\Autorun.inf]
@="@SYS:DoesNotExist"


My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users