Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Ports will NOT see devices


  • Please log in to reply
3 replies to this topic

#1 smeadows00

smeadows00

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:11:17 PM

Posted 26 September 2010 - 09:14 PM

I am having a dilemma that I cannot figure out. A friend of mine gave me his Compaq Presario 900 notebook to fix for him. The laptop has Windows Home Premium ---{...get this ===> ...with "NO" UPDATES installed at all! }, 40-GB HDD, 128-MB RAM, AMD Athlon 1.53GHz. This laptop has "2 - USB Ports" on the backside of it... He said he thought it was "...too full and could I please wipe it out for him." He also stated he has not been able to get the Unit to get past the Windows welcome screen without locking up. I asked him if he had any Anti-Virus on it and he stated "no." I asked him how long it's been since he last was on his laptop and he stated it's been several weeks since he could even use his laptop.

The first thing I did when I received the laptop was to attempt to boot the Unit. It would not boot up in NORMAL MODE. I then attempted to boot up the Unit in SAFE MODE...which it did. From this point, I began to check out some different things and found that his HDD was in fact NOT FULL...it only had 9.1-GB of data on it --- there was still 31-GB of "free" space left! I began to perform some basic "cleanup" on the laptop so that I could at least -{maybe}- get the Unit to BOOT-UP in Normal Mode. I wanted to be able to get the Unit connected to the Internet so that I could "UPDATE" the OS and load some Anti-Virus so that I could "scan" the HDD, clean it up, and give it back. I was able to perform ALL the following:

~~~ ...get the Unit to BOOT-UP normally...
~~~ ...I fully & completely UPDATED the Operating System to SP/3 (...from No updates installed at all!)
~~~ ...I loaded Norton Internet Securities 2010 and fully updated...
~~~ ...I also loaded Malwarebyte's Anti-Malware and fully updated...

Once I felt satisfied the Unit was fully and completely updated & protected, I again re-booted in "SAFE MODE," I turned off the "System Restore" feature and then I performed "Full & Complete" scans until the Unit was completely clean -{...twice w/NIS 2010 and once w/Malwarebytes...}, I also performed a "DISC CLEANUP" as well as a complete "Defrag" too... Once I was satisfied with this, I turned the "System Restore" feature back on and re-booted in NORMAL MODE.

So...there's what "I" did with the Unit once I gained possession. Now my dilemma begins! I was going to plug in a USB Mouse to use in stead of using the TouchPad -(I hate those!) and the USB Mouse wasn't recognized. I tried to plug in my buddy's Wireless USB Modem and it too, was not recognized. I even tried to plug in a "Gigaware" 4-Port USB Hub and this too was not recognized. Just to be sure the "devices" themselves were okay, I plugged them into my laptop and they were ALL recognized...individually as well as with either the Mouse plugged into the USB Hub or the Wireless USB Modem plugged in...or even both devices plugged into the USB Hub...ALL was recognized on my laptop but, NOT on my buddy's.

I have attempted to locate the issue and cannot. I have "un-installed" BOTH of the "ALi PCI to USB Open Host Controllers and BOTH of the USB Root Hubs and then, the devices are recognized. BUT ONLY FOR THAT SESSION! Once I either "log out" or Shut the Unit down, it's gone and when re-booted, again...NO Recognition of any of the Devices!
It's driving me crazy! For the life of me, I cannot figure this out!

Please HELP!

Thank you in advance for your valuable time & effort on this particular issue...

Have a great day...most of all, be "Blessed!"

<>< Scott Meadows

BC AdBot (Login to Remove)

 


#2 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:11:17 PM

Posted 26 September 2010 - 10:32 PM

Do you have any other unknown devices in your device manager? A missing ACPI driver could do this.

Edited by Gabrial, 26 September 2010 - 10:32 PM.


#3 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:11:17 PM

Posted 26 September 2010 - 10:53 PM

If you can try rolling back to SP2 .
SP3 has a "glitch" that affects some USB that causes the OS to not recognize USB devices.
OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.

#4 smeadows00

smeadows00
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:11:17 PM

Posted 27 September 2010 - 06:30 AM

Gabrial:
Thanks so much for replying! Looking into the Device Manager for "any" items, etc... that may/may not be missing.....The Device Manager shows that everything within the laptop is functional and there are no issue(s), etc...of any kind. What I mean is that there are "NO" items, etc...that is showing any signs of yellow or red...everything shows that it is working properly...I even went so far as to "uninstall" the ALi PCI to USB OHC and install the generic one to see if that would work - ...again, the ONLY time this crazy thing will do anything is if I "un-install" both of the USBs...let it "Scan for any Hardware Changes" then it works...unitl of course I log off or shut the laptop down, then it stops recognizing the USBs again....

Fairjoeblue:
Thank you as well for replying! As far as being able to roll back to "SP/2"...I can't. Unfortunately, one of the things that I have discovered with this particular Update is that once it's loaded...well...it's LOADED! There's NO going back! {...BUT, if someone knows of a "secret" as far as getting this Update to roll it back from SP/3 to SP/2...then...I am ALL ears! }


Thanks again to those that have replied...many "Blessings" upon you today...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users