Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot browse internet


  • Please log in to reply
16 replies to this topic

#1 nano567

nano567

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:03:53 PM

Posted 25 September 2010 - 01:19 AM

Hello,

I have a computer that somehow is connected to the internet but does not let me browse the internet.

its a windows XP Professional

I use a wired connection DSL ethernet with a built-in network adapter not a NIC.
ive checked the wires and tested the DSL box on this computer and it works great.

here is a report on the connection:

IPCONFIG /ALL


Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\user12>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Comp12
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 4:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® PRO/100 VE Network Connecti
on
Physical Address. . . . . . . . . : 00-11-11-30-0A-C7
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.67.214
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

C:\Documents and Settings\user12>

PING 127.1.0
Ping 127.1.0

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\user12>ping www.microsoft.com
Ping request could not find host www.microsoft.com. Please check the name and tr
y again.

C:\Documents and Settings\user12>ping 127.1.0

Pinging 127.1.0.0 with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.1.0.0:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Documents and Settings\user12>

BC AdBot (Login to Remove)

 


#2 Retirednow

Retirednow

  • Members
  • 121 posts
  • OFFLINE
  •  
  • Local time:01:53 PM

Posted 25 September 2010 - 01:32 AM

Click on Start=> Run type CMD to open a command prompt.
In the command prompt type the following commands:

To Reset WINSOCK entries type: netsh Winsock reset catalog and press enter

Reset TCP/IP stack to installation defaults, type: netsh int ip reset reset.log

ipconfig /flushdns
ipconfig /registerdns
ipconfig /release
ipconfig /renew

#3 nano567

nano567
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:03:53 PM

Posted 25 September 2010 - 02:09 AM

Sorry Retirednow i've did those steps twice and it didnt work :thumbsup:

#4 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,696 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:01:53 PM

Posted 25 September 2010 - 11:39 AM

Well, you don't have any connection:

Ping request could not find host www.microsoft.com


Default Gateway setting doesn't exist.

Is it desktop, or laptop?
Wireless, or wired connection?
Any errors in Device Manager?

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#5 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:08:53 PM

Posted 25 September 2010 - 11:53 AM

Sorry Retirednow i've did those steps twice and it didnt work :thumbsup:


After following steps you have to restart pc.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#6 Retirednow

Retirednow

  • Members
  • 121 posts
  • OFFLINE
  •  
  • Local time:01:53 PM

Posted 25 September 2010 - 12:23 PM

On the back of the pc where the network cable is plugged in to the onboard nic, what lights do you see if any?

Open Device Manager and see if there are any red x's or yellow flags next to your network adapter.

Open IE, click Tools, Internet Options, Connection Tab and then the LAN Tab and in the window that opens make sure that all the check boxes are clear, if not clear them and close IE and re-open IE.

Edited by Retirednow, 25 September 2010 - 12:25 PM.


#7 nano567

nano567
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:03:53 PM

Posted 25 September 2010 - 01:48 PM

Well, you don't have any connection:

Ping request could not find host www.microsoft.com


Default Gateway setting doesn't exist.

Is it desktop, or laptop?
Wireless, or wired connection?
Any errors in Device Manager?


thnx for the repply :flowers:
its a desktop, wired connection and there isnt any errors with the device manager :trumpet:

Sorry Retirednow i've did those steps twice and it didnt work :thumbsup:


After following steps you have to restart pc.


Darth ive restarted the PC twice after the two tries :inlove:

On the back of the pc where the network cable is plugged in to the onboard nic, what lights do you see if any?

Open Device Manager and see if there are any red x's or yellow flags next to your network adapter.

Open IE, click Tools, Internet Options, Connection Tab and then the LAN Tab and in the window that opens make sure that all the check boxes are clear, if not clear them and close IE and re-open IE.


thank you retirednow for the help :bike:
i have a green steady light aswell as a yellow steady light
i am checking the the network connections and i have to
they are connected and firewalled
and they have a lock on top of them

once again thanx for the help guys :woot:

#8 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:08:53 PM

Posted 25 September 2010 - 02:54 PM

Can you browse the internet?
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#9 nano567

nano567
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:03:53 PM

Posted 25 September 2010 - 03:31 PM

Nope i cant browse the internet :thumbsup:
its a built-in network adapter and not a NIC so maybe i should replace the whole motherboard? :flowers:

#10 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:08:53 PM

Posted 25 September 2010 - 04:02 PM

set the mtu on your pc to your mtu on your router ok.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#11 nano567

nano567
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:03:53 PM

Posted 25 September 2010 - 04:06 PM

set the mtu on your pc to your mtu on your router ok.



sorry you lost me jeje :thumbsup:
can u explain please?

#12 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:08:53 PM

Posted 25 September 2010 - 04:27 PM

Ive had a bit of a drink right now check your router mtu against your pc mtu.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#13 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,696 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:01:53 PM

Posted 25 September 2010 - 06:59 PM

Since there is no error in Device Manager, you may have on-board NIC going sour.
If that's the case, no, you don't have to replace motherboard.
It's a matter of spending 15 bucks on PCI ethernet card. but...

Let's try some basic troubleshooting....

Make sure, your computer is set to obtain IP address automatically.
1. Go Start>Settings>Control Panel (Vista/7 users: Start>Control Panel)
2. Double click Network Connections (Vista/7 users: Network and Sharing Center)
3. Vista/7 users - From the list of tasks on the left, click Manage network connections.
4. For a wired network connection, right-click Local Area Connection, and then select Properties.
For a wireless network connection, right-click Wireless Network Connection, and then select Properties.
5. From the General tab (Vista/7 users: Networking tab), click Internet Protocol (TCP/IP), make sure it is checked, and then click Properties
6. Click Obtain an IP Address Automatically, and then click OK.

If that doesn't work...
Turn off computer. Disconnect router, and modem from power source for 1 minute. At the same time disconnect ethernet cable as well.
Reconnect everything.
Restart computer.

If that doesn't work, bypass router, and connect computer straight to the modem.

If that doesn't work...
Go Start>Run (Start search in Vista), type in:
cmd
Click OK (in Vista, while holding CTRL, and SHIFT, press Enter).

In Command Prompt window, type in following commands, and hit Enter after each one:
ipconfig /flushdns
ipconfig /registerdns
ipconfig /release
ipconfig /renew
net stop "dns client"
net start "dns client"


Restart computer.

If that doesn't work...
Go Start>Run (Start search in Vista), type in:
cmd
Click OK (in Vista, while holding CTRL, and SHIFT, press Enter).

At Command Prompt, type in:
netsh int ip reset reset.log
Hit Enter.
Type in:
netsh winsock reset catalog
Hit Enter.

Restart computer.


If that doesn't work...
Download, install, and run WinSockFix: http://www.softpedia.com/get/Tweak/Network...inSockFix.shtml (doesn't work in Vista)
Restart computer, and check again.

If that doesn't work...
Download Dial-A-Fix (DAF) (doesn't work in Vista):
http://wiki.lunarsoft.net/wiki/Dial-a-fix#...2C_and_articles

Have XP CD available in case DAF needs a file. Likely not!

Check all boxes on the screen (clear any restrictions if it shows any)
Then click GO!

When the entire page is finished click the HammerHead at bottom to go to the second DAF page.

Here, one at a time, do the below:

Reinstall BITS
Reinstall Windows Firewall
Repair Permissions
Reset networking

Watch for any File not found or other errors and make note as this may lead to the fix!

Restart computer.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#14 Darth sidious

Darth sidious

  • Members
  • 248 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nottingham, UK
  • Local time:08:53 PM

Posted 26 September 2010 - 10:02 AM

set the mtu on your pc to your mtu on your router ok.



sorry you lost me jeje :thumbsup:
can u explain please?


Hi if you have followed broni worksteps and no joy.

Please do an ipconfig and post results from the cmd prompt.

If you still have a 169.xxx.xxx.xxx have all your isp details to hand and reset the router and re-enter all isp details.

The reason i suggested checking the mtu on the router and then setting the mtu on pc to the same is because you can have internet connectivity but not be able to browse the net because the mtu is set too large or too small.
If you log in to your router and under adsl setup or basic setup depends on brand of router there will be a heading mtu 1492 or 1500 or similar this is the max transmission unit size if the pc mtu setting is smaller than router setting then problems may be encountered.

You will need to set mtu on pc to same as on router you can do this using DrTcp link below:

http://www.dslreports.com/drtcp

Restart pc after changes.
HP Compaq 6715b Notebook--AMD Turionx2 2.2Ghz 64 Mobile TL-64--4GB DDR2 667Mhz--Compaq 6715b--fujitsu siemens 500GB sataII Internal, Toshiba 1TB EXT HD Backup--IGP ATI Radeon x1250 128MB--Broadcom a\b\g Wlan adapter built in, Sonicwall TZ100, Dlink DSL 2740b--Windows 7 Ultimate 64-bit and linux ubuntu dual boot--Firefox 4.0 &IE8--Eset Firewall--Nod32 antivirus & Spyware Doctor--Malwarebytes anti malware.

#15 nano567

nano567
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:03:53 PM

Posted 29 September 2010 - 01:43 AM

Well ive tried averything but no avail, so i guess am gonna have to buy an ethernet card to replace the built in one.

I guess i will have to buy a ethernet card to replace the built in ethernet one.

will that be a good idea?

alos thank you guys for all the help i appreciate it :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users