Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Change in Pictures from jpeg to Bitmap (*.bmp)


  • Please log in to reply
19 replies to this topic

#1 sweets

sweets

  • Members
  • 144 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 06:28 AM

It started a couple of days ago for some strange reason a change occured in the way I can save pictures. I don't know why but I'd like to go back to the old way cause I have to keep renaming them in order to save them to a folder on my desktop.
Le t me explain:
Previoulsy, I would come across a picture that I'd like to save, I would right-click on it, click on "Save Picture As...", where I would "Save In: Desktop". The "File name:" would appear in the box as a series of numbers, in the "Save as type:" would be "JPEG", I would save it to my desktop, where I would move it to a folder containing all the pictures I wanted to save.
Now for some unknown reason, when I want to save a picture, in the ""File name:" box appears "untitled" and in the "Save as type:" box below appears "Bitmap (*.bmp)". I Have to rename the picture to be able to save it in a folder on my desktop. I'm familiar with saving pictures, so I know that if I didn't get the entire picture downloaded before saving, the "untitled" would appear, and I would go back, download it again until I was certain the entire picture was there. This i s not the problem because it now happens every time I want to save a picture, and "Bitmap (*.bmp)" appears every time instead of "JPEG" in the "Save as type:" box. If you definitely know why this is happenning please respond as i do not wish to try things based on pure speculation. Please don't blame it the fact that I'm using SP2 and or IE6 because it was working perfectly fine with them just 2-3 days ago. I don't need to go through the time and aggravation of updating to IE8 and SP3 only to find the problem has not resolved, I'm using a dialup connection, so things can be quite slow. I tried several attempts at System Restore, going back several days before this occured, but that didn't work. Thank you
Windows XP Home Edition SP2
IE6
dialup ISP with Netzero
Avast Free ver 5.0.677

Attached Files



BC AdBot (Login to Remove)

 


#2 Eraser23

Eraser23

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Local time:07:00 AM

Posted 24 September 2010 - 06:52 AM

Please try the following link below for numerous answers to your question, they might help. The article is titled: Internet Explorer does not save graphics files in the proper format.

When you click the Save Picture As button for a graphics file in Microsoft Internet Explorer, you may be able to save the file only as a .bmp file even if the file is in another format (such as GIF or JPEG). The file name may also appear as "Untitled."


Microsoft Help

Try some of the methods listed on that page, and post back if you're still having problems.

#3 sweets

sweets
  • Topic Starter

  • Members
  • 144 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 07:26 AM

If you read my post, just 3 days ago I was saving pictures as jpeg, so why would it be Microsof to blame? Have you had this same problem?

#4 Eraser23

Eraser23

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Local time:07:00 AM

Posted 24 September 2010 - 07:33 AM

If you read my post, just 3 days ago I was saving pictures as jpeg, so why would it be Microsof to blame? Have you had this same problem?


If you read the link, a possible cause is that the Temporary internet files are to blame, which might have got full over the past 3 days.

#5 sweets

sweets
  • Topic Starter

  • Members
  • 144 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 09:04 AM

Thank you but that did not work I had tried that and other cleaning procedures beforehand

#6 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 11:50 AM

IE 6.0 you say?

Well, it is a known issue. Here is the solution you are most likely looking for:

Internet Explorer saves images as bitmaps (.bmp Files)

Pay special attention to the section 3 that I have bolded below:

Summary:
When you save an image in Microsoft Internet Explorer, the image is saved by default as a bitmap (.bmp). You do not have the option to save the image by using an extension other than .bmp. You experience this behavior even when the image uses a different format (such as .gif or .jpeg).

For example, when you right-click an image on a Web page, and then click Save Picture As, the file name that appears in the File name box is Untitled, and the file type that appears in the Save as type box is Bitmap (*.bmp).

Cause:
This behavior may occur if a damaged program file (for example, an ActiveX or Java object) is downloaded to the SystemRoot\Downloaded Program Files folder on your hard disk.

Resolution
To troubleshoot and resolve this behavior, empty the contents of the Temporary Internet Files folder, and then delete the files in the Downloaded Program Files folder that are listed as either Unknown or Damaged. To do so:

1. Start Internet Explorer (if it is not already started).
2. Empty the contents of the Temporary Internet Files folder. To do so:

1. On the Tools menu, click Internet Options.
2. Click the General tab.
3. Under Temporary Internet files, click Delete Files.
4. When you are prompted to delete all temporary Internet files, click OK.

3. In the Downloaded Program Files folder on your hard disk, remove the files that are listed as either Unknown or Damaged. To do so:

1. On the Tools menu, click Internet Options.
2. Click the General tab.
3. Under Temporary Internet files, click Settings.
4. Click View Objects.
The list of program files that are downloaded to the SystemRoot\Downloaded Program Files folder on your hard disk appears in the Downloaded Program Files window.
5. In the Status column, note the files that are listed as either Unknown or Damaged. Remove these files. To do so, right-click the file, and then click Remove.
6. When you are prompted to confirm the removal, click Yes.
7. Close the Downloaded Program Files window, and then click OK two times.

4. Save an image in Internet Explorer to test and determine if the issue is resolved.

If the issue continues to occur after you remove all downloaded program files that are listed as Unknown or Damaged, try removing the other downloaded program files that are on the list.

Note: The next time that you need one of the files that you removed from the Downloaded Program Files folder, you will receive a prompt to download the file to your hard disk in Internet Explorer.

If you follow these steps, and the issue still occurs, move the Temporary Internet Files folder to a new location. To move the folder, follow these steps:

1. Start Internet Explorer.
2. On the Tools menu, click Internet Options.
3. On the General tab, click Settings under Temporary Internet files.
4. Click Move Folder.
5. In the Browse for Folder dialog box, select a new location for the folder, and then click OK.
6. Click OK to close the Settings dialog box.
7. When you receive the following warning message, click Yes:

Windows will now log you off to finish moving Temporary Internet Files.
Do you want to continue?
(All other changes have been saved.)
Windows automatically logs you off of the computer.

8. Log back on to the computer.

Applies to:
* Microsoft Internet Explorer 6.0, when used with:
o Microsoft Windows XP Home Edition
o Microsoft Windows XP Professional
o Microsoft Windows XP Media Center Edition
o Microsoft Windows XP Tablet PC Edition
o Microsoft Windows 2000 Advanced Server
o Microsoft Windows 2000 Datacenter Server
o Microsoft Windows 2000 Professional Edition
o Microsoft Windows 2000 Server
o Microsoft Windows NT Server 4.0 Standard Edition
o Microsoft Windows NT Server 4.0, Terminal Server Edition
o Microsoft Windows NT Workstation 4.0 Developer Edition
o Microsoft Windows Millennium Edition
o Microsoft Windows 98 Second Edition
o Microsoft Windows 98 Standard Edition
* Microsoft Internet Explorer 5.5

Edited by Gabrial, 24 September 2010 - 12:02 PM.


#7 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:06:00 AM

Posted 24 September 2010 - 12:15 PM

I would say its time to perform some much needed windows updates, and upgrade to IE7 or IE8.

#8 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 12:27 PM

I would say its time to perform some much needed windows updates, and upgrade to IE7 or IE8.


He said not to say it was because he was using IE6. I agree, but some people can't be bothered to be having things like browsers without security holes that will let things like malware into their systems. Just saying.

Edited by Gabrial, 24 September 2010 - 12:28 PM.


#9 sweets

sweets
  • Topic Starter

  • Members
  • 144 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 12:35 PM

Once again, the problem has nothing to do with IE6 or SP2

#10 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:06:00 AM

Posted 24 September 2010 - 12:43 PM

You still need to update there is no reason you should be surfing the net on an outdated machine. Also Windows XP SP2 is no longer supported by Microsoft. You need to apply SP3 and update the rest of your computer to maintain support from Microsoft. You are putting your computer and your valuable files and data at risk of infection and at risk being totally wiped clean by an infection. Even if you do not think that the issue is not because of IE6 and SP2 the benefits updating your machine out weigh anything you can say about IE6 and SP2.

#11 sweets

sweets
  • Topic Starter

  • Members
  • 144 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 12:51 PM

And you know for a fact I need SP3 & IE 8 to avoid this? What about my Avast 5.0.677? Dos this not protect me? I have dialup and it would take forever to update. Dont want to bother with the disk. This is just Micrtosoft's way of keeping you spending $$$. If you know for a fact I would surely like to know of where you speak. Thanks

#12 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 12:54 PM

Did you follow the instructions I sent you? The problem isn't with IE6, but how it handles damaged active-x or other "plugins". Sweets, can you post a screen shot of your Objects window and I'll tell you which ones to delete to resolve your issue.

#13 cryptodan

cryptodan

    Bleepin Madman


  • Members
  • 21,868 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Catonsville, Md
  • Local time:06:00 AM

Posted 24 September 2010 - 12:55 PM

It doesn't matter what I say you need to keep your computer well maintained regardless of how slow your connection is. Your AV is only the first line of defense against viruses and other malware. IE6 and SP2 are very exploitable, keeping your computer updated should be any ones main priority when it comes to computing. WHo know what other programs you have that are not updated. Do you use Adobe Reader, and if so what version, do you use any office suites, and what not? I had Dial up as well way back when, yet I still managed to keep my computer fully updated even though it took me a day to install the updates.

A well maintained computer makes for a happy user and computing experience.

#14 hamluis

hamluis

    Moderator


  • Moderator
  • 56,290 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:00 AM

Posted 24 September 2010 - 01:50 PM

Dan...

Any user has the right to increase the chances of being infected by known malware...by refusing to install critical security updates.

Let it go :thumbsup:.

And...we won't bother pointing out that IE 6 is no longer the browser of choice for many websites and that it's been that way for a few months.

Louis

#15 Gabrial

Gabrial

  • Members
  • 468 posts
  • OFFLINE
  •  
  • Local time:01:00 AM

Posted 24 September 2010 - 02:58 PM

And you know for a fact I need SP3 & IE 8 to avoid this? What about my Avast 5.0.677? Dos this not protect me? I have dialup and it would take forever to update. Dont want to bother with the disk. This is just Micrtosoft's way of keeping you spending $$$. If you know for a fact I would surely like to know of where you speak. Thanks


Avast will protect you from known threats in it's database. I just removed malware yesterday from a machine that none of the 36 antivirus programs on virscan.org knew about.

And posting that you are using IE 6 and asking for help is in itself opening yourself to exploitation. Someone could easily point you to a url , saying "here's your fix", which exploits the well known holes in IE 6 to infect you with malware specifically crafted just for you. There is nothing you could do to protect yourself from that except update your IE and other windows updates.

If I seem paranoid, it's because I am, and for good reason. I clean viruses off computers in real life in exchange for money. If you live near me, please don't update. You'll be calling me soon and paying me to fix the problem instead of getting my help here for free. :D

Edited by Gabrial, 24 September 2010 - 02:59 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users