Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem installing intellipoint for sidewinder x5


  • Please log in to reply
5 replies to this topic

#1 gorydragon

gorydragon

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:06:35 PM

Posted 23 September 2010 - 03:07 PM

My Sidewinder X5 arrived today, and after i downloaded and tried to install the intellipoint software for it, during installation i get this message:

Posted Image

So I hit OK and this comes up

Posted Image

So I hit OK again and get yet another error window

Posted Image

Once I hit OK there, it just goes back to the first message warning me about compatibility issues and the process repeats as many times as i click ok or until i quit.
I thought i would download i8042prt.sys just so the program would delete it and move on, but to my surprise i8042prt.sys DOES exist on my computer under C:\Windows\System32\drivers\
what can i do to be able to be able to get this program to work so i can get full functionality out of my sidewinder x5? oh, and this is on my computer running windows 7 home premium 64-bit.
ps. i wasn't sure if this went in external hardware or software sry :thumbsup:

Thank you so much for your help!

BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,277 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:35 PM

Posted 24 September 2010 - 09:47 PM

If you have experience in making changes in the registry and are comfortable doing so you can disable i8042prt. These are drivers for the PS/2 mouse and keyboard.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt

If you make a mistake while making changes in the registry you can render your computer into a door stop. For this reason, I suggest that you back up the registry prior to making any changes. ERUNT is a good program for this purpose.

[*]Please use the following link and scroll down to ERUNT and download it.
http://aumha.org/freeware/freeware.php
[*]For version with the Installer:
Use the setup program to install ERUNT on your computer
[*]For the zipped version:
Unzip all the files into a folder of your choice.
[/list]Click Erunt.exe to backup your registry to the folder of your choice.

Note: to restore your registry, go to the folder and start ERDNT.exe

Edited by dc3, 24 September 2010 - 09:50 PM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 gorydragon

gorydragon
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:06:35 PM

Posted 03 October 2010 - 11:15 AM

well i see that folder in the registry what value do i change to disable it?

#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,277 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:35 PM

Posted 03 October 2010 - 11:47 AM

I should have thought of this the other night. Look in the BIOS and see if there is a means of disabling the PS/2. This is the safer way to do this, so give this a try first, if the BIOS doesn't provide a means for this, then we can do the registry edit.

All it takes is one mistake when editing the registry and your computer will become a doorstop.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,277 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:35 PM

Posted 03 October 2010 - 12:04 PM

If you can't disable it in the BIOS, then use these instructions.



1. Click Start, and then click Run.

2. In the Open box, type regedit, and then click OK.

3. Locate and then click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\i8042prt

4. In the details pane, double-click Start.

5. In the Value data box, type 4, and then click OK.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#6 gorydragon

gorydragon
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Local time:06:35 PM

Posted 03 October 2010 - 03:16 PM

there was no option to disable PS/2 in my bios so i went ahead and changed the registry value, but i got the same exact sequence of errors as before. i think its worth noting i've never been able to get a PS/2 device to work on my M4A785TD-V EVO mobo, but i've just assumed it was because the devices were too old and not compatible with modern equipment/windows 7.
do you think it would it would be worth a try to boot into an ubuntu live session, copy i8042prt.sys onto a flash drive and delete it from my hard drive? or will i need a clean install of windows 7 to get it to work...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users