Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

PS2 - USB not working


  • Please log in to reply
1 reply to this topic

#1 hoboque

hoboque

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Arizona
  • Local time:09:58 AM

Posted 20 September 2010 - 12:40 PM

Trying to help an elderly friend with 8.04 Linux I installed on his system about 8 months ago and he has had no problems.
Recently his mouse stopped working, then his keyboard.
I can enter BIOS, but cannot reset it because of keyboard not working.
The computer is an older model but I'm unsure of the brand, the motherboard is Intel entry server S845WD1-E.

I have tried 3 other "working" ps2 and usb mice and keyboards and they don't work.
I have installed a new usb card but that did not work.
I've tried "working" memory and swapped sticks.
I have used a usb to ps2 converter with no luck.

After trying the above and several suggestion from various support sites, including Intel, I finally cleared CMOS, removing the battery and also reset jumpers.
I can still enter Setup but of course can't reset the BIOS due to keyboard.
I can't use the keyboard to change the boot sequence to CD-ROM first so can't use Live CD of Linux, to troubleshoot.
I can use his HD on my system just fine.

I suspect the motherboard is going out, but still have hope.
This couple is elderly and fixed income so I'm trying to milk it for all I can (I do this for a hobby not money).

I will try a "working" ps2 card.
I will run memck on memory with another computer.

Any thoughts? Thanks

Edited by hoboque, 20 September 2010 - 12:41 PM.


BC AdBot (Login to Remove)

 


#2 MrBruce1959

MrBruce1959

    My cat Oreo


  • BC Advisor
  • 6,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:10:58 AM

Posted 20 September 2010 - 06:14 PM

Hello and welcome to Bleepingcomputer.

What you should do open the computer case and examine the location of where the PS2 mouse and PS2 keyboard ports are and see if these are connected directly to the motherboard or if they are connected through a wire harness.

Some older computers had the PS2 connectors on a riser mounted to the computer case and were connected to the motherboard via a ribbon wire which is plugged into the motherboard.

If this is the case with this computer, the connector on the motherboard can become a victim of corrosion or oxidation, disconnecting these connectors and re-connecting them can eliminate this problem

Now on the other hand, if your PS2 connectors are directly mounted on the motherboard, this procedure will not be possible, since the connectors are directly soldered to the motherboard.

So in this case, there may be a problem with the motherboard.

As for the USB ports also not working, this could be caused by a setting in the BIOS utility that you are having trouble entering, if the USB is not enabled in the BIOS it will not allow those ports to work.

I am assuming in this post, that your keyboard is a PS2 type keyboard.

If I am incorrect, please let me know.

Bruce.

Edited by MrBruce1959, 20 September 2010 - 06:18 PM.

Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
 
My Career Involves 37 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users