Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

LAPTOP can't PING PC through LAN/ROUTER


  • Please log in to reply
4 replies to this topic

#1 Seemos Yantra

Seemos Yantra

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:12:13 PM

Posted 17 September 2010 - 09:56 PM

First of all, thanks for taking your time in visiting this post. On with the problem:

I have a PC and a Laptop, both with WindowsXP Profesional SP3, and the very same version of CIS running. I have tried to connect to the Laptop from my PC and it SEEMS to work, as we can share files, and even play certain games via direct LAN link or through a Router (Rise Of Nations). However in some games, we experiment certain problems. For example, in Diablo 2, when the PC hosts the game and the laptop atempts to join, the laptop is unable to find the PC's IP (it displays "Cannot contact server"). However, if the laptop hosts, the PC can instantly connect to it without problem or delay. More puzzling is the fact if the PC pings the computer, it shows it has delivered the packets properly. However, the laptop cannot ping the PC for some unknown reason, stating that all the packets are lost. More troubling: the event log of the CIS Firewall on the PC lists the IP of the Laptop attempting to connect and automatically blocking it without warning or prompt.

I have basically configured both the laptop and the PC myself as I own both, so I am wide sure that there no other firewalling software meddling in the affair of both. I have tried several different things, but none have worked. The only difference between the configuration of both the CIS on the laptop and the PC are that the one of the laptop is plainly "out-of-the-box" while the one of the PC is very slightly tweaked here and there. Additionally, I am adding here an screencap of the Comodo Internet Security/Firewall/Network Security Policy/Global Rules on the PC:

Posted Image

And the one from the LAPTOP:

Posted Image

The LAPTOP is configured in spanish, mainly but, as you can see, the configuration is technically identical. Both computers have been tested connected through a router and through direct LAN link, and the results are exactly the same. Both have normal connectivity to the internet and, as I said, can share files without problems. So, if someone can grant me a hand, I will deeply thank you.



BC AdBot (Login to Remove)

 


#2 JamesFrance

JamesFrance

  • Members
  • 283 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:France/Spain
  • Local time:07:13 PM

Posted 18 September 2010 - 01:40 AM

As CIS 2011 has been released this week, I would suggest that you install it on both computers and see if the problem persists.

As CIS 2011 has a special Gaming Mode together with much improved usability, I think you would find it a great improvement.

Your Global Rules are the same, so it is probably something in Application Rules, unless you are connected to LAN 2.

Edited by JamesFrance, 18 September 2010 - 01:42 AM.

James

#3 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:12:13 PM

Posted 18 September 2010 - 08:19 AM

So far, from 3 different forums (included the one of COMODO itself), is the smartest reply I have received. However, I was wondering what do you mean with "LAN 2"? I searched Wikipedia uselessly for such a term. In the other hand, if you are meaning that if our computers were connected directly by the LAN cable instead of passing through a router, well, yes, that has been the case in most tests of this issue. I have tested the problem with the computers connected through a router and then connected to each other directly. The result was the same.

Edited by Seemos Yantra, 18 September 2010 - 08:28 AM.


#4 JamesFrance

JamesFrance

  • Members
  • 283 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:France/Spain
  • Local time:07:13 PM

Posted 18 September 2010 - 11:23 AM

I was just thinking that one computer has not allowed Local Area Network 2, so if that is the one you are using when you connect you maybe need to use the Stealth Port Wizard on that computer to trust the other one so that it can connect properly.
James

#5 Seemos Yantra

Seemos Yantra
  • Topic Starter

  • Members
  • 39 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Chorrillos, Lima
  • Local time:12:13 PM

Posted 18 September 2010 - 12:25 PM

I was just thinking that one computer has not allowed Local Area Network 2, so if that is the one you are using when you connect you maybe need to use the Stealth Port Wizard on that computer to trust the other one so that it can connect properly.


Thanks for the input. I "managed" to solve the problem by doing as you said: installing the latest version of CIS. It seems the problem laid on how Local Area Network #1 was configured when my first CIS installation detected it, or so I think. Curiously enough, even when the settings seem to be putted now on their default, the Global Rules section now seems to have more than 5 different block rules instead of the lonely 1 of the previous CIS, yet the PING finally works and I was able to host the Diablo 2 game. I would like to say the problem is solved (as it is, apparently), but it still bugs me that I don't really know what exactly was wrong. Anyway, from all the suggestions, it was yours the most smart from the beginning, and the one that worked. Thank you very much, JamesFrance.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users