Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Workgroup Serious Errors


  • Please log in to reply
2 replies to this topic

#1 tomgriffin944

tomgriffin944

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Local time:01:59 PM

Posted 08 November 2005 - 12:38 PM

I have tried all i can to get these two computers talking but they just wont, so i have decided to come and get some quality expert help. (I love u genius's)

They are two windows Xp Pro computers linked with a netgear router which ISNT the problem. They both have Zone Alarm firewalls but these have been disabled (for the times im trying to rectify this problem.) The problem is directly linked to microsofts problem article 318030 http://support.microsoft.com/kb/318030/ (mine is the third of the symptoms in the list.)
I have completed EVERYTHING related to this article and it still wont work. Computer 1 can sometimes see and access Computer 2 but can ALWAYS open the workgroup page. Computer 2 can NEVER open its workgroup page and if I type run: \\192.168.0.2 (Computer 1's IP address) it again tells me that it ISN'T accessible. To be honest I don't even know what information to provide you with so you can help me.

After a long time fiddling I came across an article which said 'never use the network setup wizard more than once.' I have DEFIANTLY broken this rule many times. I really don't know what to do but know EVERY other time i've come pleading for help i've ALWAYS been left with a smile by you guys. I just hope this one is fixable too. Just so you know the computers CAN ping each other so its to do with microsoft is my guess.

Any help that i'm given will need to be aimed at an amateur. please understand my mistakes. (Which i'm sure is the root cause of the problem)

Thank you, Tom.

Edited by tomgriffin944, 08 November 2005 - 12:42 PM.


BC AdBot (Login to Remove)

 


m

#2 Rimmer

Rimmer

  • Members
  • 2,159 posts
  • OFFLINE
  •  
  • Location:near Sydney, Australia
  • Local time:04:59 AM

Posted 08 November 2005 - 08:48 PM

While we both wait for the quality expert help to arrive I'll share my experiences, with a view to helping.
I had a similar problem although with one PC XPPro and one PC XP Home. I did fix the problem.
I don't know what fixed it. I just tweaked anything I could see in XP Pro under security policy (Control Panel / Administrative Tool / Security Policy / Local Profiles / Security Options /) that looked like it would block access.

These were the "solutions" I found then, they are cut and paste, the comments are not mine. Who knows, they might give a hint:

1.Experts Exchange re Windows 2003 Server:
Check the Local Security Policy and see who has the 'Access this computer from the network' right. If the users trying to access the share do not have this you will receive the error message you are seeing.


2.Tech Support Forum - Win2000Pro
Well, since I doubt you're logging into a domain, perhaps the question is slightly misleading. You need to make sure that in Users & Passwords that there is an account that matches the name/password of the remote machine with privileges to access the shared resources. If you log into a machine with:

Name: John Doe
PWD: abcde

You need to have an account on the machine with the shared resources that has the same name and password, and permission to access the shared resources.


3.FROM:http://www.windowsitpro.com/Article/ArticleID/24000/24000.html

I also got the "Logon failure: the user has not been granted the requested logon type."

My main problem was trying to Connect my Windows XP Home edition to the computer running Windows XP Professional. The Professional version has lots of security where Home version does not. The Professional to Home worked fine.

To fix it, I went to Control Panel -> Administrative Tools -> Local Security Policy, then under Security Settings, Local Policies, Security Options. I went to the entry "Network access: Sharing and security model for local accounts". Right clicked and selected properties and change the setting to "Classic - local users authenticate as themselves". I then had to create an account on the computer I was trying to access (Professional version) with the same name as the computer I was using to access. The password should be the same, but can be different (you will have to type the user name and password each time you access networked computer). Under "User rights Assignment" the first entry is "Access this computer from the network". Make sure it at least includes "Administrator"

I only found this solution though 8 hours of investigative work. This web page sent me in the right direction and the rest I got from the Microsoft support web site (all free). Lots of detailed reading. I hope this will help someone who is having similar problems.

The above is for Windows XP Professional. If you use Windows XP Home you should not have any trouble.

Thanks, Brian Wills


4. ditto
I fixed this by setting up the share and ensuring that 'Everyone' appeared when clicking the permissions button, then clicking on the security tab. Click on Add...and then type 'Everyone' in the Enter the Object Names box.

This then allowed everyone on the network access the the folders.


5.www.goodtechsys.com/sshcommonerrors.htm
1385 Logon failure: the user has not been granted the requested logon type at this computer.

This error means that the user has not been granted the requested logon at the computer the telnet server service is running. Make sure that all the users including domain users have the permission "Log on locally" on the host where the SSH service is running. Grant this permission to all SSH users, locally, where the SSH server is running.

6.Geeks to GO:
Resolution: The users do not have permission to connect to the remote computer. To resolve this problem: on the remote computer, select Administrative Tools>Local Security Settings>Local Policies>User Rights Assignment, right-click on Access this computer from the network>Properties>Add Users or Groups, add everyone or any users you want to be able to access the computer from the network.


7.www.jsifaq.com "JSI FAQ"

0992 SMB message signing will slow network performance.

Server(s):
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManServer\Parameters
Add Value names as type REG_DWORD:
EnableSecuritySignature and RequireSecuritySignature
Set both values to 1 (enable). The default is 0 (disable).
Restart your server.
NOTE: It is important that both values has the same setting.

Workstation(s):
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Rdr\Parameters
Add Value names as type REG_DWORD:
EnableSecuritySignature and RequireSecuritySignature
Set both values to 1 (enable). The default is 0 (disable).
Restart your workstation.
NOTE: It is important that both values has the same setting.


8.From The TechGuide Forum. http://www.thetechguide.com/forum/lofivers...p/t9932-50.html
I am running 2 machines. A desktop as my Server (running Server 2003) and a laptop as my client (running Windows XP Sp1). Im running ADSL (Alcatel 4 port ethernet modem) with a wireless Linksys WRT54G router.

My laptop is running with a wireless care and my server is directly connected via cat5 into the wireless router. I was able to ping and communicate with each other, I could also access the files from my server to the laptop but could not access files from my laptop to the server. I kept getting that bloody "may not have permissions to access this resource" microsoft crap.
I enabled NetBIOS over TCP/IP on both machines, I then went to my server (Which was the one i couldnt access) and added the "everyone" permission in the security tab. (Dont try adding it to the permissions tab. It doesnt work!)


9.Also from The TechGuide Forum:
The solution:
Assuming all other (obvious) networking issues have been addressed (ie. usernames AND passwords setup for both users on both machines, NetBIOS enabled for TCP/IP, permissions granted for shares etc.)...

1.) In Windows Explorer, from the tools menu, select "Map Network Drive...".

2.) Select an appropriate drive letter and enter the path to the shared resource (\\machine\share).

3.) And here's the trick... Click on "Connect using a different user name.

4.) You'll notice that the Connect As... dialogue indicates the default username that will be used - probably the same name as your user folder under Documents and Settings. Enter the correct username and password for this shared resource and you should be networking happily.

Note: If you're not using DHCP with a DNS on the network, a suitably written hosts file in \<WIN>\system32\drivers\etc can help speed up finding shared resources.

10.Another one:
A solution to the problem of not being able to browse a PC in the workgroup even though you can see it on XP. For all those who have been using the map network drive as another user this is a proper solution.

1. Right click my computer and choose manage

2. Go to Local Users and Groups\Users

3. Double click on Guest

4. select member of, click on add and choose administrators

5. You also need to make sure that guest account is enabled in control panel\users

This should work for everyone but be aware that its only advisable when you trust all computers on the network such as at home because admin privelidges are set for any computer on the network. If this is the case you could create a new group with the restrictions you want.

11.And another:
My solution was simply that one of the XP machines didn't allow access to its system without a password. However, there was no password set on the machine.

I changed the security policy (Control Panel / Administrative Tool / Security Policy / Local Profiles / Security Options / Limit Local Account Use of Blank Passwords to Console Login Only) from Enabled to Disabled.

Hey it worked for me.

12. It's endless:
Simple file sharing, the only method on Windows XP Home and one of two choices on Windows XP Professional, always uses the Guest account. (Classic file sharing also automatically uses the Guest account if the original logon request fails.) If access through the Guest account is inhibited, then sharing cannot work, except when logging on to XP Professional with classic file sharing through another account.

There is a user rights policy to deny network access to certain users and groups, which contains a SUPPORT user and often, perhaps by default, Guest. If Guest is included here, guest access from other computers will not be possible and yields the error message, "Logon failure: The user has not been granted the required logon type at this computer.". Double-click on the policy and remove Guest from it.

For network access to Windows XP Pro with classic file sharing (Simple File Sharing disabled) through the Guest account, the Guest account has to be enabled on Windows XP and network login for the Guest account has to be permitted in Computer Management, Local Users and Groups.

:thumbsup:

Edited by Rimmer, 08 November 2005 - 08:55 PM.


Soltek QBIC, Pentium 4 3.0GHz, 512MB RAM, 200GB SATA HDD, ATI Radeon 9600XT 256MB, Netgear 54Mb/s WAP, ridiculously expensive Satellite Broadband
Windows XP Home SP2, Trend Micro Internet Security, Firefox, Thunderbird, AdAwareSE, Spybot S&D, SpywareBlaster, A-squared Free, Ewido Security Suite.

#3 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:12:59 PM

Posted 08 November 2005 - 08:51 PM

I am going to list some suggestions. Not knowing what you have done I am sure I will list things you have don't. Just ignore them, but tell me what you have done.

1) Loggin under Admin

2) Select the folder/drive you wish to share, right click and select Sharing. Set the level of sharing that you wish. On a LAN without Port Forwarding I feel password protecting is a little much and cumbersom. I would recommend sharing a folder instead of a drive.

3) Make sure Print and File Sharing are turned on in your Network Properties.

4) In Network Properties select obtain IP automaticly, DNS automaticly.

5) In your router make sure it is set to DHCP. If you are running a staic LAN none of this applies.

6) Once everything has been configured turn everything off. Unplug the modem, router, and turn the computers off along with any print servers yu may have.

7) Do the following in the order listed.

Wait 1 minute after everthing is turned off

Turn the Modem on, and wait for 1 min.

Turn the Router on and wait for 1 min.

Turn you computers and any other network device on.

The wait between devices is to allow the modem and router to obtain information so that it can allocate IP addresses (DHCP).
POST your results. With the error message I think you need to set the premissions to your folders/drives while signed in under Admin.

Edit: typos

Edited by acklan, 08 November 2005 - 08:53 PM.

"2007 & 2008 Windows Shell/User Award"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users