Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

New modem won't play nice with router.


  • Please log in to reply
8 replies to this topic

#1 BenGalaxy

BenGalaxy

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:07:22 PM

Posted 08 September 2010 - 07:51 PM

Hi all,

Equipment: Linksys WRT54G2 router, Arris TM602G cable modem.
OS: Windows 7 Home Premium 64-bit
ISP: Cox Communications

Problem: I recently moved and when Cox came to set up my cable/Internet, they gave me a new Arris TM602G modem. Everything was working great at the old house with the old modem, but now I lose connectivity every day and need to reset my router to regain it. This affects both wired and wireless connections.

This happens every day. Upon bootup, the computer will spend a minute or two searching for the network and then eventually fail, reporting that it connected to 'Unidentified Network' and I have no Internet access.

Additionally, I often lose the ability to access my router's configuration page. This happens on a different schedule than the connectivity loss and happens multiple times per day. I enter in the router's IP address into my browser and I get back the 'Cannot display the webpage' error, although I do still have Internet access when this occurs.

Steps tried: ipconfig /release and /renew doesn't work. It gets hung up on renewing and then gives me the error 'Unable to contact DHCP server.'
Plugging the ethernet cable into a different port doesn't work (and the problem affects wireless as well).
Bypassing the router and plugging straight into the modem works just fine.
So far, unplugging and re-plugging the router is the only fix that restores connectivity.

This sounds to me like it has to be a DHCP issue, but I don't know enough to know specifically what the problem is or how to fix it.
Here's the log of my ipconfig /all just after resetting my router when all is working:
JUST AFTER RESETTING ROUTER:
Windows IP Configuration

Host Name . . . . . . . . . . . . : Jeremys
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : oc.cox.net

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : oc.cox.net
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 00-1F-BC-08-88-AD
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::3c81:2172:37f8:897e%11(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.101(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Wednesday, September 08, 2010 8:10:46 AM
Lease Expires . . . . . . . . . . : Thursday, September 09, 2010 5:45:05 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DHCPv6 IAID . . . . . . . . . . . : 234889148
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-12-90-84-E4-00-1F-BC-08-88-AD

DNS Servers . . . . . . . . . . . : 68.105.28.11
68.105.29.11
68.105.28.12
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.oc.cox.net:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : oc.cox.net
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e74:10b1:1c29:b944:4088(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::10b1:1c29:b944:4088%13(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled

I notice that DHCP enabled is set to No on the two Tunnel adapter settings. Is my modem perhaps set up with a static IP address?

Thanks for the help.

BC AdBot (Login to Remove)

 


#2 kennzsniper

kennzsniper

  • Members
  • 142 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:22 AM

Posted 09 September 2010 - 03:17 AM

Sounds like regular MAC address authentication issue experienced with the ISP.

Please do the MAC address cloning on the router and power cycle so that your ISP does not kick you off every time it wants to authenticate.
Hardware tech when I was in college.
1st job was a network support for SOHO
2nd job was lappy tech
3rd Job way out of my league but its nice...

#3 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:10:22 PM

Posted 10 September 2010 - 11:09 AM

Try disabling IPv6 : http://support.microsoft.com/kb/929852 (Fixit 50444)

Edited by Romeo29, 10 September 2010 - 11:10 AM.


#4 BenGalaxy

BenGalaxy
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:07:22 PM

Posted 17 September 2010 - 10:36 PM

Thank you for the ideas. Unfortunately neither of these worked. I also tried changing the IP address of my router to 198.162.2.1, which also did not work. After each step I power-cycled both the router and modem. I'm still having the exact same issue.

Any other ideas out there?

I'm not sure if this is relevant, but I noticed on my router's configuration status page that the Subnet mask is listed there as 255.255.248.0, whereas everywhere else it's listed as the standard 255.255.255.0. I'm attaching a screenshot.


Posted Image

Edited by BenGalaxy, 17 September 2010 - 10:37 PM.


#5 tommy28

tommy28

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Local time:10:22 PM

Posted 17 September 2010 - 11:20 PM

Yes, this is relevant. Your router has a subnetted class A outside public ip address, and according to your previous post of your ipconfig output, your default gateway (router) ip address is supposed to be 192.168.1.1. Have you tried hitting the dhcp release and renew button that I see in your router screen shot?

#6 BenGalaxy

BenGalaxy
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:07:22 PM

Posted 17 September 2010 - 11:43 PM

I've done ipconfig /release and /renew from an elevated command prompt, tommy28, but I can't recall if I tried it from the router config page. I don't think it would matter which method I used though, would it? When doing it from a command prompt it hangs for awhile and then gives me the 'Unable to contact DHCP server' error.

Regarding the IP address, yes in my original post the router's IP address was set to 192.168.1.1, but I changed it to 192.168.2.1 to see if that would fix matters. So currently it's set to 2.1, and it's handing out IP addresses to clients starting with 192.168.2.100.

And right now I have Internet access but I can't log onto my router. I can ping it just fine but am unable to access the configuration page by typing in 192.168.2.1 into my browser.

#7 NpaMA

NpaMA

  • Members
  • 635 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Memphis, TN
  • Local time:11:22 PM

Posted 19 September 2010 - 12:33 PM

Try doing the DHCP renew/release that the above poster stated. Yes it is a different, doing it on your PC only refreshes your LAN IP for that PC, doing it on the router should renew your real internet-IP.

Do you have a proxy enabled in your browser?

#8 BenGalaxy

BenGalaxy
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:07:22 PM

Posted 22 September 2010 - 10:49 PM

OK I tried that and the issue persists.

No there is no proxy enabled.

#9 BenGalaxy

BenGalaxy
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:07:22 PM

Posted 28 September 2010 - 01:23 AM

<bump>

Still having this issue. The only fix that works is unplugging the router and plugging it back in. That works temporarily--all works fine for awhile, then a few hours after resetting the router I lose the ability to access my router's configuration page, although I do still have Internet access on my computer. And then once my DHCP lease runs out I lose all Internet access until I reset the router.

I am utterly stumped on this one. Any other ideas out there?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users