Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

"Custom dll libraries are being loaded" message


  • Please log in to reply
2 replies to this topic

#1 smak451

smak451

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Local time:02:56 PM

Posted 02 September 2010 - 03:06 AM

Hey guys -- I keep getting this message that "Custom dynamic link libraries are being loaded for every application." The string is C:\Windows\system32\guard64.dll. After digging around it's related to Comodo Firewall -- I'm running Win7 x64, and am sure I didn't install the 32 bit version - in fact I was looking specifically for a good 64 bit native firewall. Does this present any problems to worry about? Thanks a lot, -- S

BC AdBot (Login to Remove)

 


#2 Driesiooo

Driesiooo

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Local time:02:56 PM

Posted 02 September 2010 - 01:14 PM

I readed a solution on: http://forums.comodo.com/bug-report-cis/cu...l-t56839.0.html

#3 smak451

smak451
  • Topic Starter

  • Members
  • 59 posts
  • OFFLINE
  •  
  • Local time:02:56 PM

Posted 02 September 2010 - 06:28 PM

I readed a solution on: http://forums.comodo.com/bug-report-cis/cu...l-t56839.0.html



Thanks D, I also looked at this but I guess I don't understand what the solution is? Granted I'm no programmer, but it's unclear to me what exactly the fix is? I get the uneasy feeling this is going to be a real pain in the neck to resolve.

He says in the post:

"I installed EMSI AntiMalware .... rebooted... still the message was gone!
I then installed Comodo Firewall... and boom the "Custom Dynamic Link" error returned only now it listed in the details StringCount 1 and pointed me to "C:\Windows\system32\guard64.dll" ... I finally had tracked it down!

I then found this thread and decided to post this here since my previous google searches didn't help me locate the cause!

So now at least I know its comodo doing it... but... if they are indeed using LoadAppInit_DLLs to inject it ... why is it still not defined in "AppInit_DLLs"?

Is this some leftover flipping of the flag that it no longer used by comodo?

Edit: upon closer inspection I found that "AppInit_DLLs" has a blank space inserted in there after the comodo install... is that the cause of all this? Perhaps the hook used to be injected in there and they removed it but left a space character (the official separator that is to be used in that key entry)"

Sounds like possibly removing the space he's referring to might be the solution? First I'll try to reinstall the latest version downloaded from Comodo and hopefully they've fixed it (though I'm doubtful). Thanks again. -- S




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users