Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How can i make my custom run commands use flags?


  • Please log in to reply
6 replies to this topic

#1 Surma

Surma

  • Members
  • 140 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sweden
  • Local time:01:28 PM

Posted 29 August 2010 - 01:39 PM

I have been using this article to customise my run commands. I am trying to execute the command " "C:\Documents and Settings\HP_Ägaren\Lokala inställningar\Application Data\jagexlauncher\bin\JagexLauncher.exe" runescape ", however it says that it cannot find the file. When i remove the last line (thats called a flag, right?) it executes, but the application requires the line to know what application to launch (cause it says that it cant load the parameter file) so it doesnt work. Is there possibly a value i could add to the key which specifies the flags to be used?
---My computer---
Manufacturer:HP Pavilion 061 CPU:Intel Pentium 4 640, 3200 MHz (16 x 200) RAM: 1024MB Motherboard:Asus PTGD1-LA Chipset:Intel Grantsdale i915P HDD:Main256GB Ext512GB Video:Radeon X600 Series Internet:DSL 2mb/s OS:Windows XP Home Edition SP3 Firefox+IExplorer AVG Internet Security

BC AdBot (Login to Remove)

 


#2 Retirednow

Retirednow

  • Members
  • 121 posts
  • OFFLINE
  •  
  • Local time:04:28 AM

Posted 29 August 2010 - 08:51 PM

I think you have to use either the "-" or the "+" sign without the quotes just before the runescape flag. Do not use the quotes around the flag.
Hope this helps.

Edited by Retirednow, 29 August 2010 - 08:52 PM.


#3 Surma

Surma
  • Topic Starter

  • Members
  • 140 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sweden
  • Local time:01:28 PM

Posted 30 August 2010 - 02:29 AM

Does not work, and i copy-pasted the line from the shortcut. I added the quotes to be clear that the last line was part of the command, but i dont have them in the value, of course.
---My computer---
Manufacturer:HP Pavilion 061 CPU:Intel Pentium 4 640, 3200 MHz (16 x 200) RAM: 1024MB Motherboard:Asus PTGD1-LA Chipset:Intel Grantsdale i915P HDD:Main256GB Ext512GB Video:Radeon X600 Series Internet:DSL 2mb/s OS:Windows XP Home Edition SP3 Firefox+IExplorer AVG Internet Security

#4 Surma

Surma
  • Topic Starter

  • Members
  • 140 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sweden
  • Local time:01:28 PM

Posted 05 September 2010 - 08:57 AM

Ive been searching high and low for a solution, but either no one has ever had the idea of running something with flags or it simply isnt possible. I have NOT done any syntax errors or anything like that. Ive checked so many times that i can rule that out.
---My computer---
Manufacturer:HP Pavilion 061 CPU:Intel Pentium 4 640, 3200 MHz (16 x 200) RAM: 1024MB Motherboard:Asus PTGD1-LA Chipset:Intel Grantsdale i915P HDD:Main256GB Ext512GB Video:Radeon X600 Series Internet:DSL 2mb/s OS:Windows XP Home Edition SP3 Firefox+IExplorer AVG Internet Security

#5 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:12:28 PM

Posted 05 September 2010 - 09:30 AM

This article explained things a little clearer for me:

http://www.online-tech-tips.com/computer-t...nds-in-windows/

I always thought that a forward slash before the final word, would do it, obviously not.

There are always shortcuts, I suppose.

#6 Surma

Surma
  • Topic Starter

  • Members
  • 140 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sweden
  • Local time:01:28 PM

Posted 05 September 2010 - 10:12 AM

already found that one, and it provides nothing to help me solve my issue.

I have decided to go for the simple solution, copypaste the shortcut to the windows dir.

I would, however like to specify what i mean. I was trying to make a registry entry, which would lead to "C:\Documents and Settings\HP_Ägaren\Lokala inställningar\Application Data\jagexlauncher\bin\JagexLauncher.exe" runescape
Note that runescape uses something called jagexlauncher.exe to start, which needs to be told what to do, which is what the last word is. its like the -s part of shutdown -s. Apparently this isnt accepted by whatever means windows uses to carry out the instructions. I dont think that adding any additional symbol before the flag will solve anything. I think that i need a separate value that defines the flag to be used.
---My computer---
Manufacturer:HP Pavilion 061 CPU:Intel Pentium 4 640, 3200 MHz (16 x 200) RAM: 1024MB Motherboard:Asus PTGD1-LA Chipset:Intel Grantsdale i915P HDD:Main256GB Ext512GB Video:Radeon X600 Series Internet:DSL 2mb/s OS:Windows XP Home Edition SP3 Firefox+IExplorer AVG Internet Security

#7 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:12:28 PM

Posted 05 September 2010 - 10:21 AM

I know exactly what you mean.

If the registry key is written correctly, there should be no reason why it doesn't work for you.

I'm more of a 'point and click' person - probably due to laziness. :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users