Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Disabling a 2nd bootable hard drive in a nForce 2 Motherboard


  • Please log in to reply
11 replies to this topic

#1 videobruce

videobruce

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Local time:04:45 AM

Posted 27 August 2010 - 04:13 PM

Details;
nForce2 motherboard (Abit NF7-S V2),
XP Pro w/ sp3 (but I doubt it matters),
IDE hard drives on the same bus,
Non RAID setup,
SATA ports not used,2nd IDE channel has a Optical drive on it.

There is the entry in the Bios to set any of the four IDE devices to "None", but doing so has no affect upon the next boot in the Bios. The drives still show up in the boot screen, so I doubt it's a Windows issue.

I have two bootable drives (1st partition each), and want to isolate one or the other (only on occasion) for different reasons, but I would rather not go through the hassle of opening up the case and pulling th cable(s). :thumbsup:
Anyone else have this issue?

Edited by videobruce, 27 August 2010 - 04:14 PM.


BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,264 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:01:45 AM

Posted 27 August 2010 - 07:37 PM

There is the entry in the Bios to set any of the four IDE devices to "None", but doing so has no affect upon the next boot in the Bios. The drives still show up in the boot screen, so I doubt it's a Windows issue.


I have two bootable drives (1st partition each), and want to isolate one or the other (only on occasion) for different reasons, but I would rather not go through the hassle of opening up the case and pulling th cable(s). :thumbsup:
Anyone else have this issue?



When you make the changes in the BIOS, do you click save before closing the BIOS?

I'm not sure what your objective is with the two bootable drives. Do these two different drives have different operating system? If this is the case and you just want to change which one boots, you can change this in System Properties. Go to Start, right click on My Computer> Advanced. Under Startup and Recovery click on Settings. You will see the first option is Default operating system. You can click on the down arrow to expand the choices, expand this and click on the operating system that you want to boot from, and then reboot.

Edited by dc3, 27 August 2010 - 07:37 PM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 videobruce

videobruce
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Local time:04:45 AM

Posted 28 August 2010 - 07:40 AM

When you make the changes in the BIOS, do you click save before closing the BIOS?

Yes, save & close as always.

I'm not sure what your objective is with the two bootable drives. Do these two different drives have different operating system?

If one goes down I have a backup (for starters among other reasons). Same O/S on each.

and you just want to change which one boots

That is not the issue. The Bios is ignoring the "None" state setting of that drive that is set in the Bios. It sees the drive no matter what. I'm assuming it's some lame flaw in the Bios firmware (possible because of age) and hoped someone had a workaround.

#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,264 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:01:45 AM

Posted 28 August 2010 - 09:24 AM

There is a very simple solution if you just want the second hdd to be there as a backup unit, disconnect the data and power connections.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 videobruce

videobruce
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Local time:04:45 AM

Posted 28 August 2010 - 09:39 AM

The 2nd partition of each drive is used for storage. I would loose that.

#6 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,264 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:01:45 AM

Posted 28 August 2010 - 09:47 AM

Then why do wish to take it out of the list of drives in the BIOS, this doesn't make sense to me.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#7 videobruce

videobruce
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Local time:04:45 AM

Posted 28 August 2010 - 09:52 AM

To troubleshoot one or the other drive as far as the O/S and/or programs goes. I have had issues with one drive affecting the other, usually when installing the O/S.

#8 MrBruce1959

MrBruce1959

    My cat Oreo


  • BC Advisor
  • 6,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:04:45 AM

Posted 28 August 2010 - 10:47 AM

To troubleshoot one or the other drive as far as the O/S and/or programs goes. I have had issues with one drive affecting the other, usually when installing the O/S.

Hello I can follow your concerns here.

The problem you are faced with is as long as your BIOS sees both drives, the OS you try to install on one drive will also see the other drive and attempt to interact with it.

As much as I'd like to say I found a work-around for this, I have found that the only solution is to disable the other drive during the procedure, this can be done by disconnecting the power connector to the other drive.

As much as I have tried to do this through the BIOS setup utility, I have found it does not work this way.

The other problem you are faced with, is you can not hot swap hard drives, doing so will cause your system to reboot or shut down.
SO basically you are stuck with having to shut the computer down and plugging in the power wire or removing it.

Sorry, I wish I could offer you a better solution, but to my knowledge, it is not possible, unless one of the drives is in an enclosure using a USB port.

Bruce.
Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
 
My Career Involves 37 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:

#9 videobruce

videobruce
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Local time:04:45 AM

Posted 28 August 2010 - 01:18 PM

the OS you try to install on one drive will also see the other drive and attempt to interact with it.

Since I have run into this years ago, I will disconnect one drive during the initial install, then reconnect it later after I have imaged a working partition. That is after, say, a new drive was installed and I had the case open anyway. Not a big deal, But to re-install a O/S (same or different), it's a PITA to open up some cases.

On my current MB (nForce5) it allows disabling/enabling SATA channels/controllers and the auxiliary IDE controller (which I do all the time (very successfully) with little issue. Since this does have a "None" option, I don't know why it doesn't work.

Edited by videobruce, 28 August 2010 - 01:18 PM.


#10 MrBruce1959

MrBruce1959

    My cat Oreo


  • BC Advisor
  • 6,377 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Norwich, Connecticut. in the USA
  • Local time:04:45 AM

Posted 30 August 2010 - 11:37 AM

So even though you choose none the drive is still being detected as though you have it enabled.

I am wondering if your BIOSes drive auto-detection feature is over-riding this selection and thus re-detecting the drive again.

What happens when you save the settings and re-boot and re-enter the BIOS again, does the drive show up again in the BIOS once you saved the none option and re-booted?

Bruce.
Welcome to Bleeping Computer! :welcome:
New Members: Please click here for the Bleeping Computer Forum Board Rules
 
My Career Involves 37 Years as an Electronics Repair Technician, to Which I am Currently Retired From.

I Am Currently Using Windows 10 Home Edition.

As a Volunteer Staff Member of Bleeping Computer, the Help That I Proudly Provide Here To Our BC Forum Board Membership is Free of Charge. :wink:

#11 Eyesee

Eyesee

    Bleepin Teck Shop


  • BC Advisor
  • 3,539 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:In the middle of Kansas
  • Local time:03:45 AM

Posted 30 August 2010 - 11:52 AM

Im wondering if the way the drives are jumpered has anything to do with it
Are they set as master/slave or cable select
Just a thought
In the beginning there was the command line.

#12 videobruce

videobruce
  • Topic Starter

  • Members
  • 66 posts
  • OFFLINE
  •  
  • Local time:04:45 AM

Posted 31 August 2010 - 06:33 AM

So even though you choose none the drive is still being detected as though you have it enabled.

Correct. "None" has no effect.

I am wondering if your BIOSes drive auto-detection feature is over-riding this selection

"Auto" is another setting, "Manual" is the third.

What happens when you save the settings and re-boot and re-enter the BIOS again, does the drive show up again in the BIOS once you saved the none option and re-booted?

AFAIK it does still show.

Im wondering if the way the drives are jumpered has anything to do with it
Are they set as master/slave or cable select

M/S. I can't 'hide' either drive. Master or Slave.

This use to be my MB before I sold it 2+ years ago. I never used the Bios provision of changing the boot order within the Bios since originally I didn't know it was there.
Previously with my past MB's I used a toggle switch of change the jumper settings between Slave and master via cables to plugs I made to fit in where the jumper would of gone. This worked fine. The only thing I would have to power down (cold boot) for it to take effect. When I discovered the feature, I just left things alone and never tried it until now. The Bios handles the boot order just fine.

I just wish I knew what they meant by the term "None". :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users