Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

keyboard inputting wrong characters


  • Please log in to reply
3 replies to this topic

#1 bigdaz

bigdaz

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:uk
  • Local time:04:26 PM

Posted 24 August 2010 - 04:01 AM

Hey, i run XP and am having an issue with my keyboard not inputting the correct character on certain keys when shift is held down. This same thing happens when i use either keyboard a basic PS/2 and a USB Steelseries Merc Stealth which i install drivers for.
Some examples of the problem are pressing shift + 2[top row] should input " but inputs @ : Shift + 3 should input pound sign but instead inputs # : shift + @ should input @ but instead inputs "
I have tried removing all my drivers through divice manager and rebooting letting xp reinstall ect, removing all my usb keyboard drivers and software and reinstalling ect still the same issue with both keyboards, exactly. At first i thought that because i am based in the UK and my USB keyboard is from the US that was the issue but its the same problem with my standard PS/2 keyboard which got me thinking that it can only be somthing related to XP or some settings in XP.
Any help as always welcome, thanks in advance.

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,698 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:02:26 PM

Posted 24 August 2010 - 01:48 PM

It looks like your keyboard layout is for US.
Change it to UK: http://www.conversationexchange.com/resour...language.php#xp

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#3 bigdaz

bigdaz
  • Topic Starter

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:uk
  • Local time:04:26 PM

Posted 24 August 2010 - 03:14 PM

Thanks for the help Broni you were spot on with that, all sorted now many thanks, you would not believe how irritating that problem was especially as none of my keys would input sign at all and being from the UK it was a constant pian. All sorted now though so thanks again.

#4 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,698 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:02:26 PM

Posted 24 August 2010 - 03:17 PM

You're very welcome Posted Image

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users